Keyboard KeySwap Problem

I have a simple problem...
******************************************************************************************
On my keyboard, a few keys seem to have swapped...
When I press the " key, I get a @ and viceversa
I get a # instead of a (backslash) and I can't type the (bakslash) character!
A few more keys seem to have swapped places
******************************************************************************************

I was using the same keyboard on Win 98 SE and it was working perfectly fine (just plug and play)
On XP however, I encountered this problem when I just plugged in my keyboard. In vain, I tried to download a few drivers. There don't seem to be too many drivers for my keyboard anyhow.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
I have a "Vesta" keyboard (Now that wasn't too informative!)
Its a PS2 keyboard and not a USB device
It is a multimedia keyboard (It has special keys like volume and mail apart from the normal keys)
The manufacturer's disk seems to be corrupt.
On the reverse side of the keyboard, there are 2 stickers:
- (Some barcode and number) + KM-2501PUSA QC OK / ENGLISH / MADE IN CHINA
- "Plaese download A/P from www.driver333.com.tw" (I tried visiting the website)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I would appreciate it if you could pinpoint the problem (driver?, keyboard itself?, virus?) and generate a solution for it.

Regards,

Ram
LVL 2
ram_einsteinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

InteraXCommented:
The keyboard language is wrong.
Goto control panel-> Regional and Language Options
Select the Languages ta at the top and then click on the Details button.
Add the correct language for the keyboard you use and delet the incorrect language.
You may need to reboot your pc after, but the language should work correctly.

Good Luck!
;-)
0
MusicManCommented:
With reference to your first problem, and in addition to InteraX's comment.  The problem you are having is because you have a UK keyboard set to US.
0
MusicManCommented:
First problem??? - forget that bit!
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

aelroyCommented:
Nice Work MusicMan and InteraX!

Amos - The Keymaker
0
InteraXCommented:
UK KB set to US, agreed.
Or vice versa....

;-)
0
InsolenceCommented:
The answer they provided sounds correct in your case ram, those two sound like they have seen this problem before... but if that doesn't work for ya, I had this same problem with one of my ps2 keyboards, only to find out someone spilt water into it a few days earlier, so the contacts were randomly touching other ones.  I took it apart, seperated the layers, and dried it out with a hair dryer, and it's like new!  =P  Just sharin' my experiences.  =P

 - Insolence
0
Kyle SchroederEndpoint EngineerCommented:
Is this the driver you used:
http://www.driver333.com.tw/driver/KEYBOARD/km-kd-kr-kf-kl/1006/driver_v3.11.exe

The website (http://www.driver333.com.tw/kmdrfl.htm) indicates you don't really need a driver for XP; if I'm translating the Engrish on the site correctly, you only need this driver for the "Email" button.

-dog*
0
ram_einsteinAuthor Commented:
My Regional lang was English(UK)
I changed it to English(US) but it mkes no difference at all!
...and I can't take apart my kbd! (Its sealed)
Please find an alternate solution.


Regards,

Ram
0
Kyle SchroederEndpoint EngineerCommented:
Go back to Regional Settings, then the Languages tab. Click Details.  Is the keyboard set to English (United States) or English (UK)?

-dog*
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mickey81Commented:
Have you tried a different keyboard?
0
Kyle SchroederEndpoint EngineerCommented:
I just tested on my PC, changing the Keyboard region to United Kingdom produces the exact results you're describing.

-dog*
0
ram_einsteinAuthor Commented:
Thanks dogztar....

Regards,

Ram
0
ram_einsteinAuthor Commented:
...and sorry InteraX, your comment was correct but I did not click on details
and dogztar was able to pinpoint the problem

Regards,

Ram
0
Kyle SchroederEndpoint EngineerCommented:
ram:
Are you using a UK version of WinXP???  I can't think of any reason why it would default to that otherwise, unless you selected UK English during setup.

Glad you got it working though!

-dog*
0
Kyle SchroederEndpoint EngineerCommented:
Actually, InteraX did suggest clicking the details and correcting the language settings.

InteraX: points for you here: http:Q_20798996.html

-dog*
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.