[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Cannot connect to Novell's iManager

Posted on 2003-11-14
13
Medium Priority
?
35,004 Views
Last Modified: 2011-08-18
I cannot connect to Novell'siManager.  I can connect to iMonitor at https://<my.server.name>:8009
I've tried http://<my.server.name>:2200 like some places on the net suggest, also
According to this:
www.novell.com/documentation/lg/nw65/ admin_ovw/data/am4s09s.html
I should be able to do this:
... To start iManager in regular mode, open a Web browser and enter either the IP address
or DNS name of the server, followed by /nps/iManager.html.  This does not work either.

Acording to this link:
www.novell.com/documentation/lg/ nw65/uddi/data/aj4j2tu.html
I should be able to use this:
http://xxx.xxx.xxx.xxx:port/nps/iManager.htmlFor Tomcat Standalone: http://hostname:8080/nps/iManager.html 
For Apache/Tomcat: http://hostname/nps/iManager.html 
For Apache/Tomcat with SSL: https://hostname/nps/iManager.html 
On NetWare 6.5 for Apache/Tomcat with SSL: https://hostname/nps/iManager.html 
On NetWare 6.5 for Apache/Tomcat without SSL: http://hostname/nps/iManager.html 

where hostname is the server name or IP address of the server where the UDDI service is running.


None of these work.   Which file do I examine, or how else do I find which port iManager is listening to?  TCPCON/protocol information/tcp/tcp connections lists the ports, but not what is listening on them.  

NDSIMON.nlm is indeed running, and I can connect to iMonitor with https://<ipaddress>:8009 just to recap.

More info:  I've upgraded to edir 8.71 on the server with the Master Replica, I've install iManager 2.01 and installed the Novell JVM 1.4.1 which was required by Tomcat.

Found some stuff here (finally after 12 hours of searching).  I'll keep you all up to date.
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10078877.htm


0
Comment
Question by:sgdought
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 2
13 Comments
 
LVL 35

Expert Comment

by:ShineOn
ID: 9749112
Firstly, I would recommend that you ask in the CS TA to have this question moved to the NetWare subtopic area.  There are ppl there that are true Novell Experts that don't always show up in the Networking TA.

As to your problem.  Do you have a link to iManager from iMonitor?  Does it also give you an error?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9749130
Also, have you tried reinstalling iManager?

http://support.novell.com/cgi-bin/search/searchtid.cgi?/10065902.htm

The TID talks about iManager 1.2 and 1.51 and not 2.01, but it may still apply.
0
 
LVL 5

Author Comment

by:sgdought
ID: 9749783
I did not see a Netware area.  Anyway, at this point I can get to to first iManager screen. I used an apache\conf\adminserv.conf from the UMich to see what ports I need to fix.  It was listening on 52443 instead of ssl 443.  Also redirects need to be pointed to port 2200.    Now I get prompted for a password, but it does not accept it.  I can use the login function to login to iMonitor, but the iManager login just prompts me 3 times, then goes to a page that says Authentication required.
That's where I stand at the moment.  
0
On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

 
LVL 35

Expert Comment

by:ShineOn
ID: 9749830
This question is posted in the Networking topic area.  Among the subtopics in the networking topic area is Netware.  That's where all the NetWare wizards in EE do their wizardry.

When you put your login ID in, are you using the full context?  i.e. .admin.myorg?  or .me.myou.myorg?
0
 
LVL 5

Author Comment

by:sgdought
ID: 9749937
Ok. I went to https://<IP Address>:2200/eMFrame/Simple.html and go a login screen complete with context.  I could login from this screen.  So I tried logging in from https://<IP Address>:2200 and got the windows authentication screen  I used just admin NOT admin.FullContext  and it worked.  Seems that the apache config files are ALREADY point to the correct context for admin, so I didnt needed to use anything but the name without the context.  Thanks anyway folks.
I will say iManager install and troubleshooting SUCKS as their is no documentation.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9750085
There is documentation.  Don't get too frustrated too quickly. The Novell support knowledgebase is superior to any other software provider's knowledgebase I have used, including the mess that Microsoft has for a knowledgebase.  They have more online, web-accessible documentation available than any other software provider I have encountered in my 20-plus years in IT.
0
 
LVL 5

Author Comment

by:sgdought
ID: 9750147
When I tried logging in from https://<IP Address>:2200 and got the windows authentication screen, the screen came up Netware Web Manager, with
NetWare® Enterprise Web Servers  
WHITE-SRV1


Novell® eDirectory™  
WHITE-SRV1


NetWare® Remote Manager  
WHITE-SRV1


eDirectory™ iManager    


On the left hand side.  You will notice that my test server White-srv1 is not listed under iManager

When I go to the URL https://<IP Address>:2200/eMFrame/Simple.html I get the following screen:
IManage
Version 1.0

   You are currently logged in as user admin.WHITE.CRIME.TOKYO.ACME
   in the Novell Directory Services tree acme-tree

Now I know I installed version 2.01 and that is what shows up in nwconfig\products\currently installed products.  So I wonder why iManage does not show up in Web Manager?  

Obviously this is a complex product that uses Apache and Tomcat4  which I will have to learn more about.

   Please select a task on the left.
0
 
LVL 35

Accepted Solution

by:
ShineOn earned 400 total points
ID: 9750230
*One possibility (from the Novell online knowledgebase:)

Here is the solution:  iManager link not present within the Web Manager. iManager not loaded.
The redirect lines or the include statement for iManager's configuration file is not present.   Check your SYS:APACHE\CONF\ADMINSERV.CONF file for the following statements:

Redirect /iManager/ https://server_ip:2200/eMFrame/iManager.html
Redirect /iManager https://server_ip:2200/eMFrame/iManager.html
Include "SYS:/webapps/eMFrame/WEB-INF/eMFrame-apache.conf"
 
 

Here is the problem or goal:
iManager link not present in the Web Manager.  iManager is not loaded.
 
There is no link for iManager in the Web Manager.
 
 
There is a link to iManager but it brings up "page cannot be found."
 
 

Problem Environment:
Novell NetWare 6.0
 
 
Novell Apache 1.3.26
 
Novell Apache 1.3.27
 
Novell NetWare Web Manager 3.5.3
 
Apache server is running off the primary IP address


*Here's another one:
Here is the solution:  iManage will not come up, thru Web Manager or through direct URL
Check to see if the redirect and include statements are found within the web manager virtual host configuration in the sys:apache\conf\adminserv.conf file.   The commands are as follows:

   Redirect /iManager/ https://10.1.1.1:2200/eMFrame/iManager.html
   Redirect /iManager https://10.1.1.1:2200/eMFrame/iManager.html
   Include "SYS:/webapps/eMFrame/WEB-INF/eMFrame-apache.conf"

Substitute your ip address with the one found in the redirect statements.

Another possibility for imanage / imanager not coming up is that there is no sys:webapps\eMFrame\iManager.html file.   There may be an iManage.html file.      This changed from the original installation of Netware 6 to the introduction of Netware 6 support pack 1.   The product was renamed to iManager.   So, an iManager.html file was created and placed in the directory.   If it is not there, you can create a copy of iManage.html and name it iManager.html.
 
 

Here is the problem or goal:
iManager will not come up either from web manager link or through direct URL to iManage page.
 

Problem Environment:
Netware 6
 
 
Apache engine comes up cleanly and is listening on all applicable ports:  80, 443, 2200, 2211.


* Or -
Here is the solution:  Cannot access iManager after adding a DNS address record
Bypass iManager and use the original DNS/DHCP Management Console for NW6.  (located under PUBLIC\DNSDHCP\Setup.exe, which requires Client32 on the client machine) This utility has proven to work efficiently with the NW6 DNS/DHCP configurations.  At this point you should be able to access the Management Console, correct the bad 'A' record and get past the -635 error you are seeing when using iManager.
 
 

Here is the problem or goal:
Cannot access iManager after adding a DNS address record
 
Secure Portal works (port 8009).  
 
Port 2200 also works, but then fails taking the link to iManager
 
"Login Failure" Error 635, the target server does not have the correct information about the source server"
 
Successfully able to access https://<dnsname>:2200/eMFrame/iManager.html and login the first time as Admin
 

Problem Environment:
Novell NetWare 6
 
Novell iManager
 

Additional Information:
Troubleshooting Steps:

Added an 'A' record for the server's DNS name and logged out.  
Attempting to login again to iManager, now fails with the following error: "Login Failure" Error 635, the target server does not have the correct information about the source server".
Tried accessing iManager via the server's IP address, thinking this was related to a DNS issue.
We ran a DSREPAIR -A (to repair the selected server address) and ran an additional full unattended DSREPAIR, but still could not access iManager.
Unloaded and reloaded NAMED.nlm and Apache and tried bouncing the server.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9750424
I noticed that you were trying "simple.html" and getting a message regarding iManage 1.0.  

Have you tried accessing it directly using "imanager.html" instead of "simple.html" ???
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 9752383
have you tried updating iManager to it's latest version?  I'm running iManager 1.21 myself - all is well here...

0
 
LVL 5

Author Comment

by:sgdought
ID: 9752759
100 points to the man, ShineON.  There was indeed a file named iManage.html, NOT imanager.   I just copied it over to iManager.html and the URLs worked.  It still does not show up in Web Manager, but I can now get to it.  I looked for hours at the Novell website and managed to miss the TID that mentioned the name change.

Thank You.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9752834
Check your redirect and include statements in ADMINSERV.CONF also - it may be missing the redirects for iManager, which would cause the link not to show in Web Manager.
0
 
LVL 10

Expert Comment

by:DSPoole
ID: 9768400
Did you shut down Java prior to upgrading iManager?  It's a must.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What monsters are hiding in your child's room? In this article I will share with you a tech horror story that could happen to anyone, along with some tips on how you can prevent it from happening to you.
With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question