Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5078
  • Last Modified:

Clear history button is disabled

I am running IE6.0 on WinXP Pro. I just found out my clear history button under Tools (in Browser) is disabled. I searched Google but can't find anything. Any suggestions?

Thanks
0
TomokoL
Asked:
TomokoL
  • 12
  • 10
  • 4
  • +3
1 Solution
 
war1Commented:
Greetings, TomokoL!

Check for virus and adware

Housecall Online Scan
http://housecall.antivirus.com

SpyBot S&D searches your harddisk for so-called spy- or adbots;
http://security.kolla.de/
or
Adaware
http://www.lavasoftusa.com/software/adaware/

Best wishes, war1
0
 
war1Commented:
TomokoL,
   1. There may be programs running in the background interfering with the operation of Internet Explorer. If you have Norton programs running in the background, temporarily turn them off, including anti-virus, win doctor, recycle bin protect, and clean sweep. Does this fix the problem?

Turn off any firewall or ad-blocker.

2. Perform a repair of Internet Explorer.

http://support.microsoft.com/default.aspx?scid=kb;EN-US;318378
OR
http://www.theeldergeek.com/repair_ie6.htm
0
 
CrazyOneCommented:
Start > Run gpedit.msc

User Configuration  > Windows Components > Internet Explorer
Look at "Disable changing history settings and if it say Enabled then double click on it and select disabled or Not Configured
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
CrazyOneCommented:
Before you do his close all internet windows
0
 
TomokoLAuthor Commented:
Hi Guys, Thank you for all your comments, I tried every one of them and none of them could fix my IE problem. I just reinstall the IE6, but the clear history button is still disabled, Oh, what should I do?!
0
 
CrazyOneCommented:
Did you have every IE window shut down when you applied the Group Policy?
0
 
TomokoLAuthor Commented:
Yes, I did. Actualy, in the group policy, they all not configed, I set the one to disable, but still doesn't work.
0
 
CrazyOneCommented:
Ok try this

Start > Settings > Control Panel > Intertnet Options
and see if it is visible then.

Although it is the same as going to Tools > Internet Options sometimes on rare occassions launching if from control panel clears up problems
0
 
CrazyOneCommented:
Also see if this helps
Enable the policy Reboot then diaable the policy and reboot and see what happens
0
 
TomokoLAuthor Commented:
I opened the Internet Option from Control panel, but the clear history is still disabled.

Your seconed comments, can you give me some details on how to do it?

Thanks
0
 
CrazyOneCommented:
Do what you did in my first comment but now enable the policy and reboot. Then take a look at that clear history to see if it is still grey out. Then reset the policy lets say to Not Configured and then reboot and see if the button comes back.
0
 
TomokoLAuthor Commented:
Hi, I just did the group policy, enable ->Reboot, not config->reboot, but still not working,
Any more comments?
0
 
CrazyOneCommented:
Bummer I am out of ideas. :(
0
 
CrazyOneCommented:
If this just happened then maybe this will fix it.

HOW TO: Restore the Operating System to a Previous State in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;306084

Log on to Windows as Administrator.
Click Start, point to All Programs, point to Accessories, point to System Tools, and then click System Restore. System Restore starts.
On the Welcome to System Restore page, click Restore my computer to an earlier time (if it is not already selected), and then click Next.
On the Select a Restore Point page, click the most recent system checkpoint in the On this list, click a restore point list, and then click Next. A System Restore message may appear that lists configuration changes that System Restore will make. Click OK.
On the Confirm Restore Point Selection page, click Next. System Restore restores the previous Windows XP configuration, and then restarts the computer.
Log on to the computer as Administrator. The System Restore Restoration Complete page appears.
Click OK.
0
 
CrazyOneCommented:
Or you may have to resort to this

Repair
How to Perform an In-Place Upgrade (Reinstallation) of Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;315341

Visual aid to the above procedure
http://www.webtree.ca/windowsxp/repair_xp.htm
Click on How To Run a Repair Install

You May Lose Data or Program Settings After Reinstalling, Repairing, or Upgrading Windows XP
http://support.microsoft.com/default.aspx?scid=kb;EN-US;312369

Data Loss May Occur After Reinstalling, Repairing, or Upgrading Windows XP
http://support.microsoft.com/default.aspx?scid=kb;EN-US;312368
0
 
sunray_2003Commented:
Like there are way to disable Back Buttons in Browsers, there could be a way to disable history button......


Are you sure you are the only person logging into this computer and no other user or administrator might have tweaked something that has disabled the history button .....

As CO , said you may have to reinstall or repair the OS but wait until you get some more comments from experts ....

Sure somebody might have faced this issue before

Sunray
0
 
sunray_2003Commented:
Did you try repairing this way

Repair IE :
-----------

Start > Run rundll32 setupwbv.dll,IE6Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g

or

Start > Run rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\windows\inf\ie.inf


Sunray
0
 
irieiamCommented:
Is your history set to remember 0 (zero) days?  If so, increase it to at least 1 day and see if that helps.
0
 
TomokoLAuthor Commented:
Hi, Realy thank you for all your comments. I triedSunray_2003's way to repair, but it still can't fix the problem. Also for the remember day is disable too, I can't change the days, but I can see it was 5 days.

Is there any other comments except reinstall OS?

Thanks
0
 
irieiamCommented:
I certainly do not think that an OS reinstall is the answer.

If any setting in IE will not allow you to change it, I'd say the browser was hijacked and should be scanned
for spyware or a virus/trojan.  Refer to war1's comment (Date: 11/14/2003 01:24PM CST) to check using housecall and/or adaware.

-irieiam
0
 
CrazyOneCommented:
irieiam TomokoL said "I tried every one of them and none of them could fix my IE problem"
0
 
TomokoLAuthor Commented:
Hi, I did scan my system again with Adware, and there are some bugs were found, but even after I remove the bugs, the history button still not working. So I try to reinstall the Ie6, but after I reinstall, all the old information is still there, such as home website, all my favorites websites are still there. I changed the registry key from 1 to 0, but still keep the old setting

How can I totally get a brand new ie, without any old memory?

Thanks
0
 
CrazyOneCommented:
Open Explorer to this folder C:\Documents and Settings\Your Profile\Local Settings\History and double click on it

and delete every folder you see listed under History
0
 
war1Commented:
TomokoL,
   Your History folder may be corrupted.  Delete the folder and reboot and let Windows recreate it.
0
 
TomokoLAuthor Commented:
Hi, under history only have something called Today, last week, which contain some website address I had visited. I already clear it. Even I delete those folder, then should I  reinstall the ie after that?

I am wondering there is any way I can my drop down address list lke what the clear history button function?

Thanks
0
 
war1Commented:
After deleting the folder, set History to 1 day.  IE or Windows should recreate the folder.
0
 
TomokoLAuthor Commented:
I  delete the folder under history, and it create a folder Today.
How to set the history to 1 day. The history button and the days all disabled.
0
 
CrazyOneCommented:
The Today folder will always be present even settting it to 0 that folder will not go away.
0
 
TomokoLAuthor Commented:
Hi Guys, I fix my problem finally. I found one my old backup image, so I restore it and the ie is OK now. I am really appreciate all your comments and help. Thank you very much.

Tomoko
0
 
rootkiddyCommented:
Well I was fixing to post what I believe was your problem.  Something probably edited a policy on your machine.  This is only available in XP Professional which is probably why some people didn't catch this right away.  You should have a group policy editor which should allow you to modify this setting.  For the windows platforms that support policies there is a setting to disable/enable History meaning you can't even modify it and several other things.  Here's a link in case you run into the problem again.

http://www.wown.com/j_helmig/winxpgpe.htm
0
 
TomokoLAuthor Commented:
Hi, Thank you for the new comments, but actualy there was a past comments mentioned that group policy already.

"Start > Run gpedit.msc

User Configuration  > Windows Components > Internet Explorer
Look at "Disable changing history settings and if it say Enabled then double click on it and select disabled or Not Configured" --From CrazyOne

But I still thank you for all the comments.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 12
  • 10
  • 4
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now