Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

hard lockup/freeze on D-link 530-tx

Posted on 2003-11-14
14
Medium Priority
?
1,941 Views
Last Modified: 2013-11-09
This is a continuation of

http://www.experts-exchange.com/Networking/Q_20796257.html

I checked the cables, routers (by connecting a laptop) and it works fine.

So I decided that the problem must be the NIC.  The current one was a DLINK 530tx (realtek 8139 driver) and I got the same card from office depot (rev E1).

The one difference I noticed between the two cards is that the new one is recognized by the router even when the power is off (the router lights are on. I suspect some power is being drawn as the plug hasnt been pulled. if this is done then the router lights go off)

Even though its the same card, it installs the driver specific to 530 tx.

after a little while browsing I get a hard lockup. On investigating I find that there is no lockup if I disconnect the cable from the router (loopback ping works fine)

But the moment I put the cable back in it locks up hard

I am wondering if this is dhcp related ?

I should mention that I noticed similar lockups with the older card a few times over the past week.

The other PC which is fine is running on a VIA motherboard with a realtek NIC.

Is it some driver issue that interacts with negotiating with the router problem? or is it caused by some XP updates?

Something about the networking hardware/software is causing communication with the router (which is basically a gateway to the cable modem) to go haywire.

Is the solution to get a different NIC? I do recall reading something about dhcpsense

0
Comment
Question by:nsriram
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
  • 2
14 Comments
 

Author Comment

by:nsriram
ID: 9750498
I get the hang even if its not connected to the router.. It does not hang if I remove the network card..(at least so far)
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9751344
In your NIC configuration, is there a PXE option?  If so, turn it off.  Also turn off any powersave features for the NIC - you don't want it to turn off the NIC just because the PC has been idle for a while...
0
 
LVL 51

Expert Comment

by:Netman66
ID: 9752156
Make sure the NIC is NOT in the PCI slot directly adjacent to the AGP slot.

The AGP shares resources with the first PCI slot and can cause this problem.

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:nsriram
ID: 9752189

Its one slot away (so theres one empty slot in between).. still your suggestion is useful.

update: I returned the d-link and got a linksys card LNE100TX v4 for 15 bucks from radio shack. It also comes with a 10 bucks mailin rebate!

XP Sp1 detects the card and installs it. There were some problems (of the cable is unplugged messages) but no hardware hangs

Finally I removed the driver and check the Award Bios.. There is one setting in the PCI list that enables or disables rewriting the PCI config (everything is on auto)

Then booted into safe networking and it was detected and installed (no messages at all) and I could get a ping from the router and the net.

I did not update the driver from the cd (I had done this earlier) and left well enough alone (I just left the one installed by XP as is)

right now I am booted into normal mode and typing this message.. so far no hangs.

The take home message in all of this I suppose is

avoid d-link? but  then it had worked fine for over a year

maybe one has to understand the bios settings real carefully and they tend not to be documented.

If there is a way to close this question I will (assuming system is stable for  few more hours)


0
 

Author Comment

by:nsriram
ID: 9753227
As it turned out the driver was fine and I could surf the net for about 2 hours

after that it hung the system

so it seems the new NIC cannot cure the problem

I tried to do a XP repair and found that the repair hung if the NIC was in place.. So I had to the repair without the NIC.

Subsequently I tried to install the driver and currently it is nonfunctional (with a yellow exclamation mark saying "the device cannot be started")

the system is back to the vanilla XP (due to the repair); so SP1 has been taken out and would need to be reinstalled

any suggestions on where I should go with this appreciated..

Perhaps SP1 had some drivers for this card that it installed (earlier) and that worked briefly

maybe something is wrong with the PCI controller.. but no error messages or anything that would make any sense.

0
 
LVL 51

Accepted Solution

by:
Netman66 earned 1000 total points
ID: 9754887
Is the CPU fan working?  If so, make absolutely sure the heatsink and fanblades are clean.

Also, clean the power supply fan and any aditional fans in the case.

Sounds like an overheating problem.

If all else fails, it could very-well be a motherboard going bad.  Check all the capacitors on the board to make sure none of them are buldging/leaking.

Advise.
0
 

Author Comment

by:nsriram
ID: 9755176
CPU fan is working.
Power supply fan is also working.

The Bios reports temperatures that are normal..

How does one clean the CPU fan and sink ? Use compressed air or gas?

I have some insight into what may be happening.

If after I slot in the network card, I change the BIOS to enable rewriting the PCI config.. it does that ONCE (and sets it to disable); after this I can install the network card.

Anyway I will see how long I can be on the net before it loses connectivity again or have a hard hang.


Sriram
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9759185
Yes with compressed air/gas, but make sure the PC is OFF and UNPLUGGED and the CPU is already cool  

Rapid cooling and/or condensation caused by using compressed air/gas on a running or hot system is a good way to make Silicon popcorn.
0
 
LVL 35

Assisted Solution

by:ShineOn
ShineOn earned 1000 total points
ID: 9759208
You should always do a reset (or whatever your BIOS calls it) after adding or moving a card.  Also, I would recommend setting the Plug&Play OS setting to off or no in the BIOS.  Let the BIOS handle the hardware instead of the OS.  XP is better at it than prior Windows versions, but there are still remnants of "plug & pray" IMHO.
0
 

Author Comment

by:nsriram
ID: 9759726
ok.. the BIOS resetting thingie was responsible for those hardhangs (and with vanilla xp even failure to load OS).. the temperature was not an issue

Can a weak cmos battery screw the network (PCI related) settings?  Once the driver was nonfunctional even though it was ok in the previous reboot (solution: change cmos reset settings once again)

for some reason network is stable via router to comcast only when the other PC (also xp) is not online. else I lose the router soon. and the other PC doesnt have a problem with a laptop.

that will be the focus for another question I suppose.. now I use one PC when I want to work stable on the net.

0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9759762
Do you have "plug & play OS" on or off?
0
 

Author Comment

by:nsriram
ID: 9760115

My BIOS doesnt have this option. Revisions probably do as I looked on the net although I am not sure on how to upgrade the BIOS.

Program:   eSupport.com BIOS Agent Version 3.23
BIOS Date: 06/07/01
BIOS Type: Award Modular BIOS v6.00PG
BIOS ID:   06/07/2001-i850-W83627-C
OEM Sign-On: KOB 850 FSX 06/07/2001
Chipset:   Intel 2530 rev 2
Superio:   Winbond 627F/HF rev 7 found at port 2Eh
OS:        WinXP
CPU:       Intel Pentium 4 1500 Mhz MAX: 2000 Mhz
BIOS ROM In Socket: Yes
BIOS ROM Size:      256K
Memory Installed:   256 MB
Memory Maximum:     1024 MB
Memory Slot 01:     128 MB
Memory Slot 02:     128 MB
Memory Slot 03:     0 MB
Memory Slot 04:     0 MB
0
 

Author Comment

by:nsriram
ID: 9760143
Investigating further I found that kobian.com the makers of the Mercury MBoard have something

http://www.kobian.com/dl_mb_get.php

point is: I am not sure which one to upgrade to as there are multiple EXEs.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9761628
You want to find the exact instructions for doing a BIOS flash on that motherboard and follow them to the letter.

In order to know which flash to use, there should be resources on that site.  It usually depends on the exact model of motherboard you have.
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This program is used to assist in finding and resolving common problems with wireless connections.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question