Solved

Connecting my server to the network brings the network down

Posted on 2003-11-14
10
306 Views
Last Modified: 2010-04-14
Hello,

I am trying to bring up a Windows 2000 Small Business Server system on a local network consisting of multiple client PCs (all running Windows XP) and a couple other small business server systems.  When I plug the computer into the network Internet access goes out for everyone on the network.  When I unplug the network cable for the server, Internet access is immediately restored.

I suspect this has something to do with DNS, but I am perplexed as to why connecting this server (which has its own unique internal IP address of 192.168.0.7) is having such an adverse effect on Internet connectivity.  I'm able to ping between systems on the local network though when this problem occurs.  Right now the system is offline, or else I couldn't get out onto the Internet to ask for help.  Any assistance with this problem would be most gratefully appreciated.

Thanks,

John Sheppard
0
Comment
Question by:John_Sheppard
  • 5
  • 3
  • 2
10 Comments
 
LVL 3

Expert Comment

by:Chris_Picciotto
ID: 9752280
When the server is connected is there any connectivity issues between the clients and servers?

Is the server running DHCP?

The perfered configuration for DNS is to have all the clients point to an internal DNS server for DNS resolution and to have the server forward queries to and upstream server such as one or more provided by your ISP. This can be done by right clicking on the server in the DNS console, chosing properties and then enabling forwarders in the forwarders tab. If the entry is greyed out than you must delete the forward lookup zone that is a "." You may have to exit the console and open it up again or stop and restart the service.
0
 
LVL 3

Expert Comment

by:Chris_Picciotto
ID: 9752292
The reason this is the perfered configuration is that the internal DNS server will cache queries for external resources which will make name resolution faster because the resolved data is on the local network operating at 100 Mbps as opposed to 1 Mbps on the average.
0
 

Author Comment

by:John_Sheppard
ID: 9752801
I believe that the server and other client computers are able to communicate to each other on the 192.168.0.x network just fine...it's just that when the server is online Internet access gets messed up.  I've tried just pinging IP addresses of known web sites (www.google.com) and I have trouble pinging when the server is online.

We tried adding forwarders to the DNS server (the same forwarders that another working server on the network uses) but the problem still exists...in fact, when the misbehaving server is connected, it's not possible to ping the upstream DNS servers.

As for DHCP, that is performed by the router, though I will check the server to make sure I haven't accidentally enabled it.

Tomorrow I'm going to sit down and compare a working server that's on the network with the problem one and check every possible setting having to do with networking to see if I can make any headway in resolving this issue.
0
 

Author Comment

by:John_Sheppard
ID: 9754825
It turns out that DHCP was enabled on the problem server.  I just disabled it but the problem does not seem to go away.

After doing further investigation, it appears that sporadically the gateway router 192.168.0.1 stops responding to pings or anything coming from computers inside the network.  Unplugging the new server from the network seems to make the router respond again.
0
 

Author Comment

by:John_Sheppard
ID: 9754827
It turns out that DHCP was enabled on the problem server.  I just disabled it but the problem does not seem to go away.

After doing further investigation, it appears that sporadically the gateway router 192.168.0.1 stops responding to pings or anything coming from computers inside the network.  Unplugging the new server from the network seems to make the router respond again.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 9

Expert Comment

by:MSGeek
ID: 9757417
SBS Server has built in Routing and Remote Access as well as the ISA firewall.  If you do not have this on any of your other servers, get rid of the flaky router and place the SBS Server with two NICs in it's place.  Better yet find a replacement router then your SBS Server running ISA then the rest of your network. That way your other workstations are protected by ISA and teh router and not just the router.  Also if you are running DHCP on the Server rather than the router you may integrate that with DNS and Active Directory.

One question I do have is you state:  "I am trying to bring up a Windows 2000 Small Business Server system on a local network consisting of multiple client PCs (all running Windows XP) and a couple other small business server systems."

SBS was not designed to run with other DCs, not that you cannot do this, but how many workstations are we talking about?  Why would you want multiple SBS on the same network?
0
 

Author Comment

by:John_Sheppard
ID: 9761880
Here is further information we found out from looking into this problem.  It turns out that what actually happened when Internet access fails on the network is that the router/gateway at 192.168.0.1 becomes unreachable.  It doesn't happen right away sometimes when the problem server is connected, but rather happens five or so minutes later.

We compared settings on the problem server with the old server it is meant to replace (the old server doesn't cause the problem).  It turns out that a service called WINS was running on the new server (it was not running on the old server).  Disabling this service on the new server makes the problem go away.  Could anyone explain why?

Oh, as for the reason why there's several Small Business Server computers running with a bunch of client Windows XP PCs on a single network, the reason why is that three separate organizations share the same network and office space.  Each organization is independent of the others; hence why each organization has its own server.  
0
 
LVL 9

Accepted Solution

by:
MSGeek earned 500 total points
ID: 9768395
"Oh, as for the reason why there's several Small Business Server computers running with a bunch of client Windows XP PCs on a single network, the reason why is that three separate organizations share the same network and office space.  Each organization is independent of the others; hence why each organization has its own server."

That explains a few things.  I hope they are on seperate VLANs and if not, that they are at least on their own subnets.

WINS is the Windows Internet Name Service.  It is used by ME and 9X workstations.  If you have those kinds of clients and WINS enabled with no static entry on the WINS server for your default gateway that could definitely cause what you are seeing.  Win2k and XP use DNS first to find resources inclding gateways on a network where 9X and ME boxes will look to WINS first.  

If you go to the new server and place a static entry, 192.168.0.1, in WINS for your router (The default Gateway) I think you will find the problem goes away, unless you have DHCP enabled.  

What kind of clients/workstations are you dealing with?  This is a messy situation you have if the traffic is not on seperate VLANS and you have a DHCP server that is not tied to any paticular domain.

Ideally your structure would look more like:

Internet - ISP - Router (DHCP Disabled) - VLAN1 - SBS Server w/DHCP, WINS and Active Directory integrated DNS - Workstations
                                                            VLAN2 - SBS Server w/DHCP, WINS and Active Directory integrated DNS - Workstations
                                                            VLAN3 - SBS Server w/DHCP, WINS and Active Directory integrated DNS - Workstations

If you have no ME of Win9x clients you may leave WINS disabled with no adverse affects.  By default SBS Server when setup has WINS enabled.  Hope this helps, MSGeek.
0
 

Author Comment

by:John_Sheppard
ID: 9769455
Hello,

Thanks MSGeek for all the information.  It turns out that all the client PCs are running Windows XP, so WINS isn't needed.  I will share your comments with my colleagues so that we can avoid pitfalls like this in the future.
0
 
LVL 9

Expert Comment

by:MSGeek
ID: 9775361
Glad I could assist.  In you case WINS is not needed.  I would recommend looking into a network structure as outlined.  Good luck.  MSGeek.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Application Deployment 2 253
Windows 2000 Print Server 2 1,018
WMI Uptime Script Reporting Incorrect Number on W2k Server 16 756
Problems executing VBS script in Windows 2000 16 163
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
When we talk about DevOps toolchains, I sometimes wonder how many people really get what we’re talking about. I don’t know if it’s just semantics or tone or something else, but sometimes I think it just sounds like buzzword sausage. So it’s always …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now