Connection Time out errors

webserver: apache on Redhat linux 8.0
router: speedstreem 2602--192.168.254.200
my domain: lewtoday.com
dsl provider: verizon
my website is: www.lewtoday.com 
but since port 80 is blocked i am using port 8080.
router: speedstream 26o2

I have zoneedit forward lewtoday.com and www.lewtoday.com to www4.lewtoday.com:8080
Apache appears to be working fine. When I type in the LAN ip 192.168.254.130:8080 my webpage appears.

my wan ip is 141.157.20.240
my lan ip (which is static) 192.168.254.130

But when I type in the WAN IP or www.lewtoday.com I get a blank screen and eventually a request has timed out error or the page cannot be displayed.
What the am i doing wrong????
I've reinstalled RH 8.0 out of frustration, thinking maybe I did something wrong to a config file, but even with the system reinstalled things still won't work.

lynn402Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
Your router must be configured to accept connections on 8080/TCP and forward those to 192.168.254.130. And Apache must be configured to listen on port 8080 rather than the defualt (80/TCP).

You won't be able to connection to the Internet IP of your web server from a machine on your local LAN. For those machines you must use the inside IP of the web server. Testing of external access to your web server must be done from some host on the Internet. If the defualt firewall is running on your Linux system it must be configured to allow connections on 8080/TCP.
0
lynn402Author Commented:
I've already set  apache and my router to accept http requests from port 8080. I've just set the linux firewall to accept port 8080. I don't know if it took. I typed, from the command, setup and did customize to the firewall, typing in 8080.

When I checked out the firewall file in in /etc/sysconfig/firewall I see:

Global ICMP all input ACCEPT forward ACCEPT output ACCEPT

here is my site www.lewtoday.com. Tell me if anything shows up
0
jlevieCommented:
Nope, it doesn't seem to be working from the Internet. Since you have a border firewall (your router) I'd suggest turning off the RedHat firewall ('service iptables stop' & 'chkconfig iptables off') until you have all of the other issues sorted out. After you have the firewall off make sure that the router is configured to accept and forward traffic on 8080/TCP to 192.168.254.130
0
lynn402Author Commented:
this is how my speedstream 2602 virtual server is setup:

private ip:192.168.254.130
private port: 8080
publc port: 8080

in apache's config file i have: listen 192.168.254.130:8080

When I reinstalled RH 8 last week, hoping that a reinstall would be the cure, I disabled the firewall. Further when I checked the anaconda-ks.cfg file it verified that the firewall is disabled.
I ran the commands you listed above, too.
0
jlevieCommented:
It is working now. I get the Apache test page when I got to the IP or www.lewtoday.com.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.