Win2k3 (X2) + 1 win98 workgroup, extremly slow

I have 2 win2k3 machines, networked with a Linksys 4 port router, and a single win98 machine. They can all see each other just fine, and in an attempt to get things going faster, I turned on the "guest" account on the 2nd win2k3 machine. (The first one is my main machine) That hasn't done any noticeable (aside from allow the

It takes it a good 1-2 minutes to find other networked computers in "My Network places" When the 2nd machine was just a simple 98, everything was very fast and speedy.

This is becoming a major concern to me.

_MillsyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
Have you enabled Netbios over TCP/IP on the Win2k3 machines?


Enable NetBios over TCP/IP in WIndows XP/2K3
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.
Reboot
0
_MillsyAuthor Commented:
no affect on anything.
0
lrmooreCommented:
On one of the Win2k3 systems, disable it from being browse master.
open regedit, search for MaintainServerList
Set to no vs auto

Do you have anything in any of the event logs that would indicate some other issues?

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

_MillsyAuthor Commented:
I think I found the problem.

I have 2 network cards in my computer, and it was giving an error of "two computers with the same name" on the network.

Disabling the one connection seems to have sped things up to what it was.


Do you know of any way I could have speedy networking with this connection active ( i use it to connect to my work VPN)
0
lrmooreCommented:
You can disable netbios on the other NIC.
0
_MillsyAuthor Commented:
Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.