Removed EVERYONE permisions from C:\ Drive (WINXP)

I have removed 'EVERYONE' permision from my C:\ Drive. Now my system refuses to load windows.

Following is the Error:

After the Windows XP Prof. splash screen

Error - "Autochk.exe not found - Skipping Autochk"

system reboots and the same cycle continues.

I think the denial of everyone assess has also remored the SYSTEM permission to access c:\ drive. This is causing WinXp to crash.

I tried to use the 'cacls connand' from MS-DOS to reset permissions, but this command does not work.

This is happening on my HP laptop HP-nx9000 laptop.  Please help me out here guys.
sanaka98Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CrazyOneCommented:
You need to take this disk to another machine that is running XP or Win2000 and add the every one group back.
CrazyOneCommented:
Then when you that set your permissions per specific users or groups other than the everyone group

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stevenlewisCommented:
does the LKG work
press F8 during boot and choose last known good
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

stevenlewisCommented:
CrazyOneCommented:
I need to clarify this statement "Then when you that set your permissions per specific users or groups other than the everyone group"

do this in the original machine not the machine you reset the everyone permission on.

As far as know resetting the everone permisson use another machine that is running XP or Win2000 is about the only way to get you back into the OS. The permissons reside in the files system on the disk.
Crash2100Commented:
If none of the above helps, have you tried booting into safe mode?
sanaka98Author Commented:
Well the machine i messed up is a brand new HP laptop. So removing the HDD and reconnecting it to another PC does not arise (warranty gets void).

When I boot I get only F2 & F12 options.  No F8.

Coming back to the micosoft link. Will my over writting the SAM file help out here. SAM usually has user and password details. Are file permissions also associated here.

One last thing, I tried to boot using a WinXp bootable CD and choose the "R" (restore) option. Here I select '1' which takes me to C:\Windows\. NOw I tried using the CACLS command here but it says its not a recognised command.  This same command works on my other PCs to restore file permissions for files and folders. Why cant I use this or some other MS-DOS command to restore access.

The command I am trying to use is : CACLS C: /T /G EVERYONE:F

Thanks for the help guys.

Crash2100Commented:
that setup command prompt is very limited.  That, and I don't think there is a calcs command in windows xp.  At least there isn't on my computer running xp pro.
Crash2100Commented:
HOW TO: Use Xcacls.exe to Modify NTFS Permissions
http://support.microsoft.com/default.aspx?scid=kb;EN-US;318754

You can get the xcalcs program here:
http://www.microsoft.com/windows2000/techinfo/reskit/tools/existing/xcacls-o.asp


Description of File Sharing and Permissions in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;304040&Product=winxp
sanaka98Author Commented:
Thanks again, but I tried the Xcacls command last time as well - no luck.  

I did try copying the xcacls.exe/cacls.exe files in C:windows\ but the process fails ( cannot copy files). Hence, I do not think I can run the setup.exe file in dos to install the prog.

Why can't i use the utility from a floppy?? How can windows let a person delete EVERYONE access (including SYSTEM, which is the O/s own access) and not have a remidy for it.

A hacker can so easily crach machines by writing a virus to remove everyone access from root (c:\). It cannot be so easy !!

Guys I need to get this PC up and running - my job is at stake here.

I appreciate your support.
Crash2100Commented:
Try installing it on one of your working computers, then copy the exe to a floppy and see if you can run it like that.
stevenlewisCommented:
>When I boot I get only F2 & F12 options.  No F8.

try pressing F8 and see what you get
CrazyOneCommented:
Safe mode won't let you in either you will have to take this disk out and put it in another machine. Contact HP and tell them your situation I am sure they won't void your warranty because of you current issue. This permission is written into the file system and no where else. It is not in the registry hives it is in the file system. Will probably not be able to a do Repair because it looks at the permissions. You probably can't even do a parallel install either. Your choice are a fresh install or move this disk to another machine and reset the everyone permission.

Now if you want to spend around $300 then there is some software that can help you do this

NTFSDOS Professional
http://www.sysinternals.com/ntw2k/freeware/ntfsdospro.shtml
http://www.winternals.com/products/repairandrecovery/ntfsdospro.asp

NTFS Reader for DOS
http://www.ntfs.com/boot-disk.htm

NTFS for Windows 98 is a NTFS file system driver
http://www.sysinternals.com/ntw2k/freeware/ntfswin98.shtml

Techw0rm
http://www.geocities.com/hendrikdejong/TECHW0RM.ZIP
CrazyOneCommented:
I mean I don't want to be the bearer of bad news here but as far as I know there are no free utilities and XCALCS is for setting permissios while Windows is running.

>>>A hacker can so easily crach machines by writing a virus to remove everyone access from root (c:\). It cannot be so easy !!

Absolutely it is that easy if they are able to gain access to the admins account. Hecne why one needs to secure their machines like using firewalls ect.
mthibaulCommented:
If you say your job is at stake then just get yourself a drive caddy and pull out the drive and connect it to a desktop and change the permissions back and then put it back into the laptop. Case closed and your vendor will never know the difference. I used to work for a large corp and used to do this type of thing all the time and I never had a problem with my vendors(because I never told them!)

Besides, warranties are not void simply by removing the drive. Just don't pull off any of the stickers that say "Void if removed"!

This job should take no less than 15 mins to do providing you have a drive caddy for the laptop drive.
stevenlewisCommented:
>When I boot I get only F2 & F12 options.  No F8
No, it's not an option, you just do it, and then you get a menu giving you options
see here
http://support.microsoft.com/default.aspx?scid=kb;en-us;315222&Product=winxp
and no offence meant, but if your job depends on this stuff, you had better learn to use the MS kb  site and how to search it for solutions!!
CrazyOneCommented:
Steve :)
sanaka98Author Commented:
Sorry Guys - I seem to have goofed!!

I wanted to give the TOP POINTS to CrazyOne -  As he got all the options and answers.  Please correct the same.

As a sign off I would like to add that the ONLY solution for my issue was:

1. Remove the HDD and connect it to another PC running the similar O/S (WinXp SP1).
2. Restore 'Permissions' on the drive.
3. Reconnect the HDD to continue using the PC.

This was given by HP and Microsoft as the only options to solve my issue.  

Thanks guys!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.