Solved

Network not working after DHCP assigned IP address (XP)

Posted on 2003-11-16
39
7,877 Views
Last Modified: 2013-12-07
Hi,

I've just got a new PC up and running with Windows XP and I'm trying to get the network working. Currently we have a home network of three PCs connected to a Netgear router which in turn connects to a cable modem and then my ISP.

The three PCs all work find on the network but this fourth one won't. The problem is, it manages to contact the DHCP server and get assigned an IP address ok, which is valid and all the settings are correct. However once it's got its IP address, networking just doesn't work. I can't even ping to or from the machine to the router or any other PC.

I checked the network status, and it's sent packets, but not recieved any...

Any ideas? I can post any ipconfig stuff if necessary. I've tried a static IP address too, still nothing.
0
Comment
Question by:jonnyvaughan
  • 12
  • 9
  • 7
  • +4
39 Comments
 
LVL 9

Expert Comment

by:cooledit
ID: 9759084
try change the cable with one that its tested from one of the other PC's

IP address in the same DHCP Scope (is it valid)
ping the Loopback 127.0.0.1
ping the DNS server
ping the Default Gateway
ping the File server
Ping www.cisco.com

first check the status of the cable the proceed
0
 
LVL 9

Expert Comment

by:cooledit
ID: 9759086
is there an Firewall running on the maschine ?
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9759102
>it's sent packets, but not recieved any

Duplex mismatch or bad cable probably.
If replacing the cable doesn't work try setting the NIC to 100Mbit 1/2 duplex.
You might also have a bent pin in either the router or PC RJ45 sockets, or a bad NIC.
0
 

Author Comment

by:jonnyvaughan
ID: 9759107
No firewall running. It's a fresh install of XP. (checked XP firewall too)

Tried changing the cable with a few others that are known to be working (besides, it manages to get the IP address correctly from the DHCP server in the first place) - still nothing.

IP address is valid (network is 192.168.0.*, assigned ip is 192.168.0.4 - not conflicting with anything else either).

Can ping loopback and network ip (192.168.0.4)
Can't ping Default Gateway (the router, 192.168.0.1)
Can't ping any other PC on the network
Can't ping DNS server
Can't ping www.cisco.com (doesn't resolve)

:(
0
 
LVL 4

Expert Comment

by:mthibaul
ID: 9759137
Specifically assign the DNS server IPs in the TCP/IP DNS properties and this should resolve your're problem. Also, if you are on a workgroup  LAN then make sure your new box has the same workgroup config
0
 

Author Comment

by:jonnyvaughan
ID: 9759160
Tried assigned DNS servers statically and still nothing. The workgroup is set to what the others are 'mshome'.

Tried setting to half duplex, no joy.

The NIC is onboard (motherboard: Asus A78NX-VM - brand new mobo). If it were bent or broken pins and/or a broken NIC then I don't think it would get an IP address from the DHCP server properly?

0
 
LVL 4

Expert Comment

by:mthibaul
ID: 9759168
OOOps, I keep thinking of Domain ENVs which is why I suggested statically assigning the DNS server IPs to your TCP/IP properties. You don't need this ifor the internal LAN but it does help for external if your having DNS problems.

In your case the fisrt place to look is the workgroup config.
0
 
LVL 4

Expert Comment

by:mthibaul
ID: 9759197
Try uninstalling and re-installing your networking components from the add/remove programs applet in control panel and if that doesn't fix it, try a differnet NIC card. Maybe the one you have is a defect?
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9759202
>If it were bent or broken pins and/or a broken NIC ...
You wouldn't think so, though when you see one counter incrementing and the other not, it's a shot.
DCHP works at the MAC level, so it seems an IP protocol issue.

Can you give up the output of ROUTE PRINT
and IP CONFIG /ALL

Sometimes the quick fix is to remove all adaptors and protocols in safe mode, reboot, redetect the adaptor and install the protocols.


0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9759212
sorry mthibaul, i was typing as you posted
0
 
LVL 9

Expert Comment

by:cooledit
ID: 9759225
try inserting a NIC in the PCI slot and go from there !!
maybe take one you r sure working from one of the other mascines u have
0
 

Author Comment

by:jonnyvaughan
ID: 9759254
C:\Documents and Settings\Administrator>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x20002 ...01 23 45 67 89 ab ...... NVIDIA nForce MCP Networking Adapter - Packet Scheduler Miniport
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.0.1     192.168.0.4        30
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1        1
      192.168.0.0    255.255.255.0      192.168.0.4     192.168.0.4        30
      192.168.0.4  255.255.255.255        127.0.0.1       127.0.0.1        30
    192.168.0.255  255.255.255.255      192.168.0.4     192.168.0.4        30
        224.0.0.0        240.0.0.0      192.168.0.4     192.168.0.4        30
  255.255.255.255  255.255.255.255      192.168.0.4     192.168.0.4        1
Default Gateway:       192.168.0.1
===========================================================================
Persistent Routes:
  None


C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration
        Host Name . . . . . . . . . . . . : fuzei
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : Yes
        WINS Proxy Enabled. . . . . . . . : Yes

Ethernet adapter Local Area Connection 2:
        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : NVIDIA nForce MCP Networking Controller
        Physical Address. . . . . . . . . : 01-23-45-67-89-AB
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.0.4
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1
        DHCP Server . . . . . . . . . . . : 192.168.0.1
        DNS Servers . . . . . . . . . . . : 194.168.4.100
                                            194.168.8.100
        Lease Obtained. . . . . . . . . . : 16 November 2003 18:04:51
        Lease Expires . . . . . . . . . . : 19 January 2038 03:14:07

I'll try removing everything and reinstall networking, see what happens.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9759262
DNS Servers . . . . . . . . . . . : 194.168.4.100
                                            194.168.8.100

That didn't come from DHCP??
everything else looks OK
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9759265
do a
NSLOOKUP
www.cisco.com
server 192.168.0.1
www.cisco.com

and post the output?
0
 

Expert Comment

by:claylj
ID: 9759271
Getting your IP address from the DHCP server is a OSI layer 2 function. Ping is a ICMP function at layer 3. It is very possible to be able to get an address via DHCP but ping and other IP functions not work correctly. If you can ping the loopback address and the assigned IP address then the TCP/IP stack for that machine is probably functioning correctly.

You tried another, known good, cable. This leads me to believe that there may be a problem with the port on the router that this machine is connected too. Try another port that is known to be working correctly.

If that doesn't work you may need to install a network protocol anaylizer and look at what is happening on the network when you are trying to ping. You should install an anaylizer on both the new machine and one of the machines that is working.

There is a free anaylizer here http://www.ethereal.com/
There is a learning curve to using an anaylizer, but it should point the way to the problem.
0
 

Author Comment

by:jonnyvaughan
ID: 9759599
ok I ran ethereal and checked out the packets it was sniffing. Seems like the XP pc keeps asking where the gateway is (192.168.0.1) and the router replies giving the MAC address, but seems like the XP pc doesn't actually record this in anyway. Then the router asks everyone else to tell the XP pc which mac address it's at.

Also, none of the ICMP ping packets show up when I try to ping.. which i thought was odd.

Absolutely no idea what to do about that! I think I'll just have to buy a seperate NIC.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9759791
Have you tried simply swapping the patch cable to another port on your router, and doing a release/renew?
0
 

Author Comment

by:jonnyvaughan
ID: 9759907
Yeh I've tried that too.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9759944
Do you have any other networking-type services running on your XP?  You said you have the firewall disabled.  How about ICS, routing, any other services not necessary in a peer network?

Check www.blackviper.com to see what services you can safely disable.
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 18

Expert Comment

by:chicagoan
ID: 9760176
DNS Servers . . . . . . . . . . . : 194.168.4.100
                                            194.168.8.100

That didn't come from DHCP??
everything else looks OK
 
Comment from chicagoan

do a
NSLOOKUP
www.cisco.com
server 192.168.0.1
www.cisco.com

and post the output?
 
0
 
LVL 4

Expert Comment

by:mthibaul
ID: 9760473
If you've tried everything related to software, connection, cables, ports, the only alternative left is to replace the NIC with a known good one while re-installing all the network components!

What about the settings for your "Client for Microsoft" in LAN connection properties. Is it still set to Windows Locator?
0
 
LVL 16

Assisted Solution

by:SteveJ
SteveJ earned 60 total points
ID: 9766501
Im assuming you "dummied" the actual MAC address for some strange reason . . . or is your ethernet card actually 01-23-45-67-89-AB?

Steve
0
 
LVL 18

Accepted Solution

by:
chicagoan earned 65 total points
ID: 9766599
I don't think that's a valid OUI!
So what about the mac address and DNS servers and the output from

NSLOOKUP
www.cisco.com
server 192.168.0.1
www.cisco.com

and post the output?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9766654
chicagoan -
is that OUI as in Offline Usenet Interface or OUI as in Open User Interface or OUI as in the French for "yes?"
0
 
LVL 16

Expert Comment

by:SteveJ
ID: 9766740
. . . and are you from Chicago or (ready for rimshot) did your Hispanic wife leave you?

Sorry, I couldn't help it.

Steve
0
 

Author Comment

by:jonnyvaughan
ID: 9766814
Hmm yeh I just noticed that my MAC address for this NIC is rather... errm improbable let's say. I've not changed it, and that's what it seems to think it is.

Luckily though, these nForce2 boards allow you to change the MAC address and the one it's supposed to have is given on a sticker on the motherboard. I'll try getting that setting it back to what it should be - I really don't know what could have made it be that though!?

I'll try that first, then try the other things listed. But I'm assuming that 01:23:45:67:89:AB is a valid address anyway?
0
 

Author Comment

by:jonnyvaughan
ID: 9766882
Right ok, I found the solution to my problem, but only really thanks to SteveJ I think.

Check this thread out about the motherboard, http://www.nforcershq.com/forum/viewtopic.php?t=31614

Seems like ASUS apparently ship this motherboard with an invalid MAC address. Luckily they print it on the mobo as I said before, so I'm gonna use XP to force that MAC address. I'll let you know if it works.

0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9766899
Organizational Unique Identifier -
Noboby is assigned to the OUI 01:23:45 and the improbability of it  ( along with your non-DHCP supplied DNS servers (I'm assuming your broadband router would supply itself) is very fishy and indicates someone or something has been mucking about with your network settings.



0
 

Author Comment

by:jonnyvaughan
ID: 9766957
As I suspected, all is well now, changed the MAC address via Device Manager - didn't even need a reboot and now all is well.

I can't actually believe that ASUS would ship their motherboards with invalid MAC addresses but print the correct one on a sticker on the motherboard. I've been tearing my hair out now for the last few days trying to get this fixed.

Thanks all for all your help, I'll decide who to give points to in a bit when I've re-read the posts.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9766986
Geez - that address is on the EPROM!??

Had a customer with a prom burner once who 'fixed' a bunch of token ring cards by copying a good one.
Took down the Chicago Board of Trade for two hours till I figured it out.
0
 

Author Comment

by:jonnyvaughan
ID: 9767012
Now if anyone can tell me how to force the address in Linux too - that would be much appreciated :)
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9767169
Oh, OUI as in the first three octets of the MAC...  I get it.

If the first 3 octets of the MAC don't correspond to a device manufacturer then you have either messed with the preassigned MAC or someone else has...
I don't see how a nonstandard MAC address would have shipped with an ASUS mainboard.  They are a premium mainboard manufacturer, not a fringe mfr.  An onboard Ethernet interface EEPROM should be shipped with a valid MAC address that identifies the interface circuitry (asic or chipset or whatever) manufacturer.

jonnyvaughan - although the MAC *can* be reset by the user, it is advisable to leave the preassigned, registered MAC address alone, unless you are in a very insular, totally segregated network that does not access the Internet.  ARP has to be able to translate an IP address to a MAC address, and if you aren't using a valid set of MAC addresses, you're asking for trouble.

The only reason I can see that you'd have "bad" MAC addresses assigned is if you are converting from an IPX environment to an IP environment, and some admin somewhere along the line decided to assign MAC addresses to putz with the IPX LAN routing. since IPX node addresses are *Based* on the MAC address rather than how IP is *related* to MAC via ARP.
0
 

Author Comment

by:jonnyvaughan
ID: 9767181
ShineOn, check that link I posted to the nforcershq.com forum and you'll see that ASUS do infact (probably by error) ship this motherboard without a valid MAC address.

Good job they print the one it should be on the motherboard though - and forcing it in Windows is the easy way to do it, or I can reflash the bios with the proper one.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9767297
Shame on ASUS for that.  I believe you, but I am still shocked that a "major" like ASUS - which also has a rep as a "premium" MB Mfr. - would do what you say they did.  

Sounds like they have to fix something in their QA, or they are not likely to maintain their "premium" status!
0
 
LVL 16

Expert Comment

by:SteveJ
ID: 9767352
These are valid locally administered MAC address ranges. No manufacturer should have a 2, 6, A, or E in the second position.

*2-**-**-**-**-**
*6-**-**-**-**-**
*A-**-**-**-**-**
*E-**-**-**-**-**

Glad it's working for you. In Linux, cant you just set the MAC address with ifconfig?

ifconfig eth0 hw ether <address>    (assuming of course that it's eht0).

Good luck,
Steve
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9767438
Steve  - Dunno, I haven't gotten that deep into Linux yet.

I would be very VERY surprised, however, if you were unable to change the MAC address of an interface with Linux.  You can with just about all other OS-es.  

The thing is, you can usually rely on your hardware Mfr to give you a valid, unique MAC address... and not have to concern yourself with MAC address in the VAST majority of cases.
0
 

Author Comment

by:jonnyvaughan
ID: 9767453
Yeh, just read that ifconfig will do it, but resets it back on restart, so have to script that in somewhere to make sure it does it all the time.
0
 

Author Comment

by:jonnyvaughan
ID: 9767558
ok wasn't sure how to split this one, but gave it to chicagoan cos he did point out it wasn't valid, and points to stevej for pointing it out in the first place
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 9767574
Works for me...
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco switch SVI 17 41
Route Summarization 2 33
Cisco iWAN 8 46
CCNA Data center exam questions 8 21
#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
Let’s list some of the technologies that enable smooth teleworking. 
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now