Wireless card not getting route set correctly (Pretty sure)

I am having a problem getting a wireless LAN card to work in SuSE Linux 9.0.  This is the first time I have tried to get a wireless lan card working in any linux version.  Anyway, I have the card working to the point that I can reach the access point.  I know this because I can open up a browser, direct it to the access point web configuration page and configure away.  Of course I can ping the access point too.  But, I cannot reach beyond the router.  Pining anything outside, like my ISPs DNS server, gives me "not accessable".

I am using DHCP, from the access point, to configure both my wired lan and wireless lan connections.  When I have both connections active the response to "route -nNvee" is:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface    MSS   Window irtt   U     0      0        0 wlan0    0     0      0   U     0      0        0 eth0     0     0      0         UG    0      0        0 eth0     0     0      0

When I have only the wireless card active I get the first route line only.  So, it looks like for some reason the routing does not get fully set up for the wireless lan.  And the obvious question is - why not, and how can I get the route to be set up correctly?  Anybody got any ideas?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

When you have only the wireless card active, you do not have a default route
add a default route with gateway on wlan0
robertjbarkerAuthor Commented:
Yes, I tried to do that by setting the default gateway in the Yast network card configuration dialog.  It did not take for some reason. (It would be nice to know why it did not, and why the dhcp did not in the first place since it did for eth0)

So, is there another method for setting that default route?  Two methods come to mind:
 1) Using the "route" command (I suppose I could look up the syntax, but if you know it off the top, could you tell me)
 2) I'm sure there is a configuration file somewhere I could edit directly.  Might you know where it is?
route add MASK

Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

route add -net netmask eth0
also please note, before adding route, first delete the existing route.

#route del default
#route add default gw netmask dev eth0(or u can use route add default gw
# route


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Replace the eth0 by wlan0 in the cmd given by shivsa
since you want to have the default route on the wireless lan card.
robertjbarkerAuthor Commented:
When this was my starting point (route -nNvee):

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface    MSS   Window irtt   U     0      0        0 wlan0    0     0      0

The command that worked was:

ip route add default via dev wlan0

After which I got (route -nNvee):

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface    MSS   Window irtt   U     0      0        0 wlan0    0     0      0         UG    0      0        0 wlan0    0     0      0

With the same starting point as above, when I entered "route del default" I got "SIOCDELRT: No such process"
After this, when I entered
"route add default gw netmask dev wlan0"
I got
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface    MSS   Window irtt   UG    0      0        0 wlan0    0     0      0   U     0      0        0 wlan0    0     0      0

Which did not give me access beyond my access point/wireless router.  I have feeling that specifying "netmask" may have given me better results.

But, anyway, things work now, and thanks for the pointers.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.