Action not allowed

Hi experts
I'm trying to write an agent based on an existing one. So I copied it and tried to paste it, and expected to get the usual new agent called "Copy of .....". However i got an error and it said "You are not authorised to carry out that operaiton".
So i started from scratch with a new agent, pasted in the code from the existing one, altered it as I needed, and tried to save it - but got the same error message.
What's wrong?
Thanks,
Stuart
StuartOrdAsked:
Who is Participating?
 
Sjef BosmanConnect With a Mentor Groupware ConsultantCommented:
Selecting "Enforce consistent ACL" is not without danger, as you found out. It seems all your databases are local, for you are Manager with an empty box, which Notes only gives on a local db where you have all rights.

A consistent ACL acts like a server-based ACL, so suddenly all rights as set in the ACL are adhered to. Which requires that you set the maximum rights for yourself BEFORE you set Consistent ACL. I assume you didn't, hence the change in access rights. You have a Notes ID, and the administrator of a Notes domain can create more ID's.

Quick fix: make a copy of your database under a new name (File/Database/New Copy), and deselect Access Control List at the bottom left. You will then have the original db, albeit under a new name. Then you can start thinking of a correct setup for the rights in your database.
0
 
Sjef BosmanGroupware ConsultantCommented:
First check: How are you mentioned in the ACL? You should be Designer or Manager.
0
 
madheeswarCommented:
Go to File->Database->AccessControlList.

U need to be listed their either in a group or individually.
And u should have access as Manager.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
StuartOrdAuthor Commented:
Yes, I'm shown as a manager, although for some reason all options are ticked and greyed out, and also the user type and access boxes are greyed out, whereas in other d/bs i have the option to uncheck "Delete docs", and can change the other option boxes.
Stuart
0
 
Sjef BosmanGroupware ConsultantCommented:
I sincerely fear that it looks as though you are listed as Manager, but you aren't. What happens if you click on the small button at the bottom-righthand side of the Notes screen, left to the location? You will see your permissions and roles. What does it say?
0
 
StuartOrdAuthor Commented:
On the troublesome one, it says I have designer access. In the box under Groups and Roles, it has listed
(tick) *
(tick) Stuart Ord
In the others, it says I have manager access and there is nothing in this box.

I think I know what's happened. I was asking in another question about restricting access, and it was suggested that I could click the "Enforce consistent ID" box to get it to recognise Notes IDs. I did this but as I didn't know how to create a Notes ID, I did no more. (I've now abandoned that line of thought.)
I've now noticed some other differences. In the ACL for other ones, I'm listed under "default" and "DomainServers" etc as "STUARTS_VAIO/******" which is my computer name & admin login password, whereas in the other ones I'm listed as "Stuart Ord". In the troublesome one, I can no longer open "Advanced" under Access Control.
However I don't know how to fix it!
0
 
StuartOrdAuthor Commented:
Thanks sjef_bosman
Yes you're right, they are all local.
I'll be more careful next time
The fix worked fine
Regards,
Stuart
0
 
David777Commented:
Maybe you don't have right to create shared agent. I think it should be your acl problem, check it on your server and server document.
0
 
David777Commented:
You can't tick the enforce consistant acl..., that will prevent you from pushing your change of acl to server. That's why you still can't create agent even it looks you have manager right.
0
All Courses

From novice to tech pro — start learning today.