Quick report printing problem

My problem is that my report which is actually a receipt of approx 76 mm in width cannot be printed out well using my printer which is epson tm - u210d. so i wonna know why it prints well for like 5 lines then it starts printing junk. Is it memory problem? coz am using data from temporary tables, print and delete the tables immediately.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

>why it prints well for like 5 lines then it starts printing junk
usual this may a cable or device-driver problem

does this problem only raises, if you print with quickreport
or also on other apps?
I really think it is the printers fault. You should try to print froim other programs, because I have built many app using quick report on a lot of different printers (well not so many... 5-8) and I never encontered this kind of behaviour.
You should check your printer.
i also face the print problem by using QReport last time, so i try in crystal report, then it become ok. Dun used QReport...
OWASP: Avoiding Hacker Tricks

Learn to build secure applications from the mindset of the hacker and avoid being exploited.

mkebeAuthor Commented:
ok.. i tried printing directly to the port using dos programs and it prints well. But when i use windows applicatios like notepad, it can print for so long like 30 lines before it starts printing junk. So thanks for your contributions, i also start to think that it's the drivers problem, coz actually i have not found drivers for XP for this printer so am using 2000 drivers- but in manufactrers website they say for 2000 and XP yu can use this drivers, so i do no what to do.
go here


and try the description

Installing a Epson USB receipt printer

meikl ;-)
mkebeAuthor Commented:
I went there, but my printer is connected to a serial port(COM1) -not a USB, when i install the USBID it says it can't find no printer, and those drivers i have installed still don solve the problem..
Well, if your printer is connected to the COM port then you should not install the USB drivers then... it's obvious isn't it? :)Try to uninstall your printer and reinstall it from Settings/Printers or control panel and reinstall the com drivers. And if it still doesn't work you should take your printer to your EPSON reseller where you bought it and give it back or ask them to repair it because I really think it's not the driver. It's probabely the RAM of the printer...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.