Win98 network drive not connecting when logging on to my XP box.

Okay, this should be an easy one, but it's been buggin' me, and I haven't found a fix for it yet.

Here's the situation:
My main PC is networked via my router to an old backup Windows 98 PC.
I save a lot of data, old docs and such on it via a network drive.

However...whenever I boot up, my Windows XP box says it "could not reconnect to all network drives".
My network drive is X'ed out, yet when I click on it, it connects to the networked PC, and is fine from then on.

My question is, how can I get it to connect, and stay connected at logon, without having to select it every time?

Thanks!
Inward_SpiralAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirbountyCommented:
Perhaps this PAQ will help: http://www.experts-exchange.com/Networking/Microsoft_Network/Q_20371868.html
>>>>
Quoting MS:

To resolve this behavior, increase the IRPStackSize value on the server: Click Start , and then click Run . Type regedt32 , and then click OK . Navigate to the following key:

HKEY LOCAL MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

In the right pane, double-click the IRPStackSize value.

NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:

In the Parameters folder of the registry, right-click the right pane. Point to New, and then click DWord Value. Type IRPStackSize.

IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.

Change the Base to decimal. In the Value Data box, type a value that is larger than the value that is listed. If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14 , and then click OK. Close the Registry Editor. Restart the computer. If the problem persists after you complete the preceding procedure, try to increase the value of IRPStackSize even more. The maximum value for Windows 2000 is 50 (0x32 hex)"
<<<<
0
sirbountyCommented:
Also - http://www.experts-exchange.com/Operating_Systems/WinXP/Q_20330310.html
>>>>
Basically, when you connect to another computer with Windows XP, it checks for any Scheduled tasks on that computer - a fairly useless task, but one that can add up to 30 seconds of waiting on the other end - not good! Fortunately, it’s fairly easy to disable this process. First, navigate to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version/Explorer/RemoteComputer/NameSpace in the Registry. Below that, there should be a key called {D6277990-4C6A-11CF-8D87-00AA0060F5BF}. Just delete this, and after a restart, Windows will no longer check for scheduled tasks - mucho performance improvement!
<<<<
0
Fatal_ExceptionSystems EngineerCommented:
As I no longer use any W98 machines to serve folders on a network, I am not quite sure these will work in your case, but they will automate connecting to network shares in general.  I have used them to automate a connection from WXP Home to a domain.  

Here is something to try:  

This can be used when connecting to a Domain from a XP Home box and run as a batch file:

net use f: \\SERVERNAME\SHARENAME /user:DOMAIN\USERID

Or, maybe this (easier and reliable):

Open the My Computer object, click the Tools menu, and then click Map Network Drive.
Select a folder on your network by clicking on the Browse button.
After selecting the folder, click on the different user name link on the page.
In the Connect As dialog box, for user name enter domainxxx\user (where domainxxx is the domain you want to connect to). Enter your domain user password and then click OK.
Check the Reconnect at login box and press Finish.
When you boot up in the morning, go to My Computer and double click on the networked drive. This causes XP to send the credentials to the Domain and opens the drive.

FE


0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Fatal_ExceptionSystems EngineerCommented:
Forgot to add, you can automate these by using gpedit.msc (only if you are using XP Pro).  Drill down to Computer Configuration > Admin Templates > Logon > Run these programs at user logon.  Enable the policy and stipulate the batch file location and name.

Hope this works for you.

FE
0
Inward_SpiralAuthor Commented:
Thanks for the comments!

Funny timing, though. As soon as I post the question, I start having network troubles. I'll get those sorted out, and try these fixes asap.
0
Inward_SpiralAuthor Commented:
Sorry for the delay, but I've tried both of them on the machine, and I still have the "could not connect to all network drives" message upon bootup.

Any other suggestions?
0
Fatal_ExceptionSystems EngineerCommented:
Can you use the Net Use command from a command line to connect?  Just to test to make sure your syntax is correct?

If so, then the batch file should work, so lets try to narrow down the problem.

FE
0
Inward_SpiralAuthor Commented:
See, I'm not connecting to a domain, I'm just accessing shared folders on another PC on my network.

Since there's no domain to send this to, I didn't think the batch file would work.
0
Fatal_ExceptionSystems EngineerCommented:
You can use the Net Use command to connect to a share in a workgroup.  I just use the above when I am confronted with a workgroup computer accessing shares on a domain.

The syntax is similar.

For instance, if you want to connect to another shared folder "Data" on computer "computer1" in a workgroup you could:

net use e: \\computer1\Data

and if you want this connection restored each time you boot:

net use e: \\computer1\Data /persistent:yes

Does this help?

FE
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Inward_SpiralAuthor Commented:
Yep, looks like that did it. Thanks!
0
Inward_SpiralAuthor Commented:
Also, I was able to give sirbounty's suggestion a second try after I cleaned up the registry, and got that one to work too, so I'm splitting the points here.

Thanks to you both!
0
Fatal_ExceptionSystems EngineerCommented:
Great

Happy Holidays

FE
0
Ramond81Commented:
I did that net send thing and it keeps on saying, windows credential expired. I just want to know how do I get rid of that pop up from coming up again, because I do not get that error, "Could not reconnect all network drives" anymore because I had went to the control panel, and went to user accounts and added the username that I am using to connect to the domain server and made it an administrator and it worked. I just want to know how do I get rid of that windows credential needed when I double click onto a folder being shared from the server?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.