Computer locks up sporadically while printing to a DeskJet 720c

I'm running a Windows 2000 computer and just installed a HP DeskJet 720c.  When I try to print various items the computer will lock up.  This happens with different apps and files but locks up every time as soon as I start to print.
LVL 1
HeathAdamsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

WillHudsonCommented:
You might want to turn off spooling to see if this fixes the problem.

Start --> Settings --> Printers

Right-click --> Properties of the 720.

Go to Advanced Tab - Select the "Print Directly to the printer" option
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wonkotsaneCommented:
I have a HP Deskjet 620C and have the same problem.  It's the print process taking all the resources.  I think it's just resource hungry printer drivers to be honest.  I have a 2.66MHz P4 with 512Mb RAM and it slows that down to a crawl.
0
lepiafCommented:
Do you hook it up on the parallel port? You may want to make sure to set a low timeout value for this port (play with 'ignore EOF char' as well) and also check whether any other virtual printer is using the same port and if so change the port for that one.

Also check in your BIOS settings that the correct transmission protocol (i.e. ECP) is being used on lpt1 instead of setting to autoselect.

Is this a PCL or a PS driver? Can you use a generic one instead of manfacturer's?

In printer properties\advanced set to 'spool prints so....' and check 'start printing immediately' or indeed to 'print directly..'. possibly uncheck 'enable advanced printing features' and make sure to use raw data format.

Then do 'net stop spooler' and 'net start spooler' from command prompt and you're done.

My 5 cents ;)

Cheers,
LePiaf
0
WillHudsonCommented:
Have you tried my fix? It seemed to have worked for the other person
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.