[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 370
  • Last Modified:

GUI Login

I have a sunblade 100 running solaris 8, when it boots up it is at a command line login, how do I change this back to a GUI login
0
CMILLER
Asked:
CMILLER
  • 4
  • 4
  • 3
2 Solutions
 
shivsaCommented:
dtconfig -d
0
 
CMILLERAuthor Commented:
I typed that at the #dtconfig -d,  got a file or command not found
0
 
yuzhCommented:
type in:

/usr/dt/bin/dtconfig -e

man dtconfig

PS:  -d  Disable
       -e  Enable
0
Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

 
shivsaCommented:
Yuzh has given u full path, run this and enable the GUI.
0
 
CMILLERAuthor Commented:
I ran the command # /usr/dt/bin ./dtconfig -e , it reported that it was enabled, but
it still has a command line login
0
 
shivsaCommented:
what is your run level.
send us output of who -r command.
if this tells u 2 then try executing
init 3

0
 
CMILLERAuthor Commented:
it is running at " Run-Level 3 "
0
 
shivsaCommented:
could u please check that about these files.
ps -aef | grep dt

and send me the output.
also try to /usr/openwin/bin/xdm manually. this will start Xserver and rest of dt scripts.

0
 
yuzhCommented:
In Commandline, type in:

/etc/rc2.d/S99dtlogin start

see what happen
0
 
yuzhCommented:
Forgot to ask you a question:

did you do:
/usr/dt/bin/dtconfig -e

in single user mode and bring up to multi-user mode?
0
 
CMILLERAuthor Commented:
Output of:
ps -aef |grep dt

root 102 95 0 14:33:25 0:00 grep dt

That tells me its not running

******************************
I tried the /etc/rc2.d/S99dtlogin start

It starts and displays text saying that it has started the gui desktop but hangs at that point.

After a hour it was still at that point, I tried a stop A it would not do anything I had to turn off the machine and when it rebooted it was still at the command line login.

******************************
I did it when logged in as root, not sure what you mean?

At the ok prompt i typed BOOT so I guess I was in Mulit-User mode.

I reboot with a boot -s and ran the /usr/dt/bin/dtconfig -e
and it said "desktop auto-start enabled"
I typed exit, then it said " init: new run level:3, system ready

I did a init 6, it still came up in a command line login.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now