[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Unable to relay (problem with outgoing mail)

Posted on 2003-11-18
3
Medium Priority
?
11,821 Views
Last Modified: 2007-12-19
Hi,

I have two Exchange 2000 native servers, in two site (A
and B, different subnets). Site A is the first site, site
B was added to the AD. Everything worked well untill
suddenly site B Exchange can't send e-mail (receiving is
not a problem). The sender on site B will receive a NDR
stating that

"You do not have permission to send to this recipient.  
#5.7.1 smtp;550 5.7.1 Unable to relay for ......"

And debug event log (SMTP) shows:

Event Type:    Information
Event Source:    MSExchangeTransport
Event Category:    Routing Engine/Service
Event ID:    984
Date:        11/18/2003
Time:        4:26:36 AM
User:        N/A
Computer:    EXCHANGEB
Description:
SMTP GetNextHop returned hr=0x0 in 0ms.
 DestAddr=<hotmail.com>, Type=<SMTP>
 MsgType=0x2, NextHopType=SAME_ROUTING_GROUP
 Type=<SMTP>, Class=<*>, SchedId=0x0
 RouteAddr=<_29a09342cdd6be4a91c67ee04e646032_S>
 Connector=<4293a029-d6cd-4abe-91c6-7ee04e646032>

Event Type:      Warning
Event Source:      MSExchangeTransport
Event Category:      Connection Manager
Event ID:      4001
Date:            11/18/2003
Time:            9:12:50 AM
User:            N/A
Computer:      EXCHANGEB
Description:
Message delivery to the remote domain '_29a09342cdd6be4a91c67ee04e646032_S' failed.  The error message is 'An SMTP protocol error occurred.
'. The SMTP verb which caused the error is 'RCPT'.  The response from the remote server is '550 5.7.1 Unable to relay for aad@palms.nl
'.
Data:
0000: d7 02 04 c0               ×..À    



followed by NDR notification.


Any idea what the problem can be?


PS:

Also the following problem when trying to reinstall Exchange 2000 SP3:

---------------------------
Microsoft Exchange 2000 Installation Wizard
---------------------------
The component "Microsoft Exchange Messaging and
Collaboration Services" cannot be assigned the
action "Update" because:

 - You must be at least an Exchange Full Administrator at
the Administrative Group level to run update. You must use
an account that has been granted the Exchange Full
Administrator role on the current administrative group, or
a higher-level role, using the Exchange Administrative
Delegation Wizard.

 - Setup is unable to access the Windows 2000 Active
Directory

- Failed to contact the Schema Master server for this
Active Directory forest.

0
Comment
Question by:2good2
3 Comments
 
LVL 26

Expert Comment

by:Vahik
ID: 9771549
Most likely ur site two has problem with DNS servers.That is what ur
erroe message is telling u.Make sure ur site B does have a dns server
available and also a site B can contact a GC.
0
 
LVL 1

Author Comment

by:2good2
ID: 9775601
How can I check this. SiteB sever has DNS Server installed. How can I see if replication works? When I go to AD Sites and Services, go to Site2 (different subnet) > EXCHANGEB server > NTDS Settings and force a replication withe the EXCHANGEA server I will get the following message:

---------------------------
Replicate Now
---------------------------
One or more of these Active Directory connections are between domain controllers in different sites and cannot be replicated immediately. Active Directory will replicate these connections at the next opportunity.
---------------------------
OK  
---------------------------

If I check the eventlog nothing seems to happen. How can I be sure DNS is working fine and so is the replication to the EXCHANGEA (in Site1)?
0
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 2000 total points
ID: 9779748
OK, here's what happened: SMTP fixup protocol was turned on, on his PIX 515. the GC replication was a different and separate routing issue altogether. I didn't bother to ask, because of the ISA servers he had in place, it never occurred to me to ask about the PIX. I'll NOT make that mistake again, mailguard absolutely trashes mailflow. It guards it alright, to the point where you don't have it :) When fixup was turned off, mailflow was re-established.

We actually did remove a GC, but because of the routing issue, the same replication errors were still seen. All that got cleaned up. the reason he got the Schema Master error is because he moved it to another site, and the replication had not happened.

the issue has been resolved. thanks vahik, I'll throw some points your way, I appreciate the input :)

David

0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question