Solved

Linux Help Please!

Posted on 2003-11-18
19
582 Views
Last Modified: 2013-12-06
Help!!

I've been locked outside my linux box !

Everything was going nice and fine until i needed to reboot it... which is when I was presented with Grub's command Prompt interface.

- I dont have a boot disk
- Cd wont boot at startup (even though i set it up through bios)  (hmmm?)


how do i boot into linux redhat 9 ?!


Cheers

0
Comment
Question by:11ods
  • 5
  • 5
  • 3
  • +4
19 Comments
 
LVL 20

Expert Comment

by:Gns
Comment Utility
Did you do anything... like move the harddrives round... at the "reboot time"?

-- Glenn
0
 
LVL 2

Expert Comment

by:asbharadwaj
Comment Utility
Can you tell exactly what you were doing before the reboot
and why you needed to reboot your machine?
0
 
LVL 4

Expert Comment

by:victorbx
Comment Utility
in the grub command prompt

type    linux single
or type linux 1

it will let you in  

then fix all the mistakes you have done



victor
0
 

Author Comment

by:11ods
Comment Utility
'linux single'
or
'linux 1'
dont work..

i dont remember doing anything special before the reboot...
I think something froze so i rebooted, and then this happened..
no change in hardware, no change in harddrives.. nothing ..
0
 
LVL 2

Expert Comment

by:asbharadwaj
Comment Utility
Seems Grub isn't able to find any image to boot
so it takes you to the prompt and leaves you there
Iam not very familiar/comfortable with Grub
do you remember the name you have given to your
default linux image in your grub.conf file?
If yes, try
boot imagename or
boot imagename single
at the grub prompt
I think you can edit the conf file at the prompt itself though Im not sure
If so, you can look into the conf file and try with the name
0
 
LVL 20

Expert Comment

by:Gns
Comment Utility
Ok, and prior to the "freeze" you weren't mucking about with fdisk, mkfs or some similar tool?
The reason I ask is that your filesystem(s) might have gotten hosed... And those could very well do it.

We know that the MBR is OK, since you get dumped directly to the grub> prompt... this indicates that grub runs, but cannot find it's "supporting" files. grub (unlike lilo, which use fixed adressing to get them) needs be able to read the filesystem where /boot is situated, and for some reason it's failing.

How many drives do you have? Did this system dualboot?
From the grub> prompt we should be able to determine _something_ about the linux partitions... like if they are there, and perhaps also if they are "mendable"... They might just have been "hidden":-). I've not tested the following (too lazy to reboot:-), but...
the "help" command is your friend, as well as the <TAB> key.
just type
help
to see what commands you have, and perhaps do
parttype (hd<TAB>
to get a "completion" of available disks... and
parttype (hd0,<TAB>
for a similar list over available partitions. You don't have to actually go through with the parttype command, unless there is something wrong with them (linux partition(s) tagged as "something else"... might be because of an erroneous "hide" command).
If the partitons look OK, one could try to use find to find the main grub config file menu.lst (default is /boot/grub/menu.lst ... contrary to popular deception (grub.conf et al);-).
Start with that and tell us what you see/get.

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
Comment Utility
If you can get hold of a floppy-rescue, that might help (since you cannot boot a CD rescue). http://www.toms.net/rb (tomsrtbt) is a very nice "linux on a floppy", just for situations like this.
Might make you feel less like "groping in the dark" that you might be feeling with grub:-).

-- Glenn
0
 

Author Comment

by:11ods
Comment Utility
Ok,
so here's what I have for you: (even some good news maybe)

Gns: prior to the "freeze" i wasnt mucking about with any program except for trying to install the official rpm's for php-mysql (which also didnt work ..*sigh*)
--------------------------------------------------------------------------------

I have 2 drives, but only 1 in use. 1 OS: rh9.

here's what i get for 'parttype (hd0<TAB>
Partition num: 0, Filesystem type is ext2fs, Partition type 0x83
Partition num: 1, Filesystem type is ext2fs, Partition type 0x83
Partition num: 2, Filesystem type is unknown, Partition type 0x82

how does that looK?
------------------------------------------------------------------------------------

when using the find command, say for example:
find menu.lst   (or even for the hell of it: menu.conf) i get:     Error 15: File not found
---------------------------------------------------------------------------------------
I also somehow found the startup disk that was created by linux setup !
and after some stuff runing down the screen i get the following:
Warning: unable to open initial console.
and thats where that ends...
------------------------------------------------------------------------------------
i'm considering just reinstalling linux and problem solved.  how bad is the situation ?

Thanks!
0
 

Author Comment

by:11ods
Comment Utility
I cant even reinstall ... cant boot from cd drive.
last time i installed was booting from a harddisk.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 12

Expert Comment

by:paullamhkg
Comment Utility
"last time i installed was booting from a harddisk. " Can you repeat the same procedure as last time you install the linux? if yes, try to do the same and let the installation to upgrade your RH9 instead of install, for doing a upgrade you may get a chance to recover your RH9 without a reinstall.

info about RH9 upgrade

The installation process for Red Hat Linux 9 includes the ability to upgrade from prior versions of Red Hat Linux (version 6.2 and later which also can upgrade the same version) which are based on RPM technology.

Upgrading your system installs the modular 2.4.x kernel as well as updated versions of the packages which are currently installed on your system.

The upgrade process preserves existing configuration files by renaming them with an .rpmsave extension (for example, sendmail.cf.rpmsave). The upgrade process also creates a log of its actions in /root/upgrade.log. As software evolves, configuration file formats can change, so you should carefully compare your original configuration files to the new files before integrating your changes.

Note
It is always a good idea to back up any data that you have on your systems. For example, if you are upgrading or creating a dual-boot system, you should back up any data you wish to keep on your hard drive(s). Mistakes do happen and can result in the loss all of your data.
 
Some upgraded packages may require the installation of other packages for proper operation. If you choose to customize your packages to upgrade, you may be required to resolve dependency problems. Otherwise, the upgrade procedure takes care of these dependencies, but it may need to install additional packages which are not on your system.

Depending on how you have partitioned your system, the upgrade program may prompt you to add an additional swap file. If the upgrade program does not detect a swap file that equals twice your RAM, it will ask you if you would like to add a new swap file. If your system does not have a lot of RAM (less than 32 MB), it is recommended that you add this swap file.


If the upgrade can't work, re install will be the last choice, but don't know whether you can repeat the installation procedure as you did by harddisk?
0
 

Author Comment

by:11ods
Comment Utility
well....

i dont have an OS running in order for me to put the redhat files on the harddrive...

which means,
cant reinstall, upgrade or anything until i either get into linux through grub,
or get my cd to boot somehow....
or fix whatever was wrong with the floppy startup disk (as i mentioned above)...

... at least thats how i see things right now...
0
 
LVL 12

Expert Comment

by:paullamhkg
Comment Utility
try using the small linux as Glenn suggest you can also get the other one here http://www.itm.tu-clausthal.de/~perle/hal91/ or check here http://dilbert.physast.uga.edu/~andy/minilinux.html.

and try to change the thing you wanted, or even use the small linux to mount your cd rom to see the cd rom is working or not.
0
 
LVL 20

Expert Comment

by:Gns
Comment Utility
The partition list looks good (0x83 == Linux native, 0x82 == Linux swap), so then it is the /boot filesystem that is probably hosed in some way... This can have happened some time prior to the freeze/(non-)boot, since most (if not all) files under that directory are only used exclusively during boot.

How very frustrating that you cannot boot a CD... You've rechecked the BIOS settings and tried with a few different CDs I'd imagine(?)...
What type of machine is this? Does it have a floppy drive?

-- Glenn
0
 

Author Comment

by:11ods
Comment Utility
Well,
what ended up happening with this is i took a cd drive off another computer, installed it in the linux box, and booted from CD that way ...   dont know why it wouldnt boot off my first cd drive..

0
 
LVL 12

Accepted Solution

by:
paullamhkg earned 250 total points
Comment Utility
Well there may be some dirt in your CD ROM, try to get some CD rom cleaner to clean it and try to use it again, may be this will help.
0
 
LVL 20

Assisted Solution

by:Gns
Gns earned 250 total points
Comment Utility
Ok... And booting rescue from the working CD, you could see something wrong with /boot? Or did you simply do a reinstall?
What brand was the non-working CD? As has been actualized recently (Mdk9.2 triggering a stoopidness in a slightly old LG firmware), not all drives/firmwares are that great:-)... Or it might just be dirty, as Paul suggests

-- Glenn
0
 
LVL 1

Expert Comment

by:Palinf
Comment Utility
If I understand well and if you didn't solve the probleme :

First of all, you must enter in your box: there is few ways :
cdrom boot: your computer doesn't seem to have the ability

floppy boot:
On "http://www.debian.org/releases/stable/i386/ch-install-methods.html#s-create-floppy" you can find how to create boot disk from unix or windows workstations with different kernel to support your hardware.

windows boot:
If there is windows os on the computer you can find way to boot on "http://www.debian.org/releases/stable/i386/ch-rescue-boot.html"

if you need help to use it, ask!
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
Comment Utility
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Answered by paullamhkg and Gns
Please leave any comments here within the next four days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

khkremer
EE Cleanup Volunteer
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

The purpose of this article is to demonstrate how we can use conditional statements using Python.
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now