Cannot get XP network to work.

I have used networks in the past with no problems, probably as far back as Windows 3.11 for workgroups. But since switching to XP Pro I have not had much success. I have set up the networking on all systems and have named the workgroup the same on all systems. I have been thru wizards, troubleshooting etc.. I sometimes can see the different systems, but that is it. I cannot connect to any of them. At one point I was able to use a shared folder if I needed to transfer files. Looking for suggestions.

Thanks ,
Wayne
wjoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nmcdermaidCommented:
XP comes with a fiewall that is on by default.

We networked a bunch of machines and everything worked perfectly except for the XP one. We finally worked out that its default firewall was on. Turned it off and all was fine.
stevenlewisCommented:
In addition to the good advice above, enable NetBIOS over tcp (it is off by default) on Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.
Is this a purely XP network, or are there other systems involved?
wjoAuthor Commented:
Sorry guys and gals, still a no-go. Fiewall was already disabled, but good start. Tried everything else. Computer Browser was already started, so the STARTwas greyed. I did RESTART on it but that also did  nothing. I am going to ask a dumb question. I once had a neywork with NetBuei. (no LOL!!!) Well there was a time when I took this MCSE course and the trainermade fun of NetBuei So I went home from class and disabled it. (Think it might have been on NT 4). Well my network would not work after that. So can my problem be something stupid like that?
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

wjoAuthor Commented:
All systems are on XP. No other O/S.
TBounCommented:
I don't know about the Netbuei, but you should make sure your only using one networking protocol, ie TCP/IP.  Delete any unnecessary protocols.  

Also, are you using a switch or hub? and are the NIC's on the pc's set for auto-sense.  If you are using a switch/hub you should check to see if it is auto sensing.  If one of the Nic's is set to 100mb full duplex and the switch only accepts 10mb, that pc won't be able to access the network.  You could also try pinging each of the pc's as well to test communication between them.
stevenlewisCommented:
You could add NetBEUI, but XP shouldn't need it
Is NetBIOS over tcp enabled?
wjoAuthor Commented:
no switch or hub, but I am using a router. I did have an extra protocol in one system but I removed it and it did not make any difference (well at least not at this point anyway). Yes NetBIOS overover TCP is enabled. All systems on XP. Just remembered I am also running Zone Alarm. Maybe a firewall issue with that or the router? I can access the Internet on all systems. I can ping say system "A" and get a reply from system "B", but if I try to ping "A" FROM "B" it won't reply. I can see I am a little rusty at this. Been a while since I had to mess with all of this stuff.
TBounCommented:
Could be the firewall.  Try disabling Zone Alarm on both Pc's.  Also, what protocol are you using for your network?  TCP/IP?  Are both computers in the same subnet?  ie 192.168.0.x
and have the same subnet mask?  Does your router handle DHCP or did you statically assign the IP address?  If the router handles DHCP, make sure both PC's are set to get their IP's automatically.  If the router isn't doing DHCP, make sure you disable that feature on the router and manually assign IP addresses for both PC's.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stevenlewisCommented:
check to make sure that 192.168.0.0/255.255.255.0 is in your trusted zone
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.