Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 642
  • Last Modified:

RDIST Warns that, "Version Numbers Don't Match."

Background: The systems are SunBlade1000s running OS5.8 and Solaris 8. rdist is installed on all hosts and will perform the basic function of notifying what changes need to be made by using the "-n" switch. However, if I remove the "-n" switch to allow the update to be made, the operating system issues the following error message:

rdist: connection failed: version numbers don't match

Question: Is this error message telling the me truth, or is it one of those I-really-don't-know-so-I'll-give-you-any-ole-answer kind of error messages? It seems to me that if there really were a mismatch in version numbers (and admittedly, I have no idea how to check them), even the command with the "-n" switch would fail.

Any ideas on how to fix this?

Cheers!
0
pdouglas
Asked:
pdouglas
1 Solution
 
yuzhCommented:
Have your setup the .rshosts file, and the boxes know each other?

type in :

rsh remoteBox echo test

to see if "test" echo back on your screen. if it doesn't work, your "r*"
command is not setup properly. (or "r" service has been disable)

man rsh
man rdist

You can also run rdisk in debugging mode, use "-D" option, to see what the
problem is.

BTW, rdist, rsh is not secure, consider to use secure shell to do the job, you can
download openssh from: (Free):

http://sunfreeware.com/

Do a search at EE, you can find out a lot of infor about how to install and set it up (including
setup ssh without password)




0
 
pdouglasAuthor Commented:
I'm beginning to suspect that you're right about the r* service not being set up correctly. But it doesn't quite make sense. I can rlogin to the remote boxes. However, rcp doesn't work and when I issue the test command "rsh remoteBox echo test", the OS comes back with, "stty: : invalid argument."

I have put the entries for all appropriate host names into the .rosts and hosts.equiv files. What else should I be doing to have r* correctly configured?
0
 
TintinCommented:
Suggest you use rsync instead of rdist.  It's a lot more secure and a hell of a lot more bandwidth efficient.

See http://rsync.samba.org/
0
 
yuzhCommented:
If you want to allow root to use rdisk to send files from boxA to boxB,
you need to create a .rhosts file under root's home dir (have a look at /etc/passwd
file to see where the root's home is) in boxB

vi .rhosts

boxA.somewhere.com  root

save it, then:
chmod 700 .rhosts

#Please get rid of the .rhosts file when you are not using rdist. boxB need to know boxA
(you can definde  it in //etc/hosts file, put it in both machine)
0
 
zdesCommented:
Most likely you have a different version of rdist  picking up server responsibility. For example, you have a version of rdist built from the sources on the machine initiating the connection, and OS-provided version on the other end. Better use -p option of rdist and specify the path to rdistd explicitly:

Here is what I have:
%: alias rdistcmd
rdist -onochkmode -p /home/tools/sys/solaris/bin/rdistd -c

And do take a look at rsync, as it was already suggested - a very nice tool.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now