Solved

Exchange Attachment Limits

Posted on 2003-11-18
7
2,835 Views
Last Modified: 2007-12-19
Exchange keep kicking out large attachments.  I have changed the SMTP virtual server to "no limit', and the message delivery (under Global Settings) to "no limit", and made sure there were no limits on the users mailbox, but it still keeps giving me:

<<<552 Requested mail action aborted: exceeded storage allocation 554 5.0.0 Service Unavailable>>>

and

<<<552 5.2.3 Message size exceeds fixed maximum message size (5000000) 554 5.0.0 Service unavailable>>>

Do I need to stop and start all the exchange services for these settings to take place, or am I missing something?

Bryant
0
Comment
Question by:dukesite
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 8

Expert Comment

by:JasonBigham
ID: 9773978
Mail you are getting or sending?

if it's sending the destination mail server is generating the message.  Not your local server.
0
 

Author Comment

by:dukesite
ID: 9773990
It's local.  Several sending mail servers are reporting the same issue.  Mail being sent to our server is being kicked back.

Bryant
0
 
LVL 8

Accepted Solution

by:
JasonBigham earned 125 total points
ID: 9774026
Are you using a gateway of any kind? I do, thus nothing I set on the Exchange side matters... as the gateway decides this.
0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 

Expert Comment

by:javadogwv
ID: 9775277
In Exchange 2000 there are several places that the message size is set.  

There is a global setting, Exchange System Manager > Global Settings > Right-click Message Delivery, and then click Properties >Default tab to configure the Receiving message size and the Sending message size.

If you are using a connector (to other servers) then adjust the Connector Setting

System Manager > Administrative Groups > expand your Administrative Group Name > Routing Groups (if applicable) > expand Routing Group Name, Expand Connectors, right-click the connector that you want to configure, and then click Properties. > On the Content Restrictions tab, under Allowed sizes

You said you adjusted the SMTP virtual limits at

System Manager > Administrative Groups > Your Administrative Group Name > Servers > Your Server Name > Protocols > SMTP node > Right-click SMTP Virtual Server Name, and then click Properties. > Messages tab to set the maximum size that you want to permit

And lastly at the individual user level

Active Directory Users and Computers snap-in >  locate the user account > Right-click the user's account, and then click Properties > Exchange General tab > Delivery Restrictions to set the maximum size that you want to permit.

Of course all of these limits work together.  A 2MB limit at the Global settings limit would trump a 3 MB on the SMTP virtual server

0
 

Author Comment

by:dukesite
ID: 9779956
Thank all of you for your suggestings and help.  Here's what I found:
All of the places I mentioned and all of you mentioned were checked and re-checked, but it wasn't any of those settings causing the problem.  The client neglected to tell me (I am a consultant), that they were using a WatchGuard Firewall with and SMTP proxy.  In the proxy configuration, under inbound, the default setting was a maximum of 3000KB (obviously, 3MB or so).  I kicked the number to the maximum allowed by the Watchguard software (30000KB) and it worked.

Points of interest:

During testing, I found that Exchange/Watchguard Proxy takes the lesser of the values specified in all locations.

If you are using a Watchguard Firewall SMTP proxy, you cannot allow attachments larger than 30MB

I had to stop and start the SMTP virtual service to get the values to take.

I telneted to port 25 of the mail server and used the:

EHLO mail.domain.com

The response gave me several values, the one of interest was:

SIZE = 3072000 (which is what pointed me in the WatchGuard Direction


The only thing I find strange is that the original error message in the NDR was reporting a maximum of 5000000 (or 5MB), when the watchguard was set to 3MB.  I fixed the problem, but I still don't understand that one!

Thanks for all your help,

Bryant
0
 

Author Comment

by:dukesite
ID: 9779965
Gave the points to JasonBigham since he was leading in the direction of a Gateway or other unit.

Bryant
0
 
LVL 2

Expert Comment

by:fendermb4
ID: 10280880
Just a point for posterity here...
If you put in 0 for the maximum size in the watchguard proxy, it will have no limit.  So you CAN allow attachments larger than 30mb.

Regards,
Rick
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question