SQL Server installation problems

Hi,

Im having a nightmare trying to install SQL server Evaluation Version onto Windows XP Pro.

In the installation, at the service accounts section, it just wouldnt recognise any of the Windows Accounts that are on my machine, therefore i using a Local System Account so i could come back and change it afterwards.

Now when i go to Tools > SQL Server configuration Properties > Security and try and change the Startup Service Account from a Local System Account to a domain user account i get the following problems.

If i just use

Username : Administrator
Password : Password

i get the following error message

Error 15407 : 'Administrator' is not a valid Windows NT name. Give the complete name: <domain\username>.

So i try that using

Username : Computername\Administrator
Password : Password

and i get the following error message

Logon Failure : the user has not been granted the requested logon type at this computer.

This is really confusing as i am logged in as Administrator, so i have every permission there is. I seem to remember something like this once before and im sure it was to do with having service pack 1 installed, but, in this case ive got all the microsoft updates that there are.

Can anyone help as this is driving me mad?

Thanks in advance

Al
higgsyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NightmanCTOCommented:
Logon Failure : the user has not been granted the requested logon type at this computer

Administrator needs to be granted the ability to login as a service. I believe that this is not enabled by default.

Cheers
Night
higgsyAuthor Commented:
Hi nightman,

how would i do that?
NightmanCTOCommented:
Usually under User manager for domains - User Rights - show advanced rights, select allow account to login as service - OK.

HOWEVER, I think this requires a domain server, so if you're on a stand-alone machine and not on a network, it may not be available. Usually on a stand-alone machine, this is automatic.

Hope this helps
Cheers
Night
arbertCommented:
Go into your Services in Control Panel/Administrative Tools.  If you change the account on the actual service, Windows by default (if you're logged in as administrator) will give the account the ability to logon as service.

Brett

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.