Solved

Mounting Public Folder store gives internal processing error c1041724

Posted on 2003-11-19
29
15,808 Views
Last Modified: 2009-04-02
I know this topic has been discussed before, but I have been through all the discussions I could find as well as MS KB articles are I am still having problems.  So here's my problem and what I have done so far.

4 days ago my backup job (veritas backup exec) reported that my public folder database was a corrupt file.

I looked in Exchange System Manager and sure enough, it would not mount.  My Mailbox store still mounts and runs just fine.  My public folder database size is 8MB so it is quite small.  I DO have a backup from the day before this started happening.

When I tried mounting it, I received the error "An internal processing error has occurred.  Try restarting the exchange system manager or the microsoft exchange information store service, or both.  Id no: c1041724 Exchange System Manager"

My event viewer reports only 4 events:  The first 3 are informations and the 4th is the error
     1.) The information store database "First Storage Group\Public Folder Store (EXCHANGE)" is limited to 16384 MB.
     2.) Attempting to start the Microsoft Exchange Information Store "First Storage Group\Public Folder Store (EXCHANGE)".
     3.) Allocating message database resources for database "First Storage Group\Public Folder Store (EXCHANGE)".
     4.) Source: MsExchangeIS  EventID: 9519
          Error 0x80004005 starting database "First Storage Group\Public Folder Store (EXCHANGE)" on the Microsoft Exchange Information Store. Failed to configure MDB.

I restarted the entire computer
I ran eseutil /g (integrity) and reported 'integrity check succssful'
I ran eseutil /mh and it reported clean shutdown (I'm not sure what else to look for here)
I ran eseutil /pg but it did not seem to repair anything

I ran setup with /domainprep with no luck
I ran ADSI Edit and gave Exchange Domain Servers group Full Control of the Exchange server
0
Comment
Question by:ErnieExpert
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 10
  • 3
  • +2
29 Comments
 
LVL 26

Expert Comment

by:Vahik
ID: 9780103
If u have the backup of ur public folders just go to ur mdbdata folder and delete pub1.edb and pub1.stm folders restart ur public folder store and import ur data back.U will have a fresh and clean data base
and also clean system folders.
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9781099
I renamed pub.edb and pub.stm and tried restarting my public folder store but I got the same errors.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9781762
Shut down the IS. Remove the logs to another location, move the pub1.edb and pub1.stm. In other words, no matter how many \mdbdata folders you have, you only want there to be 2 files,priv1.edb and .stm. then copy in the 2 files that you said were in "clean shutdown" state. Mark the public folder store to be overwritten by restore. restart the IS,and mount stores

D
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 2

Author Comment

by:ErnieExpert
ID: 9781804
Kidego - Don't some of those logs belong to the priv1.edb?
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9782200
OK, I have some more info:
I was under the assumption that eseutil /pg would perform an interactive repair, but apparently it seemded to just do an integrity check.
So I ran eseutil /p, then I ran eseutil /mh and there were 2 errors reported.
Then I ran isinteg with -fix -alltests  and I received an error 'Isinteg cannot initiate verification process'  Upon reviewing the log from isinteg, there was a warning 'Database file is too big (expected 2048 pages, file is 2049 pages)'

On another note, I tried running a restore, but the restore failed with the following message:'An error occurred while registering a database restore with Microsoft Exchange Server'
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9782222
"Don't some of those logs belong to the priv1.edb?"==yea, but once you shut donw the store, it commits them all, so technically, they aren't needed to start again, as long as you remove the .chk file

If your database was in clean shutdown, there was no need to repair. all that did was hurt it. Do you have a copy of the priv1.edb and stm before you repaired it? You didn't do this on your only copy did you?

d


0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9782320
yes I have a copy from before the repair.
I understand that the logs are commited when the store is shutdown.  But if a database(like the priv1) needs to be restored to a previous version, aren't the logs used to roll forward the transactions?
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9782507
yea, but it's a different kind of restore. Online vs offline. Databases that have been shutdown are considered offline, and do not require the logs. Logs can only play thru if there's a sequential log.

d
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9783511
Ok, I shutdown the information store.  Deleted all files except priv1.edb and priv1.stm.  Then I moved pub1.edb and pub1.stm (the clean shutdown versions) into the MDBData folder.  Then I started up the information store.  
However, I am still unable to mount the public folder store.  Same error as before.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9783526
how many mdbdata folders do you have?
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9783537
re-run /domainprep, please too....

d
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9783583
I have 1 mdbdata folder
I ran setup.exe /domainprep
...still no luck
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9784214
ok, we're missing something basic. Exchange doesn't do this without something changing. What changed, well that's the question. When you get the popup error, another event is genrated in your applog. Would you post the series of errors here please?

D
0
 
LVL 26

Expert Comment

by:Vahik
ID: 9784354
In ur mdbdata folder clean out all the log files and delete or move two public folders then import ur files from clean shut down run the eseutil /p and isinteg test and then try to mount(on oublic store only and make sure to check this database can be overwriiten by restore).
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9784373
I wish I knew of something/anything that changed that day, but there were no changes that day.
When I attempt to mount the store, I get the following 4 events:

Source: MSExchangeIS Public
ID: 1216
Description: The information store database "First Storage Group\Public Folder Store (EXCHANGE)" is limited to 16384 MB.

Source: MSExchangeIS Public
ID: 1133
Description: Attempting to start the Microsoft Exchange Information Store "First Storage Group\Public Folder Store (EXCHANGE)".

Source: MSExchangeIS Public
ID: 1133
Description: Allocating message database resources for database "First Storage Group\Public Folder Store (EXCHANGE)".

Source: MSExchangeIS
ID: 9519
Description: Error 0x80004005 starting database "First Storage Group\Public Folder Store (EXCHANGE)" on the Microsoft Exchange Information Store.
Failed to configure MDB.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9784400
Are you able to mount a blank PF store?
 Just mount the PF store after you remove the edb and stm, it will ask you if you want to create new blank stores, hit ok, and see if it will come up. just want to see if the store files are the problem. Has the PF store been defragged?
D
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9784427
If I try to mount a blank PF store, I get the same error.  
I have not done an offline defrag.  Exchange has performed the routine online defrags.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9784438
ok, well you have something else wrong, we're working on the wrong thing. Permissions have changed
So, /domainprep doesn't work, you re-applied the Exchange service pack?

D
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9784467
hey, did you or anyone else remove the everyone group on the PF store security? sounds like it, for sure

D
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9784645
I had not re-applied the exchange service packs, but I just did - no luck
I checked the Security on the PF store and the Everyone group is there.  It has the following permissions: Read, Execute, Read Permissions, List Contents, Read Properties, Create named poperties in the information store.  I tried giving it Full Control but that did not help.

This much worked - I created a new Public Folder Tree.  Then I created a new Storage Group.  In the new storage group I create a Public Store and associated it with the new Public Folder Tree.  I was able to mount this public store
0
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 250 total points
ID: 9784879
well yea, but it's not the default MAPI store, and there can only be one of those. We gotta put the first one back. What about the folder hierarchy? Everyone group still listed? There are no explicit "deny" privs set, are there? Does everyone group have full NTFS perms where the database lives?

D
0
 
LVL 2

Author Comment

by:ErnieExpert
ID: 9784985
BINGO!!
I actually figured it out just before I read your last post, but if I hadn't, your post would have gotten me there.  I checked the security on the Public Folder Tree and the Everyone group was denied Read Permission.  I don't know how this got set, but now I will spend some time trying to figure that out.  Thanks for your help.

PS - I knew that a new Public store would not be a MAPI store, I was just trying to narrow down where the permissions might have been set wrong.
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 9784997
excellent!! knew it was perms when the blank store wouldn't mount. Somebody's been playing around with perms, not a good idea.....keep 'em out!!

later

D

0
 

Expert Comment

by:MaxFatalError
ID: 10223566
I have the same problem, but the security on the Public Folder Tree is ok...
can anyone help me??? same errors as above
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 10223628
oh, it's a perms issue, unless you installed iislockdowon and urlscan. Have you done so?

D
0
 

Expert Comment

by:MaxFatalError
ID: 10223672
I'ven't installed nothing... it happens during starting/stopping services for testing backup scripts... during a script i see errors reading on M:\etc... and now i cannot mount public stores... where i have to look for?? I have only 7 hours to resolve this problem... :'(
0
 

Expert Comment

by:MaxFatalError
ID: 10223851
Kidego are you still here? I need help please...
0
 
LVL 24

Expert Comment

by:David Wilhoit
ID: 10224149
sorry, went upstairs for a while...when you backup, you're not backing up the M: drive are you?

D

PS...you should open another question, since this particular thread doesn't resolve the issue...just good form :)
0
 

Expert Comment

by:HelgiB
ID: 10467414
This problem seems to be caused by you running E2K Standard version rather than Enterprise. The message "The information store database "First Storage Group\Public Folder Store (EXCHANGE)" is limited to 16384 MB" is a clear indication of this as E2K standard only support 16Gb max size data stores. To fix this you can either run setup from E2K enterprise CD and choose the option to reinstall all items or you can use a Ms fix which allows you to grow the database to 17Gb temporarily - that will allow you to mount the databases and take further corrective action such as running an offline defrag. The Ms fix in question is described in Kb article 813051.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
Read this checklist to learn more about the 15 things you should never include in an email signature.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question