Bavkup Exec v9.0 running on a Compaq TSL10000 Autoloader


I cant get Backup Exec to recognise a TSL 10000 Autoloader, Im assuming Its teh driver which is still a compaq one but everytime I run the Backup Exec lastest drivers it doesnt chnage the media changer :-|

Ive tried everything...funny thing is, it works on the native MS backup :-| cant use that as its not got the functionality that I require.

Any suggestions would be appreciated,,this thing is driving me mad :-|
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

it is supported by exec v9.0.
Compaq 20/40 GB DAT AutoLoader (8 Cartridge) COMPAQ TSL-10000 4mm SCSI ML T.
1. try downloading all the latest patch from BE.
2. try to load compaq drivers for this autoloader.

1. Try replacing SCSI cable.
2. Be sure you have the latest firmware upgraded.
3. Don't use the Veritas device drivers, even though they
say they are "compatible" with compaq they are not.
credmoodAuthor Commented:
I have used the compaq drivers for the media changer and the Tape drive..The thing is that when i do that it works with MS native backup but still doesnt recognise from Backup it cant be cable..Ill check the firmware
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

credmoodAuthor Commented:
Have changed all the drivers, still doesnt recgonise :-(.. the one thing I cant seem to find is the firmware for the Autolader..Have checked out the library and tape tools from HP..which doesnt have the firmware for this device :-( It is the latest build from BE v4454...Im bouncing this DC so much that it aint gonna come back one day ;-)
u can get it from here.
but i checked the  site and no new driver came in this year, so u must be having the newest one with Backup exec.
1. Ensure that the tape drive or robotic library is not connected to a RAID controller.
2. Separate the tape devices from a controller that also has hard drives connected to it.
3. read this doc it has more solutions.
4. check if u can install latest drivers.

good luck.
Many tape drives can EMULATE other tape drive behavior. Look through your manual and see if you can make your tape drive emulate a different device that works with BE9 (a bit of a misnomer since I know BE9 works with that drive)

Hope this helps some,

credmoodAuthor Commented:
Ran the Backup exec diagnostic and it gave me this

0002:0000:0006:0001  Device Name             ""
                     Primary Inquiry         "COMPAQ  TSL-10000       5.06"
                     Serial Number           ""
                     Device Flags            SCSI
                     Device State            1, Offline, ERROR = 0x0000007B (ERROR_INVALID_NAME)

credmoodAuthor Commented:
Im going to kick back to backup Exec 8.6 see if that sorts the problem....As noone knows im gonna close the question....Ill post if 8.6 works
This error messages tell us that.

Drives will get left assigned only if there is a period of
    robotic control unavailability while drives are assigned, such
    as when:
       - There are network communication problems (with ACS,
         TLH, or TLM robots).
       - There are robotic hardware problems (with TL8 or TLD
         robots) including if the robot goes offline.
       - The robotic daemons/processes (acsd, tl8d, tldd, tlhd, tlmd)
         are stopped and restarted.

i would suggest running test from loader itself. disconnect the loader and the test from loader panal windows.
if everything comes clean.
then add to system and run again this diagosntic tool.

and if this comes again and then i would contact to veritas guys to fix this up.
there might be some driver problem which putting devices to offline state.

i suppose scsi drivers also comes from veritas, which require to operate this loader.
credmoodAuthor Commented:
its a real sod of a problem....dont spose i have much choice now..ill have to get hold of the veritas people,,,BTW it didnt work with 8.6 either :-|

It just wont recognise the changer....BUT when i just dont bother with veritas and use MS native it works :-| and i thought that MS native was veritas, albeit a stripped down version...

It must be a problem with the scsichanger system driver...but im lost now..ive tried so many different ways that im going driver/firmware mad :-)
It happens sometime. and with MS u can expect anything to happen :-)

anyway looks MS native uses some different driver set/conbination/layer to connect to changer.

I have seen verutas document claiming support for this looks like here u are missing/corrupting some component or driver is not at all working for u.

check out with veritas people and let them know about case, that the best u i can suggest.

Also u can do one things, u can uninstall everything. drivers and all everthing related to your changer and exec backup.
and then install from scratch and see problem still persist.

good luck.
credmoodAuthor Commented:
OK here we go.....apparently this loader can lose its serial number (for a few reasons) when it does this teh scsi changer driver cannot load as it doesnt have a clue what its loading, it needs the serial number of the loader....sooooo...I got comapq to send me a new loader and bobs yer aunties live in all now works..:-)
I suspected that there is problem with SCSI.
Glad. u got it worked.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.