Tidying up DB's

A simple one undoubtedly but i cant seem to ask the correct questions in help :)

A number of forms and hence fields have been deleted from various Databases, but they still show up as options to display in a view column.

How do i "tidy up" so that basically when a field is removed from the databse it is no longer an option  for display on a view column.

Example if i create a new view and select a column, attempt to Display a field, i get the option of

"untitled" "untitled2" etc as well as about 50 fields that were on forms that no longer exist.

Cheers

T
TweedyAsked:
Who is Participating?
 
HemanthaKumarCommented:
Try this

1. Create full text index (In database properties)
2. After index is created, delete it (In database properties)
3. Now compact the database
4. The obsolete fields should not be visible now

~Hemanth
0
 
Sjef BosmanGroupware ConsultantCommented:
Basically: Compact your database, and remove fields from documents with older names
0
 
Sjef BosmanGroupware ConsultantCommented:
Or the other way round ;-) cleanup older documents and compact the database.
There have been numerous problems with fieldnames that no longer exist, all reported in several fora about Notes. They seem to have solved this issue in R6...
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
Sjef BosmanGroupware ConsultantCommented:
Multiple suggestions have also been made into the direction of full-text index creation and removal. My template does not have an FTI, and compacts as it is supposed to. I absolutely fail to see the connection between FTI and fieldnames, hence I have only one word for it: Balderdash!
0
 
qwaleteeCommented:
Hi sjef_bosman,
> I absolutely fail to see the connection between FTI and fieldnames, hence I
> have only one word for it: Balderdash!

I have read Sjef's comment, and I have only one word for it: Accurate!

Best regards,
qwaletee
0
 
TweedyAuthor Commented:
Thanks people, thought it would be an easy one :)
0
 
qwaleteeCommented:
Sjef,

You deserved poins on this one.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.