Don't allow screensaver or background changes

We are a school.  Our XP stations have 2 logins, teacher or Student.  We want to disallow students from changing the background or screensavers (they do cute things like "start screensaver in 1 minute" or make strange messages for a screensaver).

I looked at the local policies and didn't see it.  Is there a way?

Thanks.
LVL 1
dougp23Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
Hi dougp23
Click Start , click Control Panel , click Performance and Maintenance , and then click Administrative Tools.

Double-click Local Security Policy .

In the left panel, double-click Local Policies to expand it.

Go to Security options. These are our recommendations for a good high security system.
,
Default user screensaver enabled
Enabled

Default user screensaver password protection is enabled
Enabled

Default user screensaver program
Logon.scr

Default user screensaver timeout value
900



Cheers!
0
CrazyOneCommented:
Start > Run gpedit.msc

User Configuration > Administrative Templates > Control Panel > Dispaly
Double click Screen Saver
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jirikiCommented:
The simplest way would be to deny access to the Display control panel and pre-set the screensaver so that students could not directly change the settings with either a local or group policy.  This is under User Configuration | Administrative  Templates | Control Panel and it's sub-setting Display.

Alternatively, and less recommended way, would be to set the permissions on the Reg keys to read only for the student account.  Logon as the student and startup regedt32 (if you have dissallowed access to regedt32, your'll have to re-grant it temporarily).  Change permissions on HKCU\Control Panel\Desktop.  You could try the whole key or just the SCRNSAVE.EXE, ScreenSaveTimeOut keys.  When done, disallow regedit utils.

Still I would recommend doing this with Group policy.  If you do not have an AD to do GPO's, you can set the Local Group Policy for 2 distinct groups.  You do this by making the settings with Start | Admistrative Tools | Local Group Policy.  Next deny access to the Administrators group (or user) to the G:\WINDOWS\system32\GroupPolicy folder.  Thus on boot and logon, that account cannot read the local policy and thus it doesn't get enforced for them.  You must specifically use the deny option.  Otherwise, neither the teacher or student will be able to make the changes.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.