Problem setting up NIS client of RH 7.3 box: ypbind failure

Problems with setting up a RedHat 7.3 box up as NIS client.
Have a Solaris 2.8 box as our NIS server and that is working fine
with all our other NIS cleints.
 Problem: ypbind fails on reboot. Message indicates it's binds to the NIS domain but it fails when 'Listening for an NIS domain server'
               ypbind fails when exucuting a 'service ypbind start' command from command line with same message
               ypbind runs when typing /sbin/ypbind from command line
   
  ypbind is set up to run at level 3,4,5 and domainame yields correct domain name

 What do I need to do to get ypbind to startup on reboot.

 


markwinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ahoffmannCommented:
hmm, have seen a similar question somewhere at EE, but lost the link :-(
Think jlevie or The-Captain gave an answer.
My experiance is that Linux still does not work as NIS-client with Solaris 2.x NIS-Server, sometimes, somehow.
0
jlevieCommented:
Try editing /etc/yp.conf and set "ypserver NIS-server". Also make sure that the NIS-server is in /etc/hosts with the correct FQDN of your Solaris NIS server and with the correct IP.
0
ahoffmannCommented:
check protocols:
   rpcinfo -p
   rpcinfo -p name-of-solaris-server
   rpcinfo -b ypserv 1 | sort | uniq
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

markwinAuthor Commented:
/etc/yp.conf has a ' ypserver NIS-server' line and 'ypbind -d' verifies it's picking this info up correctly.  Also, the NIS-server line (IP&FQDN) was in the /etc/hosts file.  

0
markwinAuthor Commented:

> rpcinfo -p
      program vers proto   port
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100300    3   udp  32777  nisd
    100300    3   tcp  32771  nisd
    100004    2   udp    814  ypserv
    100004    1   udp    814  ypserv
    100004    1   tcp    815  ypserv
    100004    2   tcp  32772  ypserv

 >rpcinfo -p name-of-solaris-server
      program vers proto   port
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100300    3   udp  32777  nisd
    100300    3   tcp  32771  nisd
    100004    2   udp    814  ypserv
    100004    1   udp    814  ypserv
    100004    1   tcp    815  ypserv
    100004    2   tcp  32772  ypserv
1073741824    2   udp  32778
    100007    3   udp  32794  ypbind
    100007    2   udp  32794  ypbind
    100007    1   udp  32794  ypbind
    100007    3   tcp  32775  ypbind
    100007    2   tcp  32775  ypbind
    100007    1   tcp  32775  ypbind
    100069    1   udp  32796  ypxfrd
    100069    1   tcp  32778  ypxfrd
    100009    1   udp    831  yppasswdd
    100028    1   tcp    833  ypupdated
    100028    1   udp    834  ypupdated
    100232   10   udp  32813  sadmind
    100021    1   udp   4045  nlockmgr
    100083    1   tcp  32812
    100021    2   udp   4045  nlockmgr
    100021    3   udp   4045  nlockmgr
    100021    4   udp   4045  nlockmgr
    100221    1   tcp  32816
    100235    1   tcp  32820
    100068    2   udp  32829
    100068    3   udp  32829
    100068    4   udp  32829
    100068    5   udp  32829
    100229    1   tcp  32833
    100230    1   tcp  32837
    100024    1   udp  32833  status
    100024    1   tcp  32838  status
    100133    1   udp  32833
    100133    1   tcp  32838
    100021    1   tcp   4045  nlockmgr
    100021    2   tcp   4045  nlockmgr
    100021    3   tcp   4045  nlockmgr
    100021    4   tcp   4045  nlockmgr
    100005    1   udp  33001  mountd
    100005    2   udp  33001  mountd
    100005    3   udp  33001  mountd
    100005    1   tcp  32909  mountd
    100005    2   tcp  32909  mountd
    100005    3   tcp  32909  mountd
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100227    2   udp   2049  nfs_acl
    100227    3   udp   2049  nfs_acl
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100227    2   tcp   2049  nfs_acl
    100227    3   tcp   2049  nfs_acl
    100026    1   udp  33010  bootparam
    100026    1   tcp  32910  bootparam
    300598    1   udp  33019
    300598    1   tcp  32921
 805306368    1   udp  33019
 805306368    1   tcp  32921
    100249    1   udp  33020
    100249    1   tcp  32922
    300694    1   udp    949
    390113    1   tcp   8095
    390103    2   tcp   9617
    390109    2   tcp   9617
    390110    1   tcp   9617
    390103    2   udp   9618
    390109    2   udp   9618
    390110    1   udp   9618
    390105    5   tcp   8342
    390105    6   tcp   8342
    390107    5   tcp   9434
    390107    6   tcp   9434
    390104  105   tcp   8880
    390104  205   tcp   9789
    390104  305   tcp   8697

 >rpcinfo -b ypserv 1 | sort | uniq
  Returned was a list of servers running ypserv and the one I've listed in /etc/yp.cong was one of them.
0
ahoffmannCommented:
your localhost is NIS server itself, see your posted output
Think you need to decide which one should be the server, or do you want to have a master slave NIS?
0
markwinAuthor Commented:
Sorry. my mistake with the cut and paste:
  This is the correct info:
> rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  32768  status
    100024    1   tcp  32768  status
    391002    2   tcp  32769  sgi_fam
    390113    1   tcp   7937

0
ahoffmannCommented:
and what does ypwhich tell you?
Have you setup your yp-client (see jlevie's comment)?
Then you should see ypbind with rpcinfo
Otherwise please post error messages and logged messages from starting ypbind
0
markwinAuthor Commented:
ypwhich response:
ypwhich: Can't communicate with ypbind

My yp.conf file on the client and /etc/host file have the correct info in them.

Error shown on screen when rebooing and executing /etc/init.d/ypbind start :
Binding to the NIS domain:                                 [  OK  ]
Listening for an NIS domain server....................     [FAILED]

Logged message from starting ypbind using /etc/init.d/ypbind command:
Nov 22 12:58:05 <NIS-cleint> ypbind: attempting to contact yp server failed

Logged message from boot log:
Nov 22 13:16:21 <NIS-cleint>   portmap: portmap startup succeeded
.....
Nov 22 13:16:25 <NIS-cleint>    ypbind: Setting NIS domain name <NIS-domain-name>:  succeeded
Nov 22 13:16:25 <NIS-cleint>  ypbind: ypbind startup succeeded
Nov 22 13:16:46 <NIS-cleint>  ypbind: ypbind shutdown succeeded
Nov 22 13:16:46 <NIS-cleint>  ypbind: attempting to contact yp server failed

Ok, ypbind stating then shutting down doesn't look right.  

0
jlevieCommented:
Does this system have the installation's default firewall running? If it does try shutting that down and see if things work a bit better.
0
markwinAuthor Commented:
No firewall is running.
0
ahoffmannCommented:
hmm, sounds like another proove of my very first assumtion (see above):
Can you verify if your Linux NIS-client can find/connect to another not-Solaris NIS-master ?
Another try might be to force setting to NIS protocol version 2
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
markwinAuthor Commented:
Sorry, with the Thanksgiving Holiday and very recently finding out I'll be in training until Friday of this week I won' thave a chance to look into your latest suggestions ahoffmann until at earliest Friday.  I do appreciate all the suggestions I've been given.

0
ahoffmannCommented:
does the grading mean that you changed to protocol version 2, or that you gave up with Solaris as master?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.