Losing network connection when processing lots of files

Ok, I have Athlon XP 1.3mhz with a build in VIA Rhine II Compatible Fat Ethernet Adapter on the Mainboard.  The Mainboard is by !st, model AN19E/AN19c.  I am running windows 2003 server.  I have a a PCI IDE Card for 2 more hard drives, CDROM, FLOPPY...etc  I have 512mb of ram.  I am just running a simple File server.  No AD or DNS.  My connection configuration is Client for Microsoft Network, File and Printer Sharing for Microsoft Network and Internet Protocal(TCP/IP)  I have a static IP address of /net mask  Default Gateway of and Preferred DNS  I am connection to the internet via another PC that is connected directly to the network.  That is why my DNS and Gateway is because that PC that is connected directly to the internet is configured with that IP address.  I have a 16 port hub
Now, when I am on any other PC that is running XP and I am copying large amount of files accross the network, I lose the connection to the network on the server.  I have to disable the Local Area connection and enable it again to regain access.  When I am processing large amount of photos, like creating thumbnails, I lose my network connection.  I don't get the problem from workstation to workstation, only when I am going from workstation to Server.  

Help any ideas??   I did install all the windows updates and patches.  I did have Windows 2000 server and I had the same problem  upgrading to 2003 I thought I would fix the problem.  

Thanks for the help
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

could u please explain more clearly this part.
Now, when I am on any other PC that is running XP and I am copying large amount of files accross the network, I lose the connection to the network on the server.  I have to disable the Local Area connection and enable it again to regain access.  When I am processing large amount of photos, like creating thumbnails, I lose my network connection.  I don't get the problem from workstation to workstation, only when I am going from workstation to Server.  
1. u loose the connec tion from client to server ?
2. u perform the file activity on client or server ?
3. u loose the connection from DNS server to internet. ?
Is your PC that's connected to the Internet a DNS server ? Try putting in an Internet DNS server & see how it goes (might not be involved with the problem though).

What I suspect might be the problem could be the speed/duplex issue on your network. If all your devices are connected to the hub, they have to be in half duplex & not full. Try setting the duplex to half & speed to 100 manually for all the devices under the NIC configuration settings.

The other thing that could be a cause would be virus or spyware. Scan your PCs/servers with the latest updated virus scanner & use a spyware scanner like Ad-aware (www.lavasoft.com).
dan5460Author Commented:
I am performing the process from the client to server.  In order words I am access and/or process file from the server through the client.  Example, I have about 150 photos on the server on the D Drive.  On the client side I am mapped to the server D drive as X:.  When I am creating thumbnails of those 150 photos it sometime goes throught without a problem other times I lose the connection.  I have to go to the server and disable the adapter and enable it again.  It always happens when I am transferring or processing large amounts of data to and from the server.  I don't get this problem from one client to another client.  This problem happens to any client that is connected to the server.

I did run ad-aware and everything is ok.  i am even disable norton firewall.  

I will try changing my duplex.  Right now it is setup as automatic.  I was thinking of changing the NIC.  What do you think?  Any other thougths.

Thanks for your great response.
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

see if any of this helps

Create a text file on the server put this into it:

Windows Registry Editor Version 5.00



Save the file as WHATEVER.REG not WHATEVER.TXT

Then double click on the file to apply the setting (once again on the SERVER not the pc).

What this does is it sets the DIR commad's buffer from 14000 to 65000. This fix works on NT/2000/XP.

After installing Service Pack 1 on several of my Windows XP workstations, I noticed a dramatic reduction in network performance when communicating with my Windows 2000 servers. Although everything worked fine with small files, when I tried to access, create, or modify a file over 70 KB, I would get a file creation error, a delayed write failure, or some other odd error. After a little digging, I discovered that my Windows 2000 servers were holding the files open even after I had closed them, thus making it impossible to modify the file. Unfortunately, these file lock problems often occurred while the file was open, resulting in a corrupt file.

I first suspected faulty hardware—a bad network cable or hard disk ribbon. Yet after months of experimenting, I determined that my hardware was working perfectly. Since I have almost 20 computers and only PCs running Windows XP with SP1 were experiencing these communication errors, I decided that SP1 must be the culprit. I began researching the problem and after months of searching I found three potential solutions.

Word of warning

The following article suggests ways to edit your system registry. Using the Windows Registry Editor incorrectly can cause serious problems that could require you to reinstall your operating system and you could possibly lose data. TechRepublic does not and will not support problems that arise from your editing the registry. Use the Registry Editor and the following directions at your own risk.

XP has trouble writing to 2000 domain controllers

Unfortunately Microsoft's support Web site doesn’t list Windows XP SP1 problems in a single location so I dug through its knowledge base until I found article 321169, "Slow SMB Performance When You Copy Files from Windows XP to a Windows 2000 Domain Controller."

According to the article, Windows sometimes has problems writing to domain controllers, but should have no trouble reading from domain controllers. Alas, I was having trouble reading and writing to Windows 2000. Sometimes it would take a full 60 seconds for Windows XP to open a 50-KB file that was stored on a Windows 2000 domain controller. Other times though, the same file would open instantly. Although this knowledge base article didn't address my exact problem, I decided to follow the instructions and see what happened.

The article suggests that the slow performance results from a delayed TCP/IP acknowledgement occurring in an SMB: C NT Transact-Notify Change packet. To put it simply, Windows 2000 uses what are known as SMB security signatures. If security signatures are enabled, the redirector is forced to wait until the current SMB command has completed before processing the next one. This means waiting for an SMB acknowledgement from the server. The easiest way to implement a workaround to the problem is simply to disable SMB security signatures on the domain controller by editing the registry.

To do this, open the Registry Editor and navigate to HKEY_LOCAL_MACHINE\System\

CurrentControlSet\Services\LanmanServer\Parameters. Double click on the RequireSecuritySignature value and enter 0 in the Value Data dialog box. Next, double-click on the EnableSecuritySignature value and enter 0 in the Value Data dialog box. However, this registry modification didn’t correct my particular problem.

Possible task scheduling bug

I decided to turn my attention to the Web and see if anyone else was having the same problem. A quick search revealed dozens of Web pages where people discussed similar problems. One of the suggested fixes involved a bug that exists in both Windows XP and in Windows 2000. The bug causes Windows to check for any scheduled tasks that might exist on a remote machine before displaying the browse contents.

This particular bug is also controlled by the registry. To solve the problem, just remove the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\

Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}. This registry fix did speed things up somewhat for me, but didn’t completely correct the problem.

A solution at long last: SMB signing incompatibility

Finally, after another month of digging, I discovered MSKB article 331519, "Network File Errors Occur After You Install Windows XP SP1," in which Microsoft acknowledges the problem. According to Microsoft, the problem is related to an incompatibility in SMB signing between Windows 2000 and Windows XP SP1. It appears several group policy settings are to blame.

To fix the problem, go to a domain controller and open the Active Directory Users And Computers console. Then, right-click on the Domain Controller organizational unit (OU) and select the Properties command from the shortcut menu. Doing so will display the Domain Controllers Properties sheet. Select the Group Policy tab. Select the Default Domain Controller Policy (or what ever group policy applies to the domain) and click the Edit button. Navigate through the policy to Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options. Then, locate the following four policy settings and change them to Disabled:

Digitally Sign Client Communications (Always)

Digitally Sign Client Communication (When Possible)

Digitally Sign Server Communication (Always)

Digitally Sign Server Communication (When Possible)

Close the Group Policy Editor, click OK, and close Active Directory Users And Computers. After you apply the settings, wait for the next replication cycle to complete and the settings should take effect. Once the settings took effect on my system the communication problems disappeared. Rumor has it that Microsoft intends to correct this issue in the next Windows XP Service pack.

Here's a great tip to speed up your browsing of Windows 2000 & XP machines. Its actually a fix to a bug that by default of a normal Windows 2000 setup that scans shared files for Scheduled Tasks. And its turns out that you can experience a delay as long as 30 seconds when you try to view shared files across a network as Windows 2000 is using the extra time to search the Remote Computer for any Scheduled Tasks. Note that though the fix is originally intended for only those affected, Windows 2000 & XP users will experience that actual browsing speed of both the Internet & Windows Explorers improving significantly after applying it since it doesnt search for Scheduled Tasks anymore. Here's how :

Open up the Registry and go to :

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version/Explorer/RemoteComputer/NameSpace

Under that branch, select the key :


Right click it and select "Delete".

This is key that instructs Windows to search for Scheduled Tasks. If you like you may want to export the exact branch so that you can restore the key if necessary. This fix is so effective that it doesn't require a reboot and you can almost immediately determine yourself how much it speeds up your browsing processes.


Note : This branch also exists in both Win98 & ME and Ive got so many mails asking me whether it's safe to apply the fix on it. However, I would like to warn users that the fix is intended only for Windows 2000 and XP. If you decide to try it for your Win98/ME system, pls make sure that you back up or export the exact branch so that you can restore the key if something should go wrong. Currently there are more than 20 users that have tried the fix in Win98/ME. Out of this 20, there are 4 users who reported that problems arises after removing the branch while the balance 16 reported great success.

dan5460Author Commented:
Great thanks for all the tips.  I am going to try them is if it work.  Last night I changed my media link from auto sense to 100 full duplex on both the client and the server on the adapter.  This seem to work because I was able to run large amount of data back and forth without losing my connection.  However, it is very slow, much slower.  Even when I am try to save an excel spreadsheet from the client to the server, I get a "Delay write failed"  error.  It is very noticably slow.  I tried to save the spread the second time and it works.  I am going to try the above registry fix and see if it works.  

I will keep you posted.  


dan5460Author Commented:
Ok, I have tried everything.  Now I don't lose the network connection but it is super slow.  I was trying to save a 1.2mb spreadsheet from my client (XP) to my Server (2003) and it took about 30 second and then I got the following error.  If you have any ideas please help.  

thanks again


Event Type:      Warning
Event Source:      MRxSmb
Event Category:      None
Event ID:      50
Date:            11/22/2003
Time:            8:36:50 PM
User:            N/A
Computer:      DELLGX150
{Delayed Write Failed} Windows was unable to save all the data for the file \Device\LanmanRedirector. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0000: 04 00 04 00 02 00 56 00   ......V.
0008: 00 00 00 00 32 00 04 80   ....2..€
0010: 00 00 00 00 0c 02 00 c0   .......À
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 0c 02 00 c0               ...À    
The warning message simply says whatever u are facing ie delayed write is failed.
u might wanna check your file on server whether it is tranferred properly or not.

If you change the speed & duplex settings on the network, you have to change both the port on the switch & on the server.

Maybe you can run through with us what did you change & the results that you observered after a certain change. I suggest that you roll back the last change before this error occured.

Either that, or as the error message specifies, your server NIC might be failing. Try changing to another switch port first, then try changing the NIC.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
If rolling back your changes & changing the NIC doesn't solve your problem, then try this:


But if this doesn't solve the problem, I suggest you roll-back the change as write caching usually gives better performance.
dan5460Author Commented:

I did check the cache on all my hardrive, but there are 2 hardrives that don't have the abilited to turn on the cache.  These 2 hard drives happens to be on the PCI host adapter for hardrive.  I added a PCI harddrive card to add more hardrive a while ago, but did not have this problem before.  My quess is, if I disable the build in lan connection and install a linksys NIC card everything should be OK

I will let you know.  I am off to buy a linksys card.

Thanks for all your help.

dan5460Author Commented:
Ok, i made sure I had all drives cache write enable.  I installed a new driver for the VIA bus master IDE host.  But I still get a "Windows Write Delay" error.  I am just try to save a 1mb spreadsheet from the client to the server through Excel.  In other words I am saving the spreadsheet to a map drive on the server from the client.  My only option left is to install a new NIC card and see what happens.  If you have any other ideas let me know


Actually, I meant to suggest that you disable write caching. If that didn't solve the problem, then reenable write caching. Write caching is enabled by default. Sorry I wasn't clear about that. Another alternative is to check the switch port for errors. If there're errors on the port, then either the switch port, cable or NIC is faulty. Should be a good place to start before replacing your NIC.
dan5460Author Commented:
Ok, I think I resolve the issue.  It seems that the VIA lan adapter that is build in on the motherboard keeps failing and that is why I keep getting write fail.  I installed a Linksys NIC card and now all is well.  Much faster saving and got no error so far.  

So I could consider this issue CLOSED

Thank you so much everyone for your support and knowledge.  This has to be the best place for resources.  I love it.

Thanks again

Good to know you got the issue resolved. You can close the question by following this guidelines:

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.