Solved

Can't get to proxy server through routers.

Posted on 2003-11-20
6
375 Views
Last Modified: 2012-05-04
Hi,
I have 2 2507 cisco routers connected with a back to back serial cable.
I have 2 networks, 10.10.10.0 and 192.168.1.0
The serial port ip's are 75.75.75.1 and 75.75.75.2
Workstations on the 192. side can log on to a server on the 10. side. All computers on both sides can ping each other.
I have a proxy server (10.10.10.4) with a dial up internet connection. All computers on the 10. side can get to the internet through the proxy server. When a computer on the 192. side tries, the dial up window will pop up on the proxy server and make the connection but the computers on the 192. side never get to the inetenet.
I thought it might be a DNS problem but I have the same info on all computers on both sides and the ones on the 10. side works fine.
Do you think it is a router problem or something else?
Thanks.
0
Comment
Question by:dle266
  • 3
  • 2
6 Comments
 
LVL 7

Expert Comment

by:NicBrey
ID: 9795678
Looks like a routing problem

Do you have a default route on the 192.168.1.0 router that points to the 10.10.10.0 router?
ip route 0.0.0.0  0.0.0.0  <serial IP of 10.10.10.0>

And on the 10.10.10.0 router you should have defult route pointing to Proxy server
ip route 0.0.0.0  0.0.0.0  10.10.10.4

Also, are the browsers configured with the IP of proxy server?
0
 

Author Comment

by:dle266
ID: 9797337
Hi,
This is what the routers look like.
hostname Router1
!
ip subnet-zero
ip host router2 192.168.1.1 75.75.75.2
ip host router1 10.10.10.1 75.75.75.1
!
hub ether 0 1
 link-test
 auto-polarity
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no ip mroute-cache
 no mop enabled
!
interface Serial0
 ip address 75.75.75.1 255.255.255.0
 no ip mroute-cache
!
interface Serial1
 no ip address
 no ip mroute-cache
 shutdown
!
router rip
 network 10.0.0.0
 network 75.0.0.0
!
ip classless
ip route 10.10.10.0 255.255.255.0 10.10.10.4
ip route 75.75.75.0 255.255.255.0 10.10.10.4
ip http server
!
line con 0
line aux 0
line vty 0 4
 password cisco1
 login
!
end

hostname Router2
!
ip subnet-zero
ip host router1 10.10.10.1 75.75.75.1
ip host router2 192.168.1.1 75.75.75.2
!
hub ether 0 1
 link-test
 auto-polarity
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 no ip mroute-cache
 no mop enabled
!
interface Serial0
 ip address 75.75.75.2 255.255.255.0
 no ip mroute-cache
 clockrate 4000000
!
interface Serial1
 no ip address
 no ip mroute-cache
 shutdown
!
router rip
 network 75.0.0.0
 network 192.168.1.0
!
ip classless
ip route 10.10.10.0 255.255.255.0 75.75.75.1
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 password cisco1
 login
!
end
I tried adding static routes but I did it wrong. You will notice I have 2 ip routes on router1. Can anyone tell me how to get rid of a static route?
Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9802752
If you want to get rid of this:
ip route 75.75.75.0 255.255.255.0 10.10.10.4

simply use "no" in front of it

router(config)#no ip route 75.75.75.0 255.255.255.0 10.10.10.4

You might want to add to router 1:
ip route 192.168.1.0 255.255.255.0 75.75.75.2


Is your RIP working?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 79

Accepted Solution

by:
lrmoore earned 125 total points
ID: 9802759
Does your proxy server have a route to 192.168.1.x subnet?
Try adding a static route on the server:

C:\>route add 192.168.1.0 mask 255.255.255.0 10.10.10.1
0
 

Author Comment

by:dle266
ID: 9806247
Hi,
After I added a static route to the server I removed all static routes from the routers and it still worked.
The server is Windows 98 running FreeProxy.
Now I need to see if there is a way to keep from dropping the static route when the server is rebooted.
But you've got me on the right track!!
Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9806293
To make the route change permanent, just use a "-p" flag
c:\>route add -p 192.168.1.0 mask 255.255.255.0 10.10.10.1
                    ^^
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Website Routing Issue 3 50
Command "logging persistent size .... " 6 45
WAN IP Conflict on Sonicwall 5 91
Packet Tracer Router to Router 10 62
In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now