Internal Target Failure while burning CD-RW

After spending the entire last week comming up with the perfect image for a rescue CD, cdrecord told me this:

status: 0x2 (CHECK CONDITION)
Sense Bytes: F0 00 04 00 03 8B EA 13 00 00 00 00 44 88 00 00
Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x44 Qual 0x88 (internal target failure) [No matching qualifier] Fru 0x0
Sense flags: Blk 232426 (valid)

While there's plenty of info there, the key words seem to be "internal target failure".  Research on google tells me that indeed, this error is caused by an "internal target failure".

Does anybody know what exactly an internal target is or why it would fail?

P.S.  This 300 points is for telling me what the problem is.  300 more if you can tell me how to fix this without a trip to MircoCenter.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

status: 0x2 basicly means the operation to the drive timed out

use '-o boot.iso' with mkisofs instead of piping it to cdrecord to see if there's a problem with your compilation
the use  -dummy with cdrecord to see if it's having problems with your image
if all's well try to write at a slower speed...

"your milage may vary"

generalkAuthor Commented:
I'm not piping, and I've tried every speed the burner supports.

Here's the strange thing that I've just discovered.  I seem to be able to burn images less than 450 MB without a problem, but anything more than that produces the error cited above.  Full erasures also fail, while blank=fast works just fine.

It seems the burner can only write the first ~450MB of a disc.  Any ideas?
swap >= 450MB?
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Hi there,
There appears to be several possible causes, the following relates to the actual CD used.
then there is this, which looks at the settings
generalkAuthor Commented:
I don't think I understand chicagoan's comment, but this information may be relevant.

gk@gk:~$ cat /proc/swaps
Filename                        Type            Size    Used    Priority
/dev/hda3                       partition       489972  5516    -1

gk@headless ~ $ cat /proc/swaps
Filename                        Type            Size    Used    Priority
/dev/hda3                       partition       1052248 0       -1

In response to the first article posted by philby11, I don't think this is a media problem because I'm using a Phillips 4x CD-RW in a Phillips 4x CD-RW drive.  I've also tried Memorex CD-Rs rated at 8x but burning at 2x.

The second link points to a thread where the ultimate resolution was to pass the -V flag to mkisofs.  I don't see how this could impact the burning process, and I think that he just got lucky on the third attampt.  Never the less, I did change the -volid flag that I had been passing to mkisofs to a -V flag, and for good measure, I added a -V cdrecord as well.

Aside from a torrent of debugging information, the result was the same.
Have you tried a -dummy burn with this image? With another image that's worked b4?
If other general operations are failing, considering a Phillips 4x CD-RW must have a few miles on it, maybe you should pull the drive and test it on another machine. If that works you can go about debugging your app an device files.
generalkAuthor Commented:
I tried it with -dummy and got the same results.

I don't have any large images that have worked before.

I have tried the drive on a couple of machines (gk and headless from above), but both of them linux with cdrecord.  I thought about trying to burn from Windows, but I've never been able to burn reliably there and the error messages are signigificantly less helpful.

Despite its age the drive hasn't been used enough to be worn out.  It's burned less than 500 CDs.  Even so, at this point I'm basically assuming that this mysterious error means that the drive is busted.

The question still stands, what is an internal target, and how does it fail?

Status code returned  by the command,  this is error information from the  device:
status: 0x2 (CHECK CONDITION)
When the status is CHECK_CONDITION, the sense data in the sense buffer is valid and you then check additional sense code and additional sense code qualifier. This status indicates that the target has successfully completed the
command but a contingent allegiance condition has occurred.

Sense Bytes: F0 00 04 00 03 8B EA 13 00 00 00 00 44 88 00 00
 Hex dump  of  the  auto  request  sense information for the command.

Sense Key: 0x4 Hardware Error, Segment 0
Indicates that the target detected a non-recoverable hardware failure ( controller failure, device failure, parity error, etc.) while performing the command .

Sense Code: 0x44 Qual 0x88 (internal target failure) [No matching qualifier] Fru 0x0
Sense flags: Blk 232426 (valid)

     The fourth line is a hex dump  of  the  auto  request  sense
     information for the command.

     The fifth line is the error text for the sense key if avail-
     able,  followed  by the segment number that is only valid if
     the command was a copy command. If the error message is  not
     directly  related  to the current command, the text deferred
     error is appended.

     The sixth line is the error text for the sense code and  the
     sense  qualifier if available.  If the type of the device is
     known, the sense data is decoded from tables in scsierrs.c .
     The text is followed by the error value for a field replace-
     able unit.

     The seventh line prints the block number that is related  to
     the  failed  command  and  text for several error flags. The
     block number may not be valid.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
oops - sent that before i was done editing it - the last bit is from the manpage of cd record and the line numbers don't apply here -
 decoding the error just shows a hardware error and a qualifier for which I can't find a reference (nor is there one in your scsierrs.c as it says "No matching qualifier"

If you'd like to learn more about the subsystem take a look at
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.