Preferred Logon Server

I'm actually using Server 2003 but this is still related to Server 2000. As background, I used to have this issue when I worked at a large company with six sites across the country running NT 4.0. Sometime, wokstations would choose a domain controller at a remote site as logon servers and this would casue very very slow logins. It was supposed to mean the local controllers were too busy but that wasn't the case. Anyway, we usedthe setprfdc.exe and lmhost file to solve this.

Question:  I work at a small company with two sites connected via a T1. I just setup two controllers at the primary site and a one secondary at the remote location. Anyway, very few people are using these new servers so traffic is low, but when I logged on my login script ran very slowly from the remote site. Can I set the preferred DC's in a policy or what should I do? The local dc were not busy so I'm not sure why it went remotely for logon. I really never want that to happen. if both our DC at the primary site are unavailable we are having major issues that the remote site login would not solve.

I hoped this was solved with AD ?

 
bwalanAsked:
Who is Participating?
 
Joe_CCommented:
1) Open AD Sites and Services

2)  Right click on the subnets container and select "new subnet"

3) Enter 10.10.10.0 and then assign it to the second site (if already created then just verify it's assigned to proper site)

Each site must have:

Licensing Site Settings
NTDS Site Settings
One Server

On a side note:  It's very important to ensure that the time at both sites is synchronized - see KB article 285923

Also see article 223346 regarding your FSMO placement and optimazation

When this was happening to me every time I opened AD Users & Computers Snap-In on my laptop it would default to a DC/GC that was not local to my site.  After I proplerly configured my sites and services the snap-in began using the local servers.
0
 
Joe_CCommented:
I had the same issue... remote domain controllers servicing local logon requests.  The issue was resolved after I properly configured my sites and services.

How do you have your sites and services configured?

Do you have each physical office setup as a site?
Do you have a site link between the two sites?
Do you have the proper subnets assigned to the proper sites?
0
 
simpsonehhCommented:
have the domain controllers authenticate with each other. locally have clients authenticate to a local dc.  meaning have a dc at the office.  when you authenticate where does your computer info come from? the remote site?

Joe_C has a good method, if possible, give a brief descriptions of how to.
thanks
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
Casca1Commented:
Have you set a DC at each site as a GC? Once the rest of the posts are followed, setting the local server as a GC is the final step. In fact, having a GC at each site should prevent this from happening, but we all know about Microsofts belief in the "Perfect Network World" 8-)
0
 
Joe_CCommented:
Yes... each physical office should have it's own GC to ensure that local traffic requiring the use of a GC (like logons) does not traverse the WAN.  Not only should you have a DC/GC at each site but, you need to make sure you assign the proper subnet to that site.    
0
 
bwalanAuthor Commented:
Both site have GC servers. I thought configured the sites correclty. Can somone briefly summarize what to do. Assume:

1. Primary site  10.0.0.0
2. 2nd Site       10.10.10.0

Also, what tool can I see this type of issue in. Replmon.exe shows replication occuring as expected.

Thanks
0
 
Casca1Commented:
Sites and Services. You must set the site up there for each IP subnet.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.