Poor Performance using Win Xp Peer to Peer.

Problem:
In a small four computer peer to peer network, I am receiving extremely long delays in
connecting to the computers.  Sharing applications and opening files can take a while.
The first connection to the computer is usually the longest and can take as much as 45 seconds.

Software options:
I am using IPX and TCP/IP.  

My ISP is using the TCP/IP gateway & DNS and I have enable LMhost and have LMhosts files on each computer.  I have enabled NetBIOS over TCP/IP.  

Hardware: 100Mbps Switch and a 144X DSL Router. (IDSL Router)

Any suggestions / Can you help out?

Arish75
arish75Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunray_2003Commented:
Try these

a) Disable all firewall ,Anti-virus and pop-up blockers

b) Try having the latest NIC drivers

c) Get all the software and patches for windows xp

d) Check hardware updates

Sunray
0
sunray_2003Commented:
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

stevenlewisCommented:
couple of things, try shutting off the indexing service and
http://cyberwizardpit.net/article2.htm
Here's a great tip to speed up your browsing of Windows 2000 & XP machines. Its actually a fix to a bug that by default of a normal Windows 2000 setup that scans shared files for Scheduled Tasks. And its turns out that you can experience a delay as long as 30 seconds when you try to view shared files across a network as Windows 2000 is using the extra time to search the Remote Computer for any Scheduled Tasks. Note that though the fix is originally intended for only those affected, Windows 2000 & XP users will experience that actual browsing speed of both the Internet & Windows Explorers improving significantly after applying it since it doesnt search for Scheduled Tasks anymore. Here's how :

Open up the Registry and go to :

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version/Explorer/RemoteComputer/NameSpace

Under that branch, select the key :

{D6277990-4C6A-11CF-8D87-00AA0060F5BF}

Right click it and select "Delete".







This is key that instructs Windows to search for Scheduled Tasks. If you like you may want to export the exact branch so that you can restore the key if necessary. This fix is so effective that it doesn't require a reboot and you can almost immediately determine yourself how much it speeds up your browsing processes.

Important

Note : This branch also exists in both Win98 & ME and Ive got so many mails asking me whether it's safe to apply the fix on it. However, I would like to warn users that the fix is intended only for Windows 2000 and XP. If you decide to try it for your Win98/ME system, pls make sure that you back up or export the exact branch so that you can restore the key if something should go wrong. Currently there are more than 20 users that have tried the fix in Win98/ME. Out of this 20, there are 4 users who reported that problems arises after removing the branch while the balance 16 reported great success.




0
PsiCopCommented:
WHY are you using IPX? Unless you're connecting your workstation to an ancient version of NetWare, I can't imagine why you'd need IPX. If you don't need it, its just cluttering your LAN. Remove it.
0
chicagoanCommented:
use mapped drives if you must run multiple protocols (i.e. map a drive X: to //server/share)
0
alfomatCommented:
Hi,

yes, kick IPX...
well, u do not have to use Netbios over IP as long as all Peers uses XP. Edit the HOSTS File with the same entries like your LMHOSTS and distribute it. Don`t care about DNS.

Try to hardcode the Duplex-behavior of your NIC !!! If possible, setup the flow to half-duplex and speed to 100Mbit/s on all Peers. Some NIC`s and Switches doesn`t negotiates the correct flow, a duplex-missmatch will occure and u will get a slow performance over all.

have fun
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chicagoanCommented:
both the switch and the nic have to be set explicitly, auto negotiation on one side only will use half-duplex
0
alfomatCommented:
yes, that`s the reason why i said : setup to half-duplex !!!
sometimes, i can`t adjust the switch...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
File Sharing Software

From novice to tech pro — start learning today.