Delphi 7 file associations - "repair" installation doesn't

I recently upgraded from Delphi 5 pro to Delphi 7 pro. I installed D7 while keeping D5 installed until I got everything working in D7. Then I uninstalled D5. Now all the file associations have been lost for Delphi files. I tried the D7 repair installation but it did not repair the problem. As far as I can tell, the old "registry only" installation is no longer present. Re-installing D7 with the same options on top of the existing installation does not fix the problem.

Is there any way to fix the installation without completely uninstalling and re-installing? I've done quite a bit of customizing and installing my specialized settings, components, etc, so I hate to have to do that all over again.

tgodfreyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arjanhCommented:
You could manually re-associate the .pas .dfm .dpr etc files with D7. In a Windows Explorer right click the appropriate files and set the default open with to D7.
Or, if the files are currently still linked to D5: go to Tools->Folder Options, tab File Types. Select the delphi file extensions (pas dpr dfm etc.) and enter delphi as the default "open with" command.

It's a bit tedious, but faster than uninstalling and reinstalling copmletely...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tgodfreyAuthor Commented:
I have continued to research this and found someone else had this problem;

http://groups.google.com/groups?hl=en&lr=lang_en&ie=UTF-8&oe=UTF-8&threadm=3ed3502e%240%2449113%24e4fe514c%40news.xs4all.nl&rnum=5&prev=/groups%3Fhl%3Den%26lr%3Dlang_en%26ie%3DUTF-8%26oe%3DUTF-8%26q%3Ddelphi%2B7%2Binstall%2Bassociation%26sa%3DN%26tab%3Dwg

This thread does not contain a real solution, though, other than the tedious process of manually re-associatiing each file type, although the hint of fixing the registry reference in HKCR_Applications is helpful.

I am looking for a way to cause the installer to fix the problem - like the "registry only" install in previous versions of Delphi did.

0
arjanhCommented:
You basically only need .bpg and .dpr extension to be linked to the delphi IDE. So you only need to do the manual thing twice. Besides, using right-click in Explorer makes it very easy.

I checked the install. Under the repair option it says "fixes ... and registry entries". So if that option didn't work for you, you have to do it manuall....
There is no separate register-only option anymore.
0
tgodfreyAuthor Commented:
I wanted to close this so I split the points for the two who responded.
Conclusion - this is a problem with Delphi. There is no solution. There is no warning about this issue in Delphi 7 readme or FAQs.

Anyone who is installing Delphi 7 to replace Delphi 5 should be cautioned: Either uninstall Delphi 5 before installling Delphi 7, or don't ever uninstall Delphi 5 after installing Delphi 7.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.