Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2392
  • Last Modified:

File sharing with 3 systems - xpPro/xpHome/2000

It seems like I only have partial network file sharing going on.  I have three computers that currently all have internet access through the same router, but I need to share files between the three computers.  Here is my current configuration:

- Cable Modem connected to the WAN port of a Linksys BEFW11S4 "EtherFast Wireless Access Point + Cable/DSL Router with 4-Port Switch"
- Win XP Professional computer has one network card, connected to a router's LAN port, internet works
- Win XP Home computer has one network card, connected to a router's LAN port, internet works
- Win 2000 computer has one network card, connected to a router's LAN port, internet works
- EACH computer can ping EITHER other the other two computers, however the XP Pro computer can not ping the 2000 computer (timed out error occurs).

- Win XP Pro computer's network connection properties:
Client for Microsft Networks (checked)
File and printer sharing for microsoft networks (checked)
QoS packet scheduler (checked)
Internet Protocol (TCP/IP) (checked)

- Win XP Home computer's network connection properties:
Client for Microsft Networks (checked)
Deterministic Network Enhancer (checked)
File and printer sharing for microsoft networks (checked)
QoS packet scheduler (checked)
Internet Protocol (TCP/IP) (checked)

- Win 2000 computer's network connection properties:
Client for Microsft Networks (checked)
File and printer sharing for microsoft networks (checked)
Internet Protocol (TCP/IP) (checked)
Sharing tab: Internet Connection Sharing (unchecked)


Each computer can access the router's built in configuration page: 192.168.1.1
Each computer can see the same DHCP Active IP table:
- Win 2000 computer:  192.168.1.100
- Win XP Home computer: 192.168.1.101
- Win XP Pro computer: 191.168.1.102

XP Home computer can see both computer's files.  
XP 2000 computer can only see the XP Home computer's files. (clicking 'view workgroup computers brings up all computers, but when trying to click on the XP Pro computer, gives \\Killer is not accessable.  The network path was not found)
XP Pro computer can't see either computer's files. (clicking 'view workgroup computers' gives "Friday is not accessable.  You might not have permission... contact the network admin)

I need all computers to be able to share files with eachother.  
0
iamthekiller
Asked:
iamthekiller
1 Solution
 
lrmooreCommented:
3 things to deal with here...
1. Netbios name resolution. Netbios is DIS abled by default on XP, ENabled by default on Win2k.
Enable on both XP boxes:
2. One-way information. Win2k can ping others, others cannot ping Win2k. 99.9% of the time, there is a firewall on the one that cannot be pinged
3. User accounts/permissions. Either enble guest account on all machines, or create identical username/passwords on all machines...

Some information networking XP to non-XP. XP has a whole new setup and must be adjusted to be backward compatible.

--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

References:
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm
0
 
iamthekillerAuthor Commented:
I could have sworn I had removed Zonealarm from the 2000 computer, but that was the problem.  Thanks for forcing me through the steps!
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now