installing gaim messanger

I have a redhat linux 9  installed in my pc.I wanted a messanger for my hotmail account,so i downloaded the giam0.73  package and when i did the ./configure i get the fallowing message.


...........
........
checking for socklen_t... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

plaese help me in solving the problem.
fierof2Asked:
Who is Participating?
 
asbharadwajCommented:
>>i installed the glib-2.2.0
You should be knowing where you have installed right?
If you used rpm , type rpm -qi glib and that will give you the info
the most probable location would be in /usr/local/lib
do a locate glib or find /usr/local -name glib

then export LD_LIBRARY_PATH = path_to_glib : $LD_LIBRARY_PATH

then do the configure thing

Another approach would be to add the path to the /etc/ld.so.conf file
and run ldconfig
0
 
asbharadwajCommented:
Seems you have an older version of glib or the configure script is unable to find
the latest glib
try rpm -qa | grep glib to get a list of glib packages installed on your system
look for glib2
if your glib version is < 2.0 you'll have to upgrade to a later version

if the version is > 2 then gaim is unable to find the libraries
Locate the glib libraries and add the path to LD_LIBRARY_PATH
and then do the ./configure
0
 
fierof2Author Commented:
Thank you for your comment

i think i am having a older version of glib.this is what i got

bash-2.05b# rpm -qa | grep glib
glib-1.2.10-10
glibc-devel-2.3.2-11.9
glibc-common-2.3.2-11.9
glibc-2.3.2-11.9
glib2-2.2.1-1
glibc-kernheaders-2.4-8.10
bash-2.05b#

Please tell me how to upgarde to lastest version
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
durindilCommented:
go to www.rpmfind.net and search for "glib" there will be links to the RPM packages there, and you can use them to upgrade.
0
 
asbharadwajCommented:
You can get it from
ftp://ftp.gtk.org/pub/gtk/v2.2/
if you want to go the sources-configure-make way

Wonder if rpm would let you upgrade if there are any packages that are
dependant on the lower version? You might end up having to upgrade a
whole lot of packages. Please correct me if Im wrong durindil
0
 
fierof2Author Commented:
i installed the glib-2.2.0.i get the same problem when i ./configure gaim .even after installing the glib 2.2.0
when i execute the command rpm -qa | grep glib i get the same result as mentioned above
0
 
durindilCommented:
My Counter Strike server doesn't have X-Windows on it, so I use NAIM.  It is a text-based client that only requires ncurses.  You might want to try that in the interim?

Oh, and asbharadwaj, I have run into the RPM upgrade chain nightmare before.  I will actually make and install from source to another directory, just so I can use two versions of the same package, to try to avoid this.  Doesn't always work, but you sure learn a lot about packages in the process!

NAIM can be found at:

http://site.n.ml.org/info/naim/
0
 
asbharadwajCommented:
Hi fierof2
Did u try the LD_LIBRARY_PATH thing? Think lot of people had this problem of
gaim not finding path to glib
add the path to your glib to LD_LIBRARY_PATH
and then try

and durindil
thanks for clearing my doubts. Now i need not regret not using
rpms for all the packages I installed :-)
0
 
fierof2Author Commented:
hi asbharadwaj

I am new to linux ,i dont know how to find the path to glib  and i dont know what command i should be
typing for LD_LIBRARY_PATH.Please tell me what command i should be typing.

and durindil
naims is a messanger for AOL and not HOTMAIL OR YAHOO.
0
 
durindilCommented:
Sorry, I use it for IRC so I thought it would support others as well.
0
 
tuxoverflowCommented:
Forget all that follow this

For redhat 9
Go to www.freshrpms.net and there go to redhat 9 shrike packages
download apt rpm - at a prompt as root install the apt rpm - rpm -ivh apt*
then type apt-get update - then type apt-get install gaim
If there is a error with your rpms you will have to type apt-get -f install to fix
Otherwise this will get gain (newest version) and required dependencies and install them correctly - Forget the headache use the tools that help you :-)

Wayne
happy tuxin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.