Solved

Computer allergic to installing 98-on anything!

Posted on 2003-11-22
17
443 Views
Last Modified: 2013-12-29
Hi,
I am currently trying to install Win 98 on an old PC, but without much luck. Whenever I run setup after booting from a EBD it just restarts after it has finished checking for installed components. I have tried different CDs, different CD-ROM drives, even taking out some of the RAM in case it was conflicting (I have had this on this computer before, see my other thread) and even different hard drives. It always gives the same error in the same place.
      On some hard disks, despite being recently formatted setup detects compressed volumes and if I continue it will eithr give the same message as above or say it cannot create tempory files and cannot continue.
0
Comment
Question by:mark_667
  • 7
  • 5
  • 3
  • +2
17 Comments
 
LVL 47

Expert Comment

by:dbrunton
ID: 9804830
Hmm.

These hard disks, have you removed all partitions, created a new one and reformatted it?


And check that the BIOS permits writing to the partition table.




The other possibility is to copy the CDROM drive down to the hard disk and install from that.

Format the hard disk with the command


format c: /s


Now copy the win98 folder down to the hard disk.  Make a folder there called win98.

Now boot from hard disk and run the following commands

cd /win98
setup
0
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 9804980
hmmmmmmm.........y don't u try to boot the system with a Win98 Start Up Floppy Disk instead of the CD......!!

Make a Win98 Startup Disk form anyother computer running Win98 or download it form this site:

www.bootdisk.com

then boot the system with this floppy......chooz start sith CDROM Support.......it will tel u that which drive is ur CDROM drive.....now format the hard drive, by typing format C:
let the drive to fromat fully....then insert ur Win98 Cdrom......type ur CDROM drive letter, e.g. D:
hit enter.....now type setup.exe.....setup will start......check if this time also it restarts or not......if YES then may be there is some problem with ur motherboard.....or some other hardware!!
0
 
LVL 1

Author Comment

by:mark_667
ID: 9806154
Sorry if I didn't make myself entirely clear, not all the hard disks have been formatted in the way you describe, but lets leave that for now; all I was trying to say was that I've tried everything! I tried what dbrunton suggested, but messed up the DOS commands somewhere. On the main HD I'm working with (this has been recently formatted) I tried:
I have created the windows directorie and and cabs sub-directory, but do not know how to copy over all the files from the CD. I have tried:
copy *.* E :\setup C:\windows\cabs
but this only gives me 'bad command or file name' or 'path not found' if I change a couple things round. Am I trying to copy the wrong folder from the CD? And when I do boot from the HD, will it automatically start setup or will I have to use DOS? If so, do I have to be in the same subdirectory to do this?

Oh, and I have tried starting from the CD, I just get the same.
0
 
LVL 47

Expert Comment

by:dbrunton
ID: 9806254
These are the  dos commands you need on a clean formatted hard disk.  Assuming you have booted off a floppy with CDROM support and the 98 disk in the drive try the following.

md   c:\win98
copy   e:\win98\*.*   c:\win98\*.*
copy   d:\win98\*.*   c:\win98\*.*

Use the two commands above in case your CDROM drive is at either d: or e:

Reboot without floppy and then

cd \win98
setup.exe
0
 
LVL 38

Expert Comment

by:BillDL
ID: 9808285
You say you are receiving warnings about a "compressed volume".  This tends to indicate that something like DriveSpace has been used previously to get that bit of extra space on the 2 GB drive as the user began to run out of it.  The problem with DriveSpace is that it can't then use the hard drive as FAT32.

Try and find out more detail by booting to your Win98 boot floppy and typing FDISK.  Choose option 4 to "View" the drive details and let us know what it says.

It looks like the drives have been formatted as FAT16.
0
 
LVL 13

Expert Comment

by:gonzal13
ID: 9820290
If it is true that you only have a 2 gig HD, you might just as well forget it. Get an 80 gig, 7500 rpm HD, a promise card, since your motherboard/Bios will not recognize a hd larger than 10 gigs which are not made. Your local dealer, if he is slightly crooked, will say that you need a complete new system and not mention the Promise card.
0
 
LVL 1

Author Comment

by:mark_667
ID: 9821130
Hi,
Sorry I haven't been able to get back to the post for a couple of days...after copying the files over to the hard disk using dburton's command suggestion, only to get the same thing about compressed volumes and then the freeze at the same point (after copying from the CD and then restarting) when running setup from the HD! I booted from a floppy again and ran FDisk, but it only shows 100% usage of the HD with a FAT 32 system as PRI DOS just as it should be. I then copied the files to the same destination directory from a different disk overwriting them all, just in case it was a corrupt setup files on the disk that was causing it. It came up with the same thing with the compressed volumes, then just froze as above. Any more ideas?
PS. the FAT 16 thing was causing some bugs, but not on the main HD I just mentioned above, I fixed it through FDisk. how did that get on there by the way? I never done it and none of the windows setup apps use it do they? :confused: oh well, sorted now, thanks BillDL :)
0
 
LVL 38

Expert Comment

by:BillDL
ID: 9822741
Personally, I would persevere a little longer with this.  If this were my project, I would run FDISK again, but this time use the command FDISK  /MBR.  You won't get any feedback, but boot again and try the file copy thing once more.

If that fails, FDISK and remove ALL partitions, including the option to delete all NON-DOS partitions that may or may not be shown.
Reboot to the boot floppy, and you should get the usual warnings about no FAT present.
FDISK, and CREATE a primary DOS partition and make it active
***** Reboot to the floppy  ***** Essential step!!!
and format again.

I assume, from what you have said, that you are familiar with FDISK, but download this .hlp file if you aren't.

http://www.fdisk.com/fdisk/FDISK.HLP.zip

0
Do email signature updates give you a headache?

Constantly trying to correctly format email signatures? Spending all of your time at every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

 
LVL 38

Expert Comment

by:BillDL
ID: 9822749
Sorry, I see that dbrunton already suggested this earlier:

>>> "These hard disks, have you removed all partitions, created a new one and reformatted it?" <<<

The only other thing left if all this fails is a "low level format".  Such utilities to be run from boot floppies can be downloaded from the manufacturer's site, although I have had varied success using this method.

What is the make and model of the HDD?


0
 
LVL 47

Expert Comment

by:dbrunton
ID: 9822770
Other suggestions.

Get another cable for the hard disk and check that the BIOS is set to autodetect the hard disk instead of manually assigning values for the disk.

And try the hard disk on the secondary IDE channel and see what happens there.
0
 
LVL 38

Expert Comment

by:BillDL
ID: 9829502
You know, I'm still wondering about my suggestion concerning DriveSpace or DriveSpace3 having been used on this drive at some previous time.  A 2.1 GB hard drive would have been a likely candidate for somebody wanting to compres it to gain a bit of extra capacity.

I don't know if you are aware of these utilities, but they are installed with Windows 95 and 98 respectively.  They create what is known as a "host drive" that allows the drive to operate normally, but I'm not absolutely certain what would happen if your removed Windows by whatever means, and attempted to format and reinstall onto it.

If you know anybody else with a Windows 98 computer and only one hard drive, perhaps you could try patching it in there as a slave, and setting the jumpers accordingly.

Start DriveSpace and select your drive.  The drive has to be "mounted" in Drivespace, but it will soon enough tell you if it HAS been compressed.  You then have the option of removing the compression.

Worth a try perhaps?

http://www.jefftech.net/34.html

screenshot: http://www.wugnet.com/tips/display.asp?ID=449

There are better discussions an tutorials on the web, but those 2 came up.
0
 
LVL 1

Author Comment

by:mark_667
ID: 9833685
The HD is a Samsung sv401a 010 4.2GB (the 2 GB one I mentioned before was another I only included it because I had a similar problem with it on the same box - just ignore it!).
      The DriveSpace utilities I was not aware of, do they require user intervention to creat&#65533;e compressed volumes as I never saw anything like this (back in the day when it was working)? Even if they did compress the drive, shouldn't they have been gotten rid of when I deleted the primary DOS partition and then formatted the drive? I've never had anything like that before when installing 98 on drives of a similar size after formatting, etc. I may try it as a slave in a working system if nothing else works.
      The first time I did not delete the partition, I only re-formatted it.&#65533;&#65533; I have just tried installing 98 from CD after creating the DOS partition (without formatting) and setup still gave the warning about compressed volumes! I then created the partition as normal only to get the same when running setup from either the CD or HD. I then tried the fdisk/mbr, but this had no effect; it still comes up with a black rectangle on screen during setup as if it has not has a chance to re-draw the screen properly after scanning for installed components, (I think this is meant to be an error message) and obviously the compressed drive thing.
0
 
LVL 38

Expert Comment

by:BillDL
ID: 9834649
The strange "&#65533;" characters you are seeing on this page should be ??? symbols, but it looks like you created the text in another application and pasted it in here.  This is normally what is seen in the html source code of a web page.  Strange.

Anyhow, to address your questions.  Yes, I would have thought that FDISK should have removed all vestiges of compression from the disk when you removed the partitions.  After all, you are removing the structure that allows a fileing structure to exist, and the compression relies on there being a filing structure.  It just seems rather odd, this "compressed volume" message, and that's the reason I wanted to eliminate this possibility by placing it as a slave drive in another Win98 PC and checking with DriveSpace.

I presume that FDISK is now informing you that you have a FAT32 primary DOS partition?

I am trying to go through the install sequence in my mind to see what should be happening as you have described ie. "after scanning for installed components".

Try running the setup command with the following switches, where x is your CD Rom:

x:\SETUP.EXE  /ie  /im  /is  /iv  /nr

Options:
/ie  - Skip the Startup Disk screen.
/im - Skip the check for low conventional memory.
/is  - Do not run ScanDisk.
/iv  - Do not display billboards.
/nr - Skips the registry check.

At the stage you are talking about, it is using the standard VGA video driver and showing a resolution of 640 x 480 x 16 colour, so it's nothing to do with colour.

It could be a memory problem, but try the setup options above and let us know what happens.

0
 
LVL 1

Author Comment

by:mark_667
ID: 9842392
> The strange "&#65533;" characters you are seeing on this page should be ??? symbols, but it looks like you created the text in another application and pasted it in here.  This is normally what is seen in the html source code of a web page.  Strange.

Actually, I use an old Mac for most things (ironically, this is usually fixing the PC), it's the only computer I have that ever works (the rest are all Windows PCs) so I will often copy and paste into an app called notepad so I can view responses without needing to be online or have my browser open so I can come back to it later if I have to do something else. I'll usually draft my responses there as well, but the codes only show up after I've pasted it into the response window I'll check over them more carefully in future :)

>It could be a memory problem, but try the setup options above and let us know what happens.

I tried the setup options you mentioned, but they didn't make any difference, don't know what you had in mind, but it's something else. Once (ages ago) I had the window draw normally and the error read 'cannot find setupx.dll' I don't know whether this is the same one, but it appears at the same stage. However, as mentioned above I have tried several (all fully working) 98 disks and have never got this error on anyof them before. I have also tried installing win 95 just to try to get a working Windows OS on and try installing 98 over that. But even there it comes up with the same notice about the compressed volume and freezes just like the 98.
0
 
LVL 38

Accepted Solution

by:
BillDL earned 100 total points
ID: 9842827
I'm really puzzled about this one, Mark.  The setup switches were just a last ditch to see if you could bypass as many potential problem areas as possible, but it's obviously something unconnected.

I really think that your last option here is to download:

(a) a hard drive diagnostics utility and
(b) a low level format utility

from the manufacturer of your hard drive and firstly run the diagnostics as suggested.
Usually you run an .exe in Windows and it makes a boot floppy.

If this fails, then I don't see any other realistic way of getting this hard drive to work without going to extremes usually left for when all else has failed.  These low level formats can take a long while, and you then have to use FDISK to recreate the Primary DOS partition again.

I don't know what else to suggest.  I had a 2nd-hand 4.3 GB one a while back from an auction, and even the low level format failed to revive it.

I thought I had the url for that hard drive, but my download doesn't cover that specific SV model.

Double-Check that these url's apply:

http://www.samsung.com/Products/HardDiskDrive/utilities/shdiag.htm

http://www.samsung.com/Products/HardDiskDrive/utilities/attach_file/Shdiag.exe

HDD Manuals
http://www.samsung.com/Products/HardDiskDrive/support/Download/manual/index.htm

http://www.samsung.com/Products/HardDiskDrive/support/Download/userguide/index.htm
0
 
LVL 1

Author Comment

by:mark_667
ID: 9987185
Thought I'd finally close this thread. It looks like Windows wasn't installing because of a low-level problem on the HDDs some of the links, recommended by BillDL above, had utilities which picked up and corrected them (even then, they were only detected on the more thorough surface tests). I found this site:
http://pcmedicdirect.com/downloads/Utilities/Hard%20Disk/
has quite a few good utilities for various makes. Thanks for the feedback all. Much appreciated!
0
 
LVL 38

Expert Comment

by:BillDL
ID: 9989335
Thank you Mark, and good luck.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
ZIP or ZIPX 8 71
How to make Netflix quicker? 4 40
PCAnywhere 2 58
How do i reduce disk usage on Windows System ? 31 68
Update 11/3/2014 - Although the below article will get you to relocate the WINSXS folder, Microsoft has finally released a utility to reduce the size of the WINSXS folder. For some reason, it's not that straightforward. It only works on Windows 2008…
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now