Intermittent Autorun

Hello experts,

I've been having this problem for a while now, althought it hasn't really bothered me... much. However, I'd still want it solved . Anyway, here goes:

Whenever I reboot the computer with a CD in the drive or when it read the first CD after a reboot (with nothing in the drive), autorun for that CD works fine. Afterward, any CD that runs the same executable works fine. Only when I insert a CD with a different program would it failed to run. Even when there is no CD in the drive, it would act as though there is an autorun.inf there (via the right-click menu). This seems to happen after I started following some guide to disable some unnecessary services, although I can't say for sure if that's when it started.

I've gone through some PAQ'd questions, but they don't seem to have the solution I'm looking for, yet I've tried them anyway, along with my own idea:
- looking at HKLM\SYSTEM\CurrentControlSet\Services\Cdrom\AutoRun (it's a DWORD:1)
- disabling, then reenabling "Enable Autoplay for CD and DVD drives" in TweakUI for XP
- setting all content types to "Prompt me" in the AutoPlay tab in the properties of each CD/DVD drive
- installing XP Pro SP1 in a virtual machine software and compared the default startup type for all services

This affects all CD/DVD drives that are installed on my computer, including virtual DVD drives. There are also two problems associated with this. AutoPlay does not work anymore, and the icon for the CD does not show up anymore (the one defined in the autorun.inf->[autorun]->Icon=...), even if the the autorun for the CD works.

Short of running the repair Windows from the CD, or comparing the registry line by line with the one I installed in the virtual machine, is there anything else that I should look for?
LVL 3
cwpAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mr_SkinnyCommented:
Have you got Easy CD Creator installed on your machine? some versions of this can cause problems with autorun in xp.
cwpAuthor Commented:
Nope. I've never had any installed on this computer before. What I do have is Alcohol 120%, Nero 5.5 (but not InCD), and Daemon-Tools, but I've had all these installed before and never had this kind of problem.
Mr_SkinnyCommented:
I guess you could re-enable those services you disabled to determine whether that was the cause or not.  If it starts working properly disable the services again one by one to find the culprit.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

LeeTutorretiredCommented:
Have you looked at this Microsoft Knowledge Base article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;330135
The AutoRun or AutoPlay Feature Does Not Work
cwpAuthor Commented:
@ Mr_Skinny
Well, I don't remember which ones I've disabled anymore since the changes were made a few months ago, but I did compare the services against a known working installation.

@ LeeTutor
I've checked the article, and the only chance was setting NoDriveTypeAutoRun to 0x91, but that did not help as well. I went a little further and checked for one other relevant article: Q817357. I've located the fix on Fujitsu's website, installed, rebooted, but still have the same problem.
Mr_SkinnyCommented:
I would try the windows repair, it only takes a couple of minutes.  If that doesnt work I guess you're looking at a full reinstall, unless anyone else has any ideas?
LeeTutorretiredCommented:
Here's some more info I found on enabling autorun:

http://www.kellys-korner-xp.com/xp_abc.htm

Auto-Play:  Enable

Control Panel/Administrative Tools/Services/Shell Hardware Detection/Return this service to Automatic.

Start/Run/Gpedit.msc/Computer Configuration/Administrative Templates/System. Check your settings in the right pane for Turn Off AutoPlay (and modify).

Start/Run/Regedit
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Services\Cdrom.  AutoRun = 1

Or run this edit:  Enable CD AutoPlay for Pro or Home (Line 10)

If you are using TweakUI/My Computer/AutoPlay
http://www.microsoft.com/windowsxp/pro/downloads/powertoys.asp

Go to Start/Run/Regedit and navigate to this key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers. Right click on the AutoplayHandlers subkey and delete it. Do the same here under this key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives

If still not corrected, manually make these changes under this key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives

Double click the "Drive Type" value to change it's properties. CD-R should be set to 1; CD-RW should be set
to 2;  Non-Writable should be set to 3. Then under AutoPlayHandlers:  User Defaults verify MSCDBurningOnArrival.  For any listed without an Autoplay LegacyHandler, set it to AutoPlay.

AutoPlay Handler Keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\Handlers\
MSTakeNoAction
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\Handlers

Restore AutoPlay Handlers (Line 99)
http://www.kellys-korner-xp.com/xp_tweaks.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cwpAuthor Commented:
Welp, Kelly's Korner did the trick, specifically setting HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\allocatecdrom=0 in the "Enable CD AutoPlay for Pro or Home" reg file, but I tried all of them before rebooting anyway ;). Thanks LeeTutor.
LeeTutorretiredCommented:
Glad to be of help, cwp.  And thanks for increasing the points, too.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.