Lost internet access after Linksys install, can still browse my local network

After installing a Linksys wirelass USB adapter on my laptop,
I can access the other members of my network, but any attempt
to access the internet gives me a dreaded ...DNSError page.
I can ping places like Yahoo by ip address, but not by "name", so it seems to be a DNS problem,  but I have tried everything I can think of to no avail. I am on a cable modem, with a Linksys router.  I have even tried replacing winsock.dll - ( it seemed to be overwritten with a different date - I got this idea from a eweb search). Any ideas??  
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

What OS on your laptop?
from results of C:\>ipconfig /all
What do you have listed as DNS servers?
Try manually adding one public server i.e.
Can you configure the USB device? It seem slike it giving out the wrong DNS address (if any)
Can you go back to the previous configuration?
If you can , once everything is working, then write down the DNS address of your ISP, and configure your machines to se it manually, and if you can also add it to the USB deveice DNS settings. Then hook up the USB device again with your computers
audiodudeAuthor Commented:


The OS is Win 98SE. I have tried both auto - DNS, and also manually setting DNS to point to
(Road Runners) known good DNS addresses.  How specifically do I manually add the public server?

As for the previous configuration, going back to the hard-wired ethernet adapter gives me the
same symptoms.  I am not sure what has gotten messed up.  But I really dont wanna reload this PC from scratch.

OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

I think that you have a spyware running there.
TRy using Spybot , Ad Aware or Bulletproof spyware removal to clean your computer of spyware programs.
check this link fro a little bit more of info
audiodudeAuthor Commented:
I ran SpySweeper, and it found a couple of Adware infections, and a bunch of cookies with "traces". I removed them.  I still cant get on the 'net.  I still have the problem where I can ping numeric addresses, but cant access sites by name - sounds like no DNS resolution to me.  lrmoore asked about what was displayed re DNS from ipconfig.  ipconfig show nothing concerning DNS??..???I have tried setting DNS config to point to RoadRunner's DNS server addresses but no help.???Still workin on it.....
audiodudeAuthor Commented:
-An update on my networking problem...
Running Win 98 SE, have done an "over-install" of Windows 98,
the USB adapter has been removed,  I can still ping locations by ip#,
but can't resolve addresses by name - all other PC's on my Linksys router can access the internet - I can access all the other PCs from my laptop, The only clue I have is when I run ipconfig on one of the pc's that work it show DNS server addressses - running ipconfig on my laptop doen't mention DNS..Whuzzzup?
Click on the Advance or Detail button after running winipcfg, it will give you more info.
audiodudeAuthor Commented:
I got rid of more spyware critters, but still no DNS resolution.
I've been messing with networks for 15 years, but this one has me stumped! ---lrmoore mentioned setting up a public DNS server - how does one do that specifically??
BTW the advances screen of winipcfg show no DNS affiliation at all!
Thanks in advance Sam Richardson

Change your DNS settings on the workstation. TCP/IP properties, Advanced, DNS tab.
Add this server (which is a publicly accessible uunet cache nameserver):

Any manually added server entries should override 'learned' from DHCP.
This has nothing to do with this ping or DNS issue, but could have with your browsing.
Did you check if you have any proxy settings on your Internet Explorer in the Connection Tab under Lan Settings?
audiodudeAuthor Commented:
I tried setting the manual DNS using - still no name resolution....I know in my gut if I reloaded Windows "from scratch" this thing would work - but I had a heck of a time getting all my drivers reloaded last time!....
audiodudeAuthor Commented:
koquito - I have always ran this before with "automatically detect settings setup , and no proxy - that is the way is is set up now...
Do "you'all" think it would do any good to reload IE??

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
You might also try reparing the TCP/IP stack

Reset TCP/IP in Win9x / ME

audiodudeAuthor Commented:
to lrmoore:
Thank you, Thank you!
the ipfix tool did the job!!
I'll remember this one!!
Sam Richardson
Wonderful news!
Time for a happy holiday season!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.