• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1049
  • Last Modified:

Win98 machine cannot fileshare with 2000

Hi,

I have a Windows 98 machine networked to a Windows 2000 computer. The network has TCP/IP file sharing, Microsoft Internet Connection Sharing (The 2k machine is the server), and and IPX/SPX compatible protocol for game playing. The gaming and Internet connection sharing work fine. The 2k machine has no problem accessing the files on the 98 machine. But the problem is, sometimes the Win98 computer cannot detect the other system. I get the Network Neighborhood error "\\ Family is not accessible. The device does not exist on the network." Family is the name of the Win2k computer. What confuses me is that the Win98 machine can access the 2k machine's files fine for a while after the computer comes on. It seems to stop working after the 98 machine does something like going to a website through the shared connection.

I have unbound the IPX protocol from file sharing on the 98 machine. I'm not totally sure if I have on the 2k machine. There doesn't seem to be any option to that I can see. I have also set the IP address of the 2k machine to 192.168.0.1, and the 98 machine is set to obtain its address automatically. The Primary Network Logon for the 98 machine is set to Microsoft Family Logon. I have created a user for the 98 machine in Windows 2000 with a blank password.

I can provide more information on request. Thank you for your time.
0
JonWoyame
Asked:
JonWoyame
1 Solution
 
lrmooreCommented:
Try enabling the Guest account on the 2K system. Do not change password or anything, just Enable...
It that works, then it is a simple permissions issue.
Blank passwords don't always work the way we want them to, so perhaps you can create an identical username/password on both systems.

You can also try adding the win2K system to the 98 system's LMHOSTS file.
Single entry:
192.168.0.1 <tab> FAMILY

Save file as "c:\Windows\lmhosts" note: no .txt or any other file extension.
(on 98)
Then use command line C:\>nbtstat -R  <--Capital "R", case sensitive
Then use command line C:\>nbtstat -c to make sure you have FAMILY in the cache
0
 
kaooooooooCommented:
In your scenario, network won’t work properly while internet connection sharing has been enabled. Try windows xp (server) and windows 98 (workstation), network and internet sharing can work all right.
0
 
SPHCommented:
You could also try setting up a user on the Win2K machine with the same name as the login user name on the Win98 machine.  I would also unbind file sharing from the TCP/IP protocol as it is a bit of a security risk if you're using the Internet on the same machine. Try enabling NetBEUI for file sharing instead. This way you can keep the file sharing protocol seperate from the Internet, and probably have less problems with your TCP/IP settings.
0
 
JonWoyameAuthor Commented:
It has been a while, and NetBEUI file sharing seems to be working fine. I still haven't figured out what's wrong with TCP/IP file sharing (I haven't tried all of lrmoore's suggestions) but it probably doesn't matter anyway, if TCP/IP file sharing is a security hazard with ICS.

Thank you everyone.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now