Opening links in emails

I had this once before and I don't remember what I checked or unchecked to fix it. But, when I click on a link within an email i get this message "Ths operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator."  That would be me ... but, can anyone help me here?  Thanks - cathy

Oh, forgot to mention ... Outlook 2002 and Windows XP PRo.
Squirc77Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
shivsaCommented:
1. This is actually a security feature of Outlook in response to a number of viruses that placed malicious links in emails as attachments.  If you want to disable this, go to the main Outlook window then  Tools-->Options-->Security tab-->Attachment Security button and choose none (default is high).

2. if you do not have any program associated with files of type "HTM", clicking these links fails. Reinstalling your web browser associates "HTM" files properly in WINDOWS Software.
0
 
shivsaCommented:
also reinstalling outlook and office may clear the things perfectly, if something have gone wrong.
0
 
Squirc77Author Commented:
shivsa, i appreciate your time in answering but I sure get tired of the "pat answer" to "reinstall".

For whatever reason when I Shift + Click the link it opens in Outlook ... i stumbled on this by accident. Now if I can just get the links to open in my forums.  The newsreader just sits there when links are clicked on the response pages from the forum. I'll stumble across that someday too cuz I know it's happened before. I just thought I could get a quick answer.

Thanks for trying.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
RanjeetRainCommented:
You may try restoring the association manually.

Open Winodws Explorer and localte a .htm file. <Shift> + <Right-click> brings up "Open with..." command. On some OSs you might just right-click and there is a "Choose program to open with..." Select the program you would like to associate it with and select the check box labled "Alwyas open with this program".

0
 
shivsaCommented:
could u check this:
----------------------------------
internet explorer/tools/internet options/
in advanced tab, under section Navigation, uncheck reuse windows to launch shortcuts
0
 
shivsaCommented:
if above does not work then check out this link.

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q281679&sd=tech
0
 
Squirc77Author Commented:
RanjeetRain ... this is the answer I was looking for and how I fixed this problem the last time it occured. But, here is my problem now. When I right click  and choose Open with , I browse to Internet Explorer, click on Explorer.exe and select to always open with this program, but, it doesn't add IE to the list. I have a "Windows XP Component Program " in the options list which i don't remember seeing before. When I click on it, it opens the .htm document in Word! Ya oughta see what that looks like!  Any ideas on how I can get Explorer to show in the Folder Options list? I've tried a different way through My Computer> Tools> Folder Options ... no luck either.  Thanks! We're on the right track.
0
 
RanjeetRainCommented:
Ok. Do some more. Scrap your .htm file association altogether and build it all over again.

1. Open explorer
2. Click menu Tools
3. Folder options
4. File types
5. In the registered file type box look for Microsoft HTML document or something sismilar. You have to drop ALL HTML docuemnt types. (.htm .html .mht) may the problem is due to multple association.
6. Then recreate the association using the above suggested method.
0
 
Squirc77Author Commented:
Crap is right. : )  How I fixed this before I saw your response is, I downloaded the IE updater, and then had to off that Silly Program that loads with it. But, I was then able to associate the .html and .htm files to open with Explorer. I also reinstalled Office XP hoping it would fix the link problem in Outlook, but nope. I still can't open links there or within my forums. Frustrating. I'll keep trying if you or anyone has more suggestions. Thanks.

To Shivsa: Thanks for the link. I actually already had gone there and went through the first few steps until I got to the registry stuff. I don't know how to check to see if those registry keys or numbers, whatever they are, are on my system. Hope this is making some sense.
0
 
shivsaCommented:
Actually that is simple.
just follow step by step, anyway it does not harm, just confirm that all the settings on your system ate correct.
--------------------------------------------------------
RESOLUTION
To resolve this problem in Internet Explorer, follow these steps:

   1. Quit all programs that are running.
   2. Click Start, and then click Run.
   3. Type regsvr32 urlmon.dll, and then click OK.
   4. When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK.

If this does not resolve the problem, repeat steps 2 through 4 for each of the following files (in step 3, replace Urlmon.dll with each of the file names below):

    * Shdocvw.dll
    * Msjava.dll
    * Actxprxy.dll
    * Oleaut32.dll
    * Mshtml.dll
    * Browseui.dll
    * Shell32.dll (Windows XP and Windows 2000 only)

If the problem is still not resolved, verify that the following registry values are present and correct:

HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}
Name: (Default)
Value: IDispatch
HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid
Name: (Default)
Value: {00020420-0000-0000-C000-000000000046}
HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid32
Name: (Default)
Value: {00020420-0000-0000-C000-000000000046}


If the problem is still not resolved, reinstall Internet Explorer. If you are using the version of Internet Explorer that is included with your operating system, reinstall or repair your operating system.
0
 
Squirc77Author Commented:
Sorry that I'm being so dense. Last evening I did steps 1-4 entering each .dll and each succeeded.  I don't know how to check if values are present and correct in the registry. I tried to follow the path starting with HKLM but didnt get it. Also, last evening I did the repair to the operating system. If I have to reinstall the OS do I just run the program or do I have to remove XP first? And, will I lose my programs/files ...  I'm thinking I may just do a Restore. I'm at work, so will have to wait until tonight to work on this. Thanks.
0
 
shivsaCommented:
if u do not format the disk
and If you put the disk in, you should be prompted for an Upgrade option when XP starts up. If you choose this you will be fine.

if u do restore that will be simply great too.

also when u run runedit.
try clicking HKLM  it opens up then click SOFTWARE .... and so on at last u will see Interface clicking on this will show u this
{00020400-0000-0000-C000-000000000046}.
if u click on this value on right hand side u will see the values. check the values.
u cando it for all the values shown above.

if this also does not work then
try restore.
if restore does not work then u may reinstall XP.
0
 
Squirc77Author Commented:
I'm baaaaaaaack  : )

I just run regedit and the keys i see are all HKEY_Classes  etc. I did a search in the registry for HKLM and nothing shows. Am I in the correct place? How do I add these since they appear to be missing? Are we on the right track? Oh, I did a system restore and it didn't help the problem so I undid it. This is a computer I don't use much, i'm usually on my laptop. My daughter uses this more, so who knows what might have happened, altho she is usually careful, and I Shan't blame the child  : )

Thank you, again.
0
 
shivsaCommented:
start from there only HKEY_CLASSES_ROOT.
or just type 00020400-0000-0000-C000-000000000046 in find windows of regedit and it will do the job for u.
HKLM is short form.
0
 
Squirc77Author Commented:
shivsa,
okay, got it. And, all the values are there. So, i suppose i'm to the point of reinstalling XP. I only have the upgrade CD since I upgraded from 2000, so can I just ran that and my files will not be affected? Going to bed, will check in the morning. Again, thank you. YOur input is appreciated.
0
 
sunray_2003Commented:
Are you still not able to figure out the registry key given in the  link sent by Shivsa..

Just open registry ( Start --> run --> regedit)
and click on Ctrl = F and give the registry key and it will find for you

Sunray
0
 
Squirc77Author Commented:
Sunray,
Oh yes, I found them. That's what I meant by my previous response that all the values are in the registry. I was able to obtain a copy of Outlook 2002 so am going to reinstall. I still can't get my Outlook program to open links... don't know what happened or how to fix it. First I have to figure what files to save so I don't lose my contacts and forums. I know i have to save my .pst file but not sure where the forum info is stored. Any idea?
Thank you for checking in with me.
0
 
shivsaCommented:
HI Squirc77,

read this article to backup your outlook data. this has all the information u need.

http://support.microsoft.com/?kbid=287070
0
 
Squirc77Author Commented:
hello everyone,
i solved my own problem and am so excited i thought i'd let you know how it happened ... quite by accident, actually.

I Opened Control Panel > Add/Remove Programs. Where the icons are on the left side of the installed programs I clicked Set Program Access & Defaults.  Then under "Choose a Configuration" I clicked the Microsoft Windows radio button. I then left all settings as they were including the "Use my current e-mail program" in the E-mail selection box, then i clicked OK and Voila! the magic happened!
0
 
RanjeetRainCommented:
I'd suggest a PAQ with refund.
0
 
Squirc77Author Commented:
I answered my own question ... please close this question and refund.
http://www.experts-exchange.com/Applications/MS_Office/Outlook/Q_20806545.html#10579948



Thank you.
0
 
ee_ai_constructCommented:
PAQed, with points refunded (250)

ee_ai_construct
Community Support Moderator
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
nsdincCommented:
This worked for me, thanks!!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.