Solved

Flash

Posted on 2003-11-24
20
393 Views
Last Modified: 2010-04-07
Hi everyone..I am making one movie in macromdeia flash 5.0. when i finish a movie, i would like to play it as first layer will will b played and it stops on its place and then second layer starts and then it stops on its place. i am facing a problem that when first layer played it disappears and then second layer starts. i would like to stop them on its place. i hope  you understand what i am trying to say.i need to stop 1st layer ,it must not disappear when 2nd layer starts. this is my question. i hope you will give me answer as soon as possible.Its very Urgent, Thanks a lot
Adnan
0
Comment
Question by:Adnan J Iqbal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
20 Comments
 
LVL 5

Expert Comment

by:zenlion420
ID: 9816337
If I'm reading you right:

At the end of your first layer of animation (last keyframe), put a "(stop)" command and a " _root.gotoandplay(number of the keyframe your second layer begins its anim on, in )in the actionscript pane.  Then, in that same layer, go to the frame number that your second layer animation ends on, and right click/choose "insert frame".

Then at the end of your second layer's anim, either put a "(stop)" command, or if you want to loop it, _root.gotoandplay(1)

does this help?  if not, you'll need to clarify your Q.

j
0
 
LVL 1

Expert Comment

by:yans
ID: 9827723
I know Macomedia FLash , if you wonna know it too stop asking questions go to www.flashkit.com or www.actionscript.org
there you will find anything you ever wanted to know about FLASH
0
 
LVL 3

Expert Comment

by:alexgreen
ID: 9832115
if you're looking at trying to keep the first layer visible whilst playing the second layer then on top of Zenlion's comments, you need to make sure the second layer's background is TRANSPARENT or you won't see a thing!
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 1

Expert Comment

by:adanv1
ID: 9832936
It could actually be that your first layer ends before the second layer starts, so when the movie is playing, the first layer animation will play, and then disappear, and the second layer animation will play, and disappear. If I am correct from your question, then you would simply have to make sure the two animations are on different layers for one, you can press the '+' button to create a new layer, and then drag the end of your animation on the first layer to the end of the animation of your second layer. It's really quite easy to do. If you aren't doing a Motion Tween (the purple layer color) then the layer should be colored grey. Select the end of the animation by selecting the '[]' at the end of the first layer (it's on the last frame) and moving it to the end of the second animation. If you are doing a Motion Tween (the purple layer color), then move the 'o' at the end of the first layer animation to the end of the second layer animation.
I hope this helps, if not, post additional information about your problem.
G'day and happy thanksgiving
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9833454
heh, good point, alex :)
0
 

Author Comment

by:Adnan J Iqbal
ID: 9848557
Dear Zenion
thanks for your reply, but i am still facing the problem, the solution u gave me, i tried twice. i put STOP command in the end of first layer and then i put GOTO command in the start of second layer, but when i run a movie, the first layer runs and stops but the second layer doesnot run until i press the ENTER key.i gave frame number in gotoplay command but the first layer runs and stops and to play second layer i have to press ENTER, wheni press enter the first layer disappear. i hope you are getting my point. and i hope u will give me better solution. Thanks
Adnan
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9849239
Hello adnanjaved,

can you please post your .fla online so i can figure out what is going on?  If not, e-mail it to me (in my profile), and I will post the unadulterated version online for anyone interested before I correct the error.

aloha,

j
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9849248
Oh wait.  You need to put the gotoandplay command in the last keyframe of the first layer (not last frame).  maybe that will help you.  you would still want the gotoandplay at the end of the second layer, if you want the anim. to loop.  get back to me.

j
0
 

Author Comment

by:Adnan J Iqbal
ID: 9855874
hello zenlion
if u have any solution to this probelm then plz let me know, and if not then plz give me your email address i will send you the movie clip
thanks
adnan
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9856020
For anyone interested, I posted the file here before i even looked at it:

www.nokaoidesign.com/adnan.zip
0
 
LVL 5

Accepted Solution

by:
zenlion420 earned 20 total points
ID: 9856056
adnan:

www.nokaoidesign.com/adnan1.zip

That should be what you're after.  let me know if you have any more Q's.

look at the actions in the frames.  I added a gotoandplay(16) to frame 15 of layer one, and a (stop) command to the last frame of layer 2.  Also, i extended the frames of the first layer to the end keyframe of the second.

aloha,

j
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9856061
Hey, I just noticed the gotoandplay(15) you have in layer 2.  since it is on frame i5, you can delete that :)

j
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9856068
i5=15
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9864313
I thought you were in a rush for this solution.  It's been about 24 hours since I solved it for you and no reply?

aloha,

j
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9864512
Did I not answer you correctly?  Why the B?  What more info did you require?  As far as I can tell, I posted the exact solution.

j
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9872265
guess you're not going to reply.

j
0
 

Author Comment

by:Adnan J Iqbal
ID: 9894939
hi zenlion
thanks v much for helping me , and i hope u will help me more in future
thanks once again
Adnan
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9895574
But why the B grade?  This doesn't make sense to me.

j
0
 

Author Comment

by:Adnan J Iqbal
ID: 9902174
yes your answer is correct , thanks for help...
0
 
LVL 5

Expert Comment

by:zenlion420
ID: 9902316
Whatever :)
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When deciding to adopt any help desk solutions many factors should be explored before taking decisions. This will change from business to another but in general there are some kind of rule of thumb. Here are some quick tips: Do we need only ticket…
This guide will walk you through the essential considerations and tech stack for building scalable websites. Know how to grow your business the smart way!
The purpose of this video is to demonstrate how to exclude a particular blog category from the main blog page. This is can be used when a category already has its own tab, or you simply want certain types of posts not to show up on the main blog. …
The purpose of this video is to demonstrate how to set up an RSS Feed on a WordPress Website. This will be demonstrated using a Windows 8 PC. Feedburner will be used for this demonstration. Go to your WordPress login page. This will look like the…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question