Solved

I need a sample of configurations for a Cisco 2611!!!

Posted on 2003-11-24
11
882 Views
Last Modified: 2007-12-19
I want to make this very brief,  I just want to know does cisco have an area for just simple baseline configs.  I have 2611 fresh out the box and want to set it up.  Any Idea's

Thank you
Dease
0
Comment
Question by:deasem
  • 5
  • 4
  • 2
11 Comments
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
I don't know of a dedicated area that has simple configs. Many of their quick start guides have examples of configurations.

You may try:

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/2600_qsg.htm

or you could go to

http://www.cisco.com/univercd

pull down the "Cisco IOS Software" box and select your version of the IOS, pick "Cisco IOS Release xx.y Configuration Guides and Command References" and then either pick "Master Indexes" or find a technology and go from there.

Don
0
 
LVL 7

Expert Comment

by:NicBrey
Comment Utility
What WICs do you have in your router?
What WAN technology are you using? (leased lines/frame relay/DSL)
Is it connecting to the internet or to another site on an internal network?

The config you want to use will depend on the WICs installed in your router and what type of WAN connections the router is going to connect to. If you give us a little more information we can help you build a basic config.

Another option is to use the Cisco Configmaker that you get with the new router. Install it on a PC, connect the PC to router with the console cable at from COM1. It guides you through creating a basic config. Follow the wizzards and then "deliver the configuration" to the device.

0
 

Author Comment

by:deasem
Comment Utility
NicBrey
I tired the Config Maker, I downloaded to my laptop from CCO and it tells me that it does not support the Router I have.  I have a 2611 with 2FE and 1T1.  The router is going to be one of the end points of P2P.  The other end of the P2P is not up yet.  I'm really under the gun to get this router up.  Any help you give would be great
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
How about this? It's a pretty basic config from a 1760. You just need to change the interface numbers to match what you have. With the exception of the T1 interface, most of this could be done using the setup dialog ("setup" from priviliged mode).

Don

hostname New-Router
!
enable password cisco
!
controller T1 0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
interface Loopback0
 ip address 172.23.31.97 255.255.255.224
!
interface FastEthernet0/0
 ip address 172.23.61.1 255.255.255.252
 speed auto
!
interface Serial0/0:0
 ip address 172.23.50.1 255.255.255.252
!
interface Serial1/0                  
 shutdown
!
router rip
 network 172.23.0.0
!
line con 0
 password router
 login
line aux 0
line vty 0 4
 password cisco
 login
0
 
LVL 7

Accepted Solution

by:
NicBrey earned 500 total points
Comment Utility
Connect the router to the PC with the console cable and then use HyperTerminal to configure it.
Configure the COM port in HyperTerminal as:  
Bits per sec.   9600,  
Data Bits        8
Parity            none,  
Stop bits       1,  
Flow Control  none

Power the router up and you'll see the bootstrap program run and the router booting.
Answer the following questions as follows:  Might be slight differences due to different IOS versions and router modules, but the basics is the same.

Would you like to enter the initial configuration dialog? [yes/no]: y
Would you like to enter basic management setup? [yes/no]: n
First, would you like to see the current interface summary? [yes]: n
Enter host name [Router]: YourHostname
Enter enable secret: YourEnableSecret
Enter enable password: YourEnablePassword
Configure SNMP Network Management? [yes]: n
  Configure IP? [yes]: y
    Configure RIP routing? [yes]: n
  Configure bridging? [no]: n
Configure Async lines? [yes]: n
Do you want to configure FastEthernet0  interface? [yes]: y
  Use the 100 Base-TX (RJ-45) connector? [yes]: y
  Operate in full-duplex mode? [no]: y                              <---full duplex only if connected to a switch - if going to connect to hub, answer no
  Configure IP on this interface? [yes]: y
    IP address for this interface: 192.168.0.1
    Subnet mask for this interface [255.255.255.0] : 255.255.255.0
    Class C network is 192.168.0.0, 24 subnet bits; mask is /24

Do you want to configure Serial0  interface? [yes]: n

Would you like to go through AutoSecure configuration? [yes]: n

Now your first Fastethernet interface (0/0) is configured with 192.168.0.1    255.255.255.0


On your side, the router should have the following on the serial interface
Select 2 to save the config.

Under your serial interface you should have:
interface Serial 0/0
 description connected to Cisco2611
 service-module t1 clock source line
 service-module t1 framing esf
 service-module t1 linecode b8zs
 ip address 192.168.100.1 255.255.255.252
 encapsulation ppp
 no shutdown

ip route  192.168.200.0  255.255.255.0   192.168.100.2       <---assuming that 192.168.200.0 is the other side LAN netowrk address
                                                                                       point the route to other side LAN to the IP address of the other side serial interface


On the other side router should have:
interface Serial 0/0
 description connected to Cisco2611
 service-module t1 clock source line
 service-module t1 framing esf
 service-module t1 linecode b8zs
 ip address 192.168.100.2 255.255.255.252
 encapsulation ppp
 no shutdown

ip route 192.168.0.0  255.255.255.0   160.122.100.1


Remeber to do no shut command on the fastethernet interfaces and the serial interfaces
Then safe the configuration:
copy run start

Hope this helps...




 

0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:deasem
Comment Utility
SO  NicBrey, for the P2P I don't need to have any public space on T1 to Route 192.168.100.X traffic to the 192.168.200.X network on the other side.  I will use this config and see what it gets me.

Thanks again
Dease
0
 
LVL 7

Expert Comment

by:NicBrey
Comment Utility
No, because the traffic is sent from your router via a leased line to the other side router. It never have to be routed by outside internet routers.
You only need to have a public IP address if you want to connect it to the internet. In that case, your ISP will provide you with an address/subnet or they will tell you to configure your outside interface to get an IP address from a dhcp server on their network.
0
 

Author Comment

by:deasem
Comment Utility
NicBrey
Opps I'm in trouble then because I told my company to get Public Space on this T1.  But the remote site needs Internet access anyway(they have another T1 for that) so it all works out.  I would only need to use Static Routes instead of any other protocol?

I have already have a 192.168.1.0 work on this side for the servers and work stations so it would make sense to make up another network for the P2P.  

My side 192.168.100.X 255.255.255.252
OTher side 192.168.200.X 255.255.255.252
all on Serial Interfaces.  Thanks because I have been out of Networking for 2 years.  Its coming back.  SLOWY

Dease
0
 
LVL 7

Expert Comment

by:NicBrey
Comment Utility
>My side 192.168.100.X 255.255.255.252
>OTher side 192.168.200.X 255.255.255.252

No, the serial interfaces have to be in the same subnet - see the config I posted above (192.168.100.1 and 192.168.100.2 mask 255.255.255.252   )

Correct, if you already have a working network on the one side of 192.168.1.0  255.255.255.0, then it makes sense to just configure the router fastethernet address to 192.168.1.1  255.255.255.0  and then set the default gateway on all PC's and servers to 192.168.1.1

If you are only connecting 2 sites, static routes are fine. Do not bother with routing protocols.

0
 

Author Comment

by:deasem
Comment Utility
NicBrey
Is there any books out there than can show me in detail how to set these networks up.  I will use config maker but I just want all information I can get on this.

Thanks
again
Dease
0
 
LVL 7

Expert Comment

by:NicBrey
Comment Utility
The Cisco site is a great place to start - you'll get any info you need.

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/26xx_qsg/2600_qsg.htm
http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/index.htm
http://www.cisco.com/en/US/products/hw/modules/ps3129/products_tech_note09186a00800b1501.shtml
http://www.cisco.com/en/US/products/hw/modules/ps3129/products_tech_note09186a0080093d70.shtml


LAN A                           Router A                                                          Router B                                    LAN B
192.168.1.0            FE 0/0= 192.168.1.1/24   -------------------------   FE0/0 = 192.168.200.1/24                192.168.200.0
255.255.255.0        S 0/0  = 192.168.100.1/30                                  S0/0 =  192.168.100.2/30                 255.255.255.0
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

In a WLAN, anything you broadcast over the air can be intercepted.  By default a wireless network is wide open to all until security is configured. Even when security is configured information can still be intercepted! It is very important that you …
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now