Problem in agents

Hello,

I had created a agent in which I used a script library and called few sub written in library. it was working fine meeting all requirements. Later I created another Library. I copied this library from library of another database. I am using this new library in my old library.
  This is working . But if i run the program,the  sub called from the agent are throwing errors.

   Please suggest the answer
 
RajendracnAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CRAKCommented:
Depends on the error...
Any subs, functions or vars with the same name declared globally (twice)? (note: you can declare them a 2nd time as local va inside a sub)
Does the copied library use another library that is not available? Or perhaps a circular use (A using B, B using A thus A and B indirectly calling themselves)?
Is it a type mismatch (declared as number in one place, fed with a string in the sub)?
I really need more info on the error(s)!

If you suspect its not a programmatic error, try recompiling the whole bunch...
Assume you have an agent "A", using a library "B" and "B" uses a 2nd library "C".
Open "C", save it after making a modification (e.g. type a space and remove it again), then do the same on "B" an finally on "A".

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CRAKCommented:
I'd appreciate some feedback.....
RajendracnAuthor Commented:
the copied library had a function call that did not have right prameters, however the bugs were cleared  

 Regards
  Rajendracn
CRAKCommented:
Cool! So you are about to close the question?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.