Phantom code left after delete

Hi experts,
Again just a trivial thing really. If I enter code into an event and then decide that I got it all wrong and delete the code, the little icon in the objects list in the design pane remains shaded. Then if debugger is running and I pass over the event in Notes (eg a Postopen) the debugger stops on the empty step and I have to click Continue or Step into. Just a click, I know, but it's irritating. Any ideas how to reset the object to empty?
StuartOrdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ksi2001Commented:
remove the whole event code including   'sub' / 'end sub'

if the icon is still there close/save the form in the designer. Icon should disappear
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
qwaleteeCommented:
The icon often remain "lit" until you exit the form/view/etc that contains the code, and re-open it.  ALso, if there is even a space left in the event, it will not be treated as empty.  And the containg SUB delimiters DO count as code.
0
StuartOrdAuthor Commented:
Oh dear, that was TOO easy! You're right of course; I'd thought I'd hit problems if I deleted the sub and end sub.
Interestingly, on the form where I've just tried that out, there were 3 icons "lit". One is no longer (as desired), one other is lit (as expected), and the third was not lit despite there still being code in it!!! However saving the form and coming back in again restored it to 2 lit icons so all's well. Thanks.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

StuartOrdAuthor Commented:
I'm a stickler for detail, so I hope I got the points right - the screen now says accepted by qwaletee and assisted by ksi2001 whereas I felt the reverse was true and intended to point accordingly but it no longer says what I gave ...
0
qwaleteeCommented:
Yes, ksi got there first.  Use Community Suport to ask for a redistribution.
0
StuartOrdAuthor Commented:
OK, have done. I realise my mistake now - I clicked both names thinking I needed to and so the last one clicked (ksi) was the one that was regarded as Accepted. I got it right on the next split question!
0
StuartOrdAuthor Commented:
Thanks
0
ksi2001Commented:
:-) thanks guys
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.