Linux Networking, eth0 device not found

I installed Mandrake Linux 7.1 on a dual 300MHz computer. I also have another computer having Windows 2000. I have connected both of them using a belkin router. After installing, I set the IP address for the Linux machine using the
"<b>ifconfig eth0 netmask broadcast</b>" .

After this both the computers were connected(I ran a FTP server on the windows 2000 machine and I was able to access the FTP server from the linux machine).

After this I rebooted the linux machine and I noticed that the Ip address was gone. I tried to set the IP address to using the same ifconfig command, but it keeps saying eth0 device not found. I used LinuxConf program and it shows that the ethernet card is installed properly.

What may the problem be?

Also, in the /var/log/messages file I saw this boot up message..

Nov 25 00:40:05 shibuhost network: Setting network parameters succeeded
Nov 25 00:40:05 shibuhost network: Bringing up interface lo succeeded
Nov 25 00:40:05 shibuhost network: Enabling IPv4 packet forwarding succeeded
Nov 25 00:40:05 shibuhost insmod: Note: /etc/conf.modules is more recent than /lib/modules/2.2.15-4mdksmp/modules.dep <27>Nov 25 00:40:05 insmod: /lib/modules/2.2.15-4mdksmp/net/tlan.o: invalid parameter parm_irq
Nov 25 00:40:05 shibuhost ifup: Delaying eth0 initialization.
Nov 25 00:40:05 shibuhost network: Bringing up interface eth0 failed

I am able to ping to . Does that mean the ethernet card driver is installed and loaded fine?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

try to look for the file /etc/sysconfig/network-scripts/ifcfg-eth0, add your ip in this file and restart linux and try again.


[root@test network-scripts]# more ifcfg-eth0

Also the file /etc/sysconfig/network, add your gateway info there eg.

[root@test sysconfig]# more network

and /etc/hosts
[root@test sysconfig]# more /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.               localhost.localdomain             localhost      hostname

after change those file restart to see it will help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sprint907Author Commented:
Thank you.
I will try that.
sprint907Author Commented:
I could not try that.  I got Red Hat 9.0 CDs and installed on that machine.
Now there is no problem at all :)

Thank you for your response.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.