Linux Networking, eth0 device not found

I installed Mandrake Linux 7.1 on a dual 300MHz computer. I also have another computer having Windows 2000. I have connected both of them using a belkin router. After installing, I set the IP address for the Linux machine using the
"<b>ifconfig eth0 192.168.2.100 netmask 255.255.255.0 broadcast 192.168.2.155</b>" .

After this both the computers were connected(I ran a FTP server on the windows 2000 machine and I was able to access the FTP server from the linux machine).

After this I rebooted the linux machine and I noticed that the Ip address was gone. I tried to set the IP address to 192.168.2.100 using the same ifconfig command, but it keeps saying eth0 device not found. I used LinuxConf program and it shows that the ethernet card is installed properly.

What may the problem be?

Also, in the /var/log/messages file I saw this boot up message..

Nov 25 00:40:05 shibuhost network: Setting network parameters succeeded
Nov 25 00:40:05 shibuhost network: Bringing up interface lo succeeded
Nov 25 00:40:05 shibuhost network: Enabling IPv4 packet forwarding succeeded
Nov 25 00:40:05 shibuhost insmod: Note: /etc/conf.modules is more recent than /lib/modules/2.2.15-4mdksmp/modules.dep <27>Nov 25 00:40:05 insmod: /lib/modules/2.2.15-4mdksmp/net/tlan.o: invalid parameter parm_irq
Nov 25 00:40:05 shibuhost ifup: Delaying eth0 initialization.
Nov 25 00:40:05 shibuhost network: Bringing up interface eth0 failed


I am able to ping to 127.0.0.1 . Does that mean the ethernet card driver is installed and loaded fine?
sprint907Asked:
Who is Participating?
 
paullamhkgCommented:
try to look for the file /etc/sysconfig/network-scripts/ifcfg-eth0, add your ip in this file and restart linux and try again.

eg.

[root@test network-scripts]# more ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.0.255
IPADDR=192.168.0.2
NETMASK=255.255.255.0
NETWORK=192.168.0.0
ONBOOT=yes

Also the file /etc/sysconfig/network, add your gateway info there eg.

[root@test sysconfig]# more network
NETWORKING=yes
HOSTNAME=hostname.yourdomain.com
GATEWAY=192.168.0.254

and /etc/hosts
eg.
[root@test sysconfig]# more /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain             localhost
192.168.0.2            hostname.yourdomain.com    hostname

after change those file restart to see it will help.
0
 
sprint907Author Commented:
Thank you.
I will try that.
0
 
sprint907Author Commented:
I could not try that.  I got Red Hat 9.0 CDs and installed on that machine.
Now there is no problem at all :)

Thank you for your response.
Sprint907
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.