?
Solved

WLAN

Posted on 2003-11-25
6
Medium Priority
?
1,657 Views
Last Modified: 2013-11-12
Hi,
I have installed RedHat 8 (I believe kernel version: 2.4.18-14) onto my laptop. For this laptop I bought a pcmcia network pc card (LinkSys WPC11 v3) and have a LinkSys Wireless router.  I am having trouble getting this network to work

The router works correctly for all my normal ethernet connections. Wireless is enabled with a specific SSID, channel 6 and WEP 128 bits enabled.

I read several articles on the internet on how to set the network and got it to work partly (at least that is what I seem to think). I did not use the linux-wlan-ng since RedHat 8 should be able to do it with minimum efforts (thatr's what I read, but I am new to Linux).  

The steps I took:
- crerated a hermes.conf file including the manfid
- service pcmcia restart (I hear one beep when shutting down and two high beeps when starting)
- created a wireless network connection using the Network tool. In this configuration I saw the eth1 controller which I just added. I configured the wireless connection to Ad-Hoc mode, channel 6, the WEP key written out (please note that I did not use any seperators but copied the exact key from my router). I configured the connection to a static IP.

The results:
I restarted my machine and it gave me a message that Channel is out of range (0). Also the TX could not be bound to the BAP or something (don't have the exact error message here). Anyway, these errors could be due to the startup sequence (pcmcia is S24pcmcia), but that is what I read on the net so I cannot be totally sure.

After the machine has been started and I have logged in as 'root' I tried activating the new network connection. I activated like it should without problems.
Inside the terminal I then tried to ping my router, which could not be found.
When issueing cardctl ident I see that my network card has been identified as the one it should be.
After issueing /sbin/ifconfig I see that the eth1 network is running as well as eth0. The eth1 sends data, but never receives any.
After issueing /sbin/iwconfig I see that the connection with all settings I entered above were correctly initialized. The link quality is 0 however.

When looking into the modules currently loaded I do see the orinoco_cs and hermes running.

I also never see any lights flashing on my router.

I'm out of options, except for a possible linux-wlan install. But that install requires me to rebuilt Linux from source. I already gave it a small try, but I'm stuck after running make menuconfig and make dep.

Can anybody help me? If there is insufficient points for the help I am requesting I am wiling to put up more points.

0
Comment
Question by:CJ_S
6 Comments
 
LVL 5

Accepted Solution

by:
brabard earned 700 total points
ID: 9816889
Possibly the problem is not on Linux , but on the router .
There are at least 3 fast things I've been do in your place :
1. I see your NIC is version3 , check the firmware version of LinkSys router and discover the Net for some information about non-abilitty .
2. Try connectin without encription ( I don't know if router will allow it .
3. Check all firewalls on router , MAC control , etc.
0
 
LVL 22

Author Comment

by:CJ_S
ID: 9816902
1) I will check the firmware later. But this will probably not make a difference (I think) since these products should work together and did work when I had Windows on my laptop.
2) Already checked without encryption. No difference :-(
3) No firewall installed on the router. What do I need to do when checking the MAC address?
0
 
LVL 9

Assisted Solution

by:cooledit
cooledit earned 600 total points
ID: 9830395
easy way of trouble shooting

let the Linux run in DHCP mode and hand out addresses out for fast finding.

there are several sittings of the Router modes u just have to try them out one by one. I have installed Mandrake 9.2 myself
and it instant install the correct driver for me. Or you could try to download the newest version of Redhat 9. There are all newer drivers in that one.

Router modes = channeling
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 22

Author Comment

by:CJ_S
ID: 9830427
I will check this out tonight. I have been very busy the past few days without time to get to this problem again. Thanks so far!
0
 
LVL 3

Assisted Solution

by:rgeers
rgeers earned 700 total points
ID: 9889296
If you want to create the kernel modules for wlan-ng you do not need to
create your own kernel. You will need the include/header files that define
your running kernel. Usually you can find something like kernel-source,
kernel-image and kernel-devel packages. Here you need the kernel devel
packages to create wlan-ng modules. If you unpack the source you need
to run the 3 step configure, make, install steps in order to get these on your
system.

If you dont find the rpm's for the install try also rpmfind.net, but use the rpm
that belong to your distribution (redhat v8.0)

Also I would recommend you to try the simplest configuration first, without
encryption. I found in several cases that WEP does not allways work,
including on PocketPC plattform.

Gook luck!
0
 
LVL 22

Author Comment

by:CJ_S
ID: 10218350
Dont' care anymore, but thanks for the provided help!
0

Featured Post

What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This subject  of securing wireless devices conjures up visions of your PC or mobile phone connecting to the Internet through some hotspot at Starbucks. But it is so much more than that. Let’s look at the facts: devices#sthash.eoFY7dic.
The Summer 2017 Scholarship Winners have been announced!
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question