Solved

Windows 2000 Server Network Shares limited with Win 2000 Pro Clients

Posted on 2003-11-25
12
626 Views
Last Modified: 2013-12-23
I just ran into a problem in one of my clients network, let me give you some background:

Network is using a Win 2000 Server only as a file server (running active directory), all the clients have always been Win98 Machines. My client runs an administrative application programed in FoxPro with is availalable in a network share in the server so the clients can connect to it. The only thing that is needed to run the foxpro aplication in the clients is the visual foxpro runtime library.

This foxpro aplication is the one giving me problems, but only in win2k. let me explain.

I just upgraded one of the client machines to Windows 2000 Pro in order to restrict the user ability to install/remove programs, after getting the computer ready, I installed the foxpro runtime libraries, mapped the Admin App. network share to drive S:, then created the usual shotcut to the aplication's executable, I ran the aplication and it seemed to run fine. Today i got called in because they're experiencing problems with the foxpro aplication in the win2000 machine.

The program opens and seems to be functional, I mean, some of the forms and queries work, but when we click on ONE of the options (one that shows a calendar) I get an error saying "Ole 0x8002802b: Element not found".

I suspected it was maybe incompatibility with win2000, since all the computers running win98 run the app just fine. So I went right to the Win2k Server, intalled the Foxpro Runtimes and ran the app. from it, everything ran fine.

Now I'm puzzled, when the app is ran from win98 computers everything runs fine, when ran from win2000 I get the error. I went to the server and checked the "share" and it's "security", I set BOTH sharing and security to "everyone" with "FULL CONTROL", the problem persists =(

 It seems to be that the network access to the share that the Win2000 Machine is getting is not "completely" "FULL CONTROL". I'm desperate. what can I do? why does this problem appear only in Win2k machines?

Thanks in Advance

-Andres Tinoco
0
Comment
Question by:atinoco
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 37

Accepted Solution

by:
bbao earned 500 total points
ID: 9823082
it sounds the foxpro application is not windows 2000 compatible. you know, windows 98 and windows 2000 have some differences on system API, althought commonly we call them same name WIN32.
0
 

Author Comment

by:atinoco
ID: 9824102
I don't think that's the problem. Remember I ran that foxpro application locally in the Windows 2000 Server with no problems.

That's why I suspect it's related to the network access.

-Andres Tinoco

0
 
LVL 37

Expert Comment

by:bbao
ID: 9824130
i would suppose it is a MDAC releated problem, caused by incompatible or lower version issue.

you may check the MDAC versions on the problemic windows 2000 and those well-performanced windows 2000 server and windows 98 clients, here are three methods on how to determine which version of MDAC is installed:

1. Run regedit and search for the following key:

HKEY_LOCAL_MACHINE
      \Software  
          \Microsoft  
               \DataAccess  
                    \Version

2. Another option is to find msado15.dll (in %SYSTEM32%\DLLCache\) and check its properties. This should show the same results as the ones from the registry.

3. Also there is a tool available from Microsoft called Component Checker. It can be downloaded from
http://download.microsoft.com/download/dasdk/CC/2.7/WIN98MeXP/EN-US/cc.exe

of course, to upgrade the MDAC version will fix your problem

hope it helps,
bbao


0
Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:atinoco
ID: 9824175
Will try this in the afternoon when I go to work on my client. I just noticed I didn't apply any Service packs to that Windows Machine.

Any other ideas?

-Andres
0
 
LVL 37

Expert Comment

by:bbao
ID: 9824315
since windows 2000 SPs also fixed MDAC bugs, so i think it is possible that the latest SP may fix your problem. good luck, bbao
0
 
LVL 4

Expert Comment

by:Roly_Dee
ID: 9837379
To test your theory that it is a network access problem, you need to try two more tests:
- map the S: drive when you are on the server. Then run the application using the same shortcut as the clients use.
- copy the whole folder to the C: drive of the workstation, and run it locally (as you did on the server)

My guess is that the first test will work, but the second will not: this eliminates the network as the problem. Your SPs may fix the problem, but the best test would be to do a clean install of 2000 on a PC and see.

I have never liked upgrading from W9x, I always spend longer fixing these obscure little problems :-( Much quicker to copy off the data, format and install.
0
 

Author Comment

by:atinoco
ID: 9837484
Will try that Roly, Will  apply all the Win2000 patches later on today had a little problem with the inet access that I will solve today.

Also what I meant with Upgrade it that I changed w98 for Win. 2000. A clean install was done with no problems.

Will keeep you guys posted.

-Andres Tinoco
0
 
LVL 37

Expert Comment

by:bbao
ID: 9862519
hi, how it goes?
0
 
LVL 37

Expert Comment

by:bbao
ID: 10056645
atinoco, any feedback please?
0
 

Author Comment

by:atinoco
ID: 11365773
I tried updating the MDAC but never got the issue solved. Since I needed the computer operational i went back to win98
0
 

Expert Comment

by:sssh1980
ID: 11512738
hi everybody.... i face one problem with Windows 2000 Professional. let me explain...
i use Win2k pro to control the desktop icon to my 10 PC clients. my client is using windows XP home edition. when i setup the exe file to my client pc , that will redirect to the Window2k pro PC(my server PC). then i put the exe file at startup and i restart the PC. After restart, my exe file cannot connect the server's file(dekstop icon). but if i log off and log in again then can connect oledi...

so my problem is why after i restart the client PC, my client PC cannot connect to the server, but log off and log in then no problem.... ?? thx for help....

0
 

Expert Comment

by:cmcclendon
ID: 14181600
Sorry. But your accepted answer is wrong. The correct answer is your ActiveX calander control (mscal.ocx) is missing or not in the correct location. Windows 98 and 2000 store the file in different places. When FoxPro tries to display the form containing the ActiveX calander control is can not find it and is display the OLE error. Follow this link to correct the error: http://www.fontstuff.com/mailbag/qvba01.htm 
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A brief overview to explain gateways, default gateways and static routes OR NO - you CANNOT have two default gateways on the same server, PC or other Windows-based network device. In simple terms a gateway is formed when a computer such as a serv…
FIPS stands for the Federal Information Processing Standardisation and FIPS 140-2 is a collection of standards that are generically associated with hardware and software cryptography. In most cases, people can refer to this as the method of encrypti…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question