Solved

PC-Anywhere between HOME and WORK and a CISCO 1720 in between

Posted on 2003-11-25
4
728 Views
Last Modified: 2010-08-05
I have a Cisco 1720 Router connected to a fractional T1 at my work.  I would like to PCanywhere to at least one computer over the internet, if not several different machines.  We have a static internet IP address.  We are using NAT.  My assumption is I have to do something fancy with an access-list.

I'm a Cisco newbie, but I think what I want to do is forward ports 5631 TCP and 5632 UDP to an internal IP address on our LAN.  The IP of the internal system is 192.168.1.9.  I will have PC-Anyhwere listening on that machine.

I can do this with my Linksys router from Work to Home, Simple.  Ok, here is my running-config on the router.    

Here goes:

Current configuration : 1065 bytes                                  
!
version 12.1            
service config              
service timestamps debug uptime                              
service timestamps log uptime                            
no service password-encryption                              
!
hostname xxxxxxxxxxxxxx                  
!
enable secret xxxxxxxxxxxxxxxxxx                                              
enable password xxxxxx                      
!
!
!
!
!
memory-size iomem 25                    
ip subnet-zero              
ip name-server 199.224.86.20                            
ip name-server 199.224.64.20                            
!
!
!
!
interface Serial0                
 ip address 199.224.93.78 255.255.255.0                                      
 ip nat outside              
 service-module t1 timeslots 1-2                                
!
interface FastEthernet0                      
 ip address 192.168.1.1 255.255.255.0                                    
 ip nat inside              
 speed auto          
 half-duplex            
 no cdp enable              
!
ip default-gateway 199.224.93.77
ip nat pool ovrd 199.224.93.78 199.224.93.78 netmask 255.255.255.252
ip nat pool natpool 199.224.93.78 199.224.93.78 prefix-length 24
ip nat inside source list 1 pool natpool overload
ip classless
ip route 0.0.0.0 0.0.0.0 199.224.93.77
no ip http server
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password spw1dar
 login
!
no scheduler allocate
end

Thanks in advance, if anybody could recommend a good book also?

Deeky
0
Comment
Question by:deeky
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 9822451

You need to create a static port map:
Example your PC is 192.168.1.9 that you want to access via PCAnywhere
ip nat inside source static tcp 192.168.1.9 5631 199.224.93.78 5631
ip nat inside source static udp 192.168.1.9 5632 199.224.93.78 5632

the best "book" is Cisco documentation either online or the CD that came with the router.

0
 

Author Comment

by:deeky
ID: 9822662
Thank you so much.  Any suggestions about how to access more than one computer on our LAN from a remote location (HOME)???  Please don't say VPN then I'll really feel uncomfortable.  Baby-steps for me....

Deeky
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9825521
You would have to set your PCAnywhere hosts to use different TCP/UDP ports to listen on, then map statics to those ports. Example:

ip nat inside source static tcp 192.168.1.9 5631 199.224.93.78 5631
ip nat inside source static udp 192.168.1.9 5632 199.224.93.78 5632

ip nat inside source static tcp 192.168.1.10 5632 199.224.93.78 5632
ip nat inside source static udp 192.168.1.10 5633 199.224.93.78 5633

ip nat inside source static tcp 192.168.1.11 5633 199.224.93.78 5633
ip nat inside source static udp 192.168.1.11 5634 199.224.93.78 5634

System#1 uses default TCP 5631/ UDP 5632
System#2 uses 5632/5633
System#3 uses 5633/5644

I'm not that up on PCAnywhere internals, but if you read the help, I'm sure it will tell you how to setup the host to use different ports.
0
 

Expert Comment

by:earlchambers98
ID: 10117342
You need to setup a host to base from.  Internal ports are not changeable on PC Anywhere.  The first lines in the first solution are right.  Once inside you can pc anywhere to the list inside of the first session.

Earl
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month6 days, 19 hours left to enroll

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question