Solved

1721 - Frame Relay installation

Posted on 2003-11-26
12
5,797 Views
Last Modified: 2013-12-12
I purchased a new Cisco 1721 router in order to replace the old NILE router for FR connection. I found some examples of Cisco 2620 router as below:

EDISON-FR(config)#interface serial0
EDISON-FR(config-if)#ip address 204.117.5.9 255.255.255.192
EDISON-FR(config-if)#desc Serial0 to FR external CSU/DSU
EDISON-FR(config-if)#no shutdown
EDISON-FR(config-if)#encapsulation frame ietf

EDISON-FR(config)#interface serial0.1 point-to-point
EDISON-FR(config-subif)#desc Connected to site TN
EDISON-FR(config-subif)#ip address 204.117.5.5 255.255.255.192
EDISON-FR(config-subif)#frame-relay interface-dlci 30

EDISON-FR(config)#interface serial0.2 point-to-point
EDISON-FR(config-subif)#desc Connected to site VA
EDISON-FR(config-subif)#ip address 204.117.6.6 255.255.255.192
EDISON-FR(config-subif)#frame-relay interface-dlci 32

EDISON-FR(config)#interface serial0.3 point-to-point
EDISON-FR(config-subif)#desc Connected to site OH
EDISON-FR(config-subif)#ip address 204.117.6.0 255.255.255.192
EDISON-FR(config-subif)#frame-relay interface-dlci 45

Later another article told me a different example as below:

EDISON-FR(config)#int s0
EDISON-FR(config-if)#encap hdlc
EDISON-FR(config-if)#encap frame-relay ietf
EDISON-FR(config-if)#frame-relay map ip 204.117.65.65 30 broadcast
EDISON-FR(config-if)#frame-relay map ip 204.117.65.67 32 broadcast
EDISON-FR(config-if)#frame-relay map ip 204.117.65.70 45 broadcast
EDISON-FR(config-if)#frame-relay interface-dlci 33

The major difference is the first example is to assign IP address on serial port and sub-ports and the second example is to map IP address on serial port. Please advise, which one is correct or they are all right but for different router models?

Thanks in advance.








0
Comment
Question by:slu2003
  • 6
  • 5
12 Comments
 

Author Comment

by:slu2003
ID: 9825262
Here are some information for reference:

EDISON-FR#show conf
Using 1902 out of 29688 bytes
!
! Last configuration change at 12:29:56 UTC Tue Nov 25 2003
! NVRAM config last updated at 12:30:03 UTC Tue Nov 25 2003
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EDISON-FR
!
boot system flash
boot system tftp 198.69.18.157 255.255.255.255
logging buffered 52000 debugging
enable secret 5 $1$D1hF$DbXeip35LjNUCpvOVwLU30
enable password xxx
!
username sdm privilege 15 password 0 xxx
ip subnet-zero
!
interface FastEthernet0
 description FastEthernet0 to LAN switch
 ip address 198.69.18.6 255.255.255.0
 speed auto
 half-duplex
!
interface Serial0
 description Serial0 to FR external CSU/DSU
 ip address 204.117.65.69 255.255.255.192
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay map ip 204.117.65.65 30 broadcast
 frame-relay map ip 204.117.65.67 32 broadcast
 frame-relay map ip 204.117.65.70 45 broadcast
 frame-relay interface-dlci 33
!
ip classless
ip route 0.0.0.0 0.0.0.0 198.69.18.4
ip route 10.0.1.0 255.255.255.0 198.69.18.2
ip route 10.0.2.0 255.255.255.0 198.69.18.3
ip route 10.69.19.0 255.255.255.0 204.117.65.70
ip route 10.69.218.0 255.255.255.0 204.117.65.65
ip route 198.69.16.0 255.255.255.0 204.117.65.65
ip route 198.69.17.0 255.255.255.0 204.117.65.65
ip route 198.69.18.0 255.255.255.0 FastEthernet0
ip route 204.117.65.64 255.255.255.192 Serial0
ip route 208.11.156.0 255.255.255.0 204.117.65.65
ip route 208.11.157.0 255.255.255.0 204.117.65.65
ip route 208.11.158.0 255.255.255.0 204.117.65.68
ip route 208.11.159.0 255.255.255.0 204.117.65.65
ip http server
ip http authentication local
!
snmp-server community public RO
snmp-server enable traps tty
banner motd
Welcome to the FR router in NJ ****************
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 password cisco
 login local
 transport input telnet
!
no scheduler allocate
!
end

EDISON-FR#show fr map
Serial0 (down): ip 204.117.65.65 dlci 30(0x1E,0x4E0), static,
              broadcast,
              IETF, status defined, inactive
Serial0 (down): ip 204.117.65.67 dlci 32(0x20,0x800), static,
              broadcast,
              IETF, status defined, inactive
Serial0 (down): ip 204.117.65.70 dlci 45(0x2D,0x8D0), static,
              broadcast,
              IETF, status defined, inactive

EDISON-FR#show fr pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            4            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 30, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:10:50, last time pvc status changed 00:10:50
DLCI = 32, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:11:06, last time pvc status changed 00:11:06

DLCI = 33, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:11:16, last time pvc status changed 00:11:16

DLCI = 45, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:11:26, last time pvc status changed 00:11:26

EDISON-FR#show fr lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 0                Num Status msgs Rcvd 0
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req never            Last Full Status Rcvd never

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9826928
Most typically, frame-relay is point-to-point and therefore the most appropo config is to use a separate point-to-point sub-interface for each DLCI as depicted in your first example.

If both ends of the frame-relay PVC are Cisco routers, you don't need the IETF at all

You might also want to bring the interface "up"
router(config)#interface serial 0
router(config-if)#no shut

0
 

Author Comment

by:slu2003
ID: 9827156
Nice to get response from you, I know you are a top expert here.

I did by the first example but it did not work, then I called CISCO and was told that I should not assign IP address on serial port and sub-ports but should map IP address on serial port by the second example. When I asked him why, I could not get a good answer. I read several articles that use the first example to set up FR, thus I want to understand why I should use the second in this case.

FYI - not all routers use Cisco.

Thanks.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9827479
I have done literally thousands of frame-relay deployments and with one single exception, always use the point-to-point sub-interfaces. The single exception was due to replacing an exisiting router that was already set up that way while we moved them to the point-to-point.

First, we have to determine why it did not work.
Assuming that you have a v.35 cable, or a new CSU/DSU to get signal from the telco....

Are these point-to-point PVC's?
Are the remote sites already "live" with working connections?

Here is a typical config for multiple frame-relay sites:

"HQ or Core site"
!
interface serial 0/0
 no ip address
 no shutdown
 encapsulation frame-relay
 lmi-type ansi <-- use this ONLY if required by the telco. No entry here means 'autodetect' / default to CISCO
!
interface serial 0/0.30  <-- these sub-if numbers are abitrary. I use the DLCI # for ease
 description PVC to SITE2
 ip address 192.168.254.1 255.255.255.252
 frame-relay interface-dlci 30
!
interface serial 0/0.32
 description PCV to SITE3 - Nortel router
 ip address 192.168.254.5 255.255.255.252
 frame-relay interface-dlci 32 IETF
!
interface serial 0/0.45
 description PCV to SITE4
 ip address 192.168.254.9 255.255.255.252
 frame-relay interface-dlci 45 IETF
!
<etc>

SITE 2 - x all Cisco routers
Interface serial 0/0
 no ip address
 no shut
 encapsulation frame-relay
!
interface serial 0/0.1
 description PVC to HQ
 ip address 192.168.254.2 255.255.255.252
 frame-relay interface-dlci 33
!

SITE4
Interface serial 0/0
 no ip address
 no shut
 encapsulation frame-relay
!
interface serial 0/0.1
 description PVC to HQ
 ip address 192.168.254.10 255.255.255.252
 frame-relay interface-dlci 33
!


Subinterfaces act just like real interfaces. A dropped PVC will drop an interface which is an snmp trap event. Easier to manage. You can do things with subinterfaces that you can't do with maps. You can encrypt on a sub-interface. You can assign access-lists to a subinterface, you can do basically anything that you can do on a 'real' interface. It also makes dynamic routing using EIGRP or OSPF easier because you don't have the split-horizon issues.

I can think of no good reason to use maps vs sub-interfaces.

Some troubleshooting tools include "show interface"
Serial 0/0
Line UP / protocol DOWN = good T1 connection, not getting LMI from the switch
Line UP / protocol UP = good T1 connection, getting LMI from switch
But
Serial 0/0.1 line down/protocol down = wrong DLCI assigned to the subinterface.

'show frame-relay pvc' may show ACTIVE DLCI on serial 0/0, not on the expected Subinterface. If so, change the interface-dlci of that sub-interface to match what you're "seeing" from the switch.

Remember, BOTH sides of the PVC have to be up for the DLCI to become ACTIVE.
0
 

Author Comment

by:slu2003
ID: 9850130
First, it is right that I am replacing an existing router. There are four routers with the same configuration. I think it is the point why I still need to use the old way to have FR work.

Second, I need a customized cable to get signal from my ISP after confiming with ISP and CISCO. My cable is customized because a T1 supports both voice and data.

Third, three remote sites still use the old routers to work lively.  

Fourth, I read your typical config for multiple frame-relay sites. One question is if I should assign IP address on the serial 0/0 in addition to all sub-serial interfaces.

Thanks.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 9850386
Easy part first. No, you don't need to assign an IP address to the major serial interface, only to the point-to-point sub-interfaces

For easier migration from old config to new config, setup one sub-interface as point-to-multipoint, example:

interface serial 0/0
 encapsulation frame-relay
 no ip address
!
interface serial 0/0.22 point-to-multipoint
 ip address 204.117.65.69 255.255.255.192
 frame-relay map ip 204.117.65.65 30 broadcast IETF
 frame-relay map ip 204.117.65.67 32 broadcast
 frame-relay map ip 204.117.65.70 45 broadcast IETF
!
interface serial 0/0.33 point-to-point
 Description point-to-point to SITE 1
 ip address 192.168.222.1 255.255.255.252
 frame-relay interface-dlci 33
!

I still don't understand your requirement for a customized cable. If your T1 is bringing in both data and voice, then the DSU is providing the drop-insert functions, splitting data to a v.35 interface and voice to a DsX port. The v.35 - router cable should be standard Cisco issue.

0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:slu2003
ID: 9850406
Thanks for your quick reply.

About the customized cable, I keep thinking the same question. I am still checking with CISCO and my ISP (Sprint), they are still arguing each other. The V.35 port is the same, but they have the different PIN layout. I never experienced or heard about this situation...  
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9850415
Is Sprint providing the CSU/DSU as part of their package, or do you own it?
What make/model/brand is it?
0
 

Author Comment

by:slu2003
ID: 9850438
Yes, it is an external CSU/DSU, which is inside of Channel Bank. I cannot find any information about the CSU/DSU, the Channel Bank is NewBridge/3624/MainSterrt.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9877259
You should have RS232/X.21, or V.35 connection on the channel bank. These are all standard, and you simply need the appropriate Cisco cable for each one. Determine the connector, male or female, and order the appropriate cable.
0
 

Author Comment

by:slu2003
ID: 9882799
I have talked with CISCO and ISP. It seems that the external CSU/DSU is not compatible with CISCO 1721 router. Thanks for your help.
0
 

Expert Comment

by:sanjeevarya
ID: 10234393
Never assign an IP address to a physical interface, if u r going to make subinterfaces on the same interface....assign IPs to subinterface and map the dlci...
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now