Solved

Router Rip Problem

Posted on 2003-11-26
18
890 Views
Last Modified: 2012-06-21
Hi.. i'm sure i have a very simple router rip problem for someone to solve.


I have two routers.. Router 1 192.0.10.246
and Router 2 192.0.10.254

Now the problem i have is as following..

i type show ip route in 192.0.10.246 i get the following...

R    192.0.110.0/24 [120/3] via 192.0.10.254, 00:00:05, Ethernet0
C    192.0.10.0/24 is directly connected, Ethernet0
     172.16.0.0/32 is subnetted, 2 subnets
C       172.16.1.35 is directly connected, Dialer0
C       172.16.33.51 is directly connected, Dialer0
R    192.0.2.0/24 [120/2] via 192.0.10.254, 00:00:05, Ethernet0
R    192.0.3.0/24 [120/1] via 192.0.10.254, 00:00:05, Ethernet0
S*   0.0.0.0/0 is directly connected, Dialer0

FastTrack#

I type show ip route 192.0.10.254 i get the following....


R    192.0.110.0/24 [120/2] via 192.0.3.201, 00:00:09, Ethernet1/
C    192.0.10.0/24 is directly connected, FastEthernet0/0
R    192.0.2.0/24 [120/1] via 192.0.3.254, 00:00:00, Ethernet1/0
C    192.0.3.0/24 is directly connected, Ethernet1/0
S*   0.0.0.0/0 [1/0] via 192.0.10.246


I dont understand when both routers have the following router config.

Router 1 - 192.0.10.246

!
router rip
 version 2
 network 192.0.3.0
 network 192.0.10.0

Router 2 - 192.0.10.254
router rip
 version 2
 network 192.0.2.0
 network 192.0.3.0
 network 192.0.10.0

Thanks in advance!
0
Comment
Question by:IanH001
  • 11
  • 7
18 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 9825604
Router 1 is trying to advertise a network that is directly connected to router 2
Router 1 - 192.0.10.246

Router 1 - 192.0.10.246
!
router rip
 version 2
 network 192.0.3.0 <--------not connected to this router--
 network 192.0.10.0
===================
Router 2 - 192.0.10.254
router rip
 version 2
 network 192.0.2.0
 network 192.0.3.0  <------directly connected
 network 192.0.10.0


What other network is attached to router #1 that you want router #2 to learn?

0
 

Author Comment

by:IanH001
ID: 9825653
Ok i've made the changes you suggest.

Router 2. 192.0.10.254 has 1 ethernet port conf. 192.0.3.245 and 1 fast ethernet conf. 192.0.10.254...

Router 1 is an ADSL Cisco 827H so i didnt think about adding anymore networks in... I'm trying to get the ADSL router to advertise 193.193.102.130 and 213.148.63.222. Both are ping/traceable from router 1
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9825746
I'm assuming this question is related to this other open one..
http://www.experts-exchange.com/Hardware/Routers/Q_20802923.html
And this one:
http://www.experts-exchange.com/Hardware/Routers/Q_20794061.html


>I'm trying to get the ADSL router to advertise 193.193.102.130 and 213.148.63.222
What is the next hop to get to these networks from this router? You can add statics and then re-distribute the statics:

827H:
ip route 193.193.102.0 255.255.255.0 A.B.C.D <-- ip address of next hop
ip route 213.148.63.0 255.255.255.0 A.B.C.D <-- ip address of next hop
!
router rip
 version 2
  network 192.0.10.0
 redistribute static

Now, on Router 2, you should see route entries for these two networks, learned via RIP


0
 

Author Comment

by:IanH001
ID: 9825960
Well i tried all this earlier.. I've put it in as you said..

Now router 192.0.10.254 has the following

show ip route

R    192.0.110.0/24 [120/2] via 192.0.3.201, 00:00:01, Ethernet1/0
C    192.0.10.0/24 is directly connected, FastEthernet0/0
R    192.0.2.0/24 [120/1] via 192.0.3.254, 00:00:15, Ethernet1/0
C    192.0.3.0/24 is directly connected, Ethernet1/0
S*   0.0.0.0/0 [1/0] via 192.0.10.246

I've made sure i left it longer than 30seconds so it would refresh and get the next routing tables.
0
 

Author Comment

by:IanH001
ID: 9825994
And yes its me again still fumbling around with Routers. !
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9825995
Can you post results from router 1
"sho ip pro"

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9826042
Router #2 is not showing these routes in the route table for a very simple reason:
S*   0.0.0.0/0 [1/0] via 192.0.10.246

You have a static default route that has a lower cost (pointing to router1) than any learned route, so it will not list those specifically learned from router 1

If you want to "see" these routes in the route table, you would have to change the metric of the static on router 2:

no ip route 0.0.0.0 0.0.0.0 192.0.10.246
ip route 0.0.0.0 0.0.0.0 192.0.10.246 200 <-- note metric '200' is higher than RIP 120



0
 

Author Comment

by:IanH001
ID: 9826053
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 1 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0             2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.0.10.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.0.10.254         120      00:00:14
  Distance: (default is 120)
0
 

Author Comment

by:IanH001
ID: 9826068
I've actually changed this

S*   0.0.0.0/0 [1/0] via 192.0.10.246
 
to 192.0.3.254 200

0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:IanH001
ID: 9826083
Still i only get this...



Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inte
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
       E1 - OSPF external type 1, E2 - OSPF external type 2, E
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -
       * - candidate default, U - per-user static route, o - OD
       P - periodic downloaded static route

Gateway of last resort is 192.0.3.254 to network 0.0.0.0

R    192.0.110.0/24 [120/2] via 192.0.3.201, 00:00:21, Ethernet
C    192.0.10.0/24 is directly connected, FastEthernet0/0
R    192.0.2.0/24 [120/1] via 192.0.3.254, 00:00:28, Ethernet1/
C    192.0.3.0/24 is directly connected, Ethernet1/0
S*   0.0.0.0/0 [200/0] via 192.0.3.254
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 30 total points
ID: 9826086
>Redistributing: rip

you're not redistributing statics...
I would expect to see:
  Redistributing: static, rip


Paste the router rip and static route portion of the config of router 1 again...


0
 

Author Comment

by:IanH001
ID: 9826121
Heres the WHOLE config for Router 1.

BY the way 192.0.10.254 NOW picks up the routes from 192.0.10.246. However it wont ping 193.193.102.xxxx

FastTrack#show conf
Using 1178 out of 131072 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FastTrack
!
enable secret 5 $1$x74B$dw0tEX2UWS6fDCs1faWH61
enable password gxxxxx
!
ip subnet-zero
ip name-server 172.16.1.61
ip name-server 172.16.1.62
!
!
!
!
interface Ethernet0
 ip address 192.0.10.246 255.255.255.0
 ip nat inside
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
 hold-queue 224 in
!
interface Dialer0
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxxxxxxxxxxxxxxxxxxx
 ppp chap password xxxxxxxxxxxxxxxxxxxxxxx
!
router rip
 version 2
 redistribute static
 network 192.0.10.0
!
ip nat inside source static 192.0.10.246 interface Dialer0
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 193.193.102.0 255.255.255.0 172.16.1.35
ip route 213.148.102.0 255.255.255.0 172.16.1.35
no ip http server
!
!
!
line con 0
 stopbits 1
line vty 0 4
 password xxxxxx
 login
!
scheduler max-task-time 5000
end

0
 

Author Comment

by:IanH001
ID: 9826126
You were right.. i wasnt redist static route.. dont understsand why it wont ping though.
0
 

Author Comment

by:IanH001
ID: 9826137
So i'll give you the points because you got the question right :)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9826154
Can you re-visit the other open questions and close them out?
0
 

Author Comment

by:IanH001
ID: 9826196
Its not fully working yet :( :( So i dont want to close them in case i get an answer :(

Router 2 will still not ping the IP's that in in Router 1's table..

here is router2 config..

I goto shoot home. Will answer in the morning..

FOLBR1#show conf
Using 731 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname FOLBR1
!
enable password xxxx
!
ip subnet-zero
!
!
ip name-server 192.0.3.2
ip name-server 192.0.3.3
!
!
!
!
interface FastEthernet0/0
 ip address 192.0.10.254 255.255.255.0
 speed auto
 full-duplex
!
interface Ethernet1/0
 ip address 192.0.3.245 255.255.255.0
 half-duplex
!
router rip
 version 2
 redistribute static
 network 192.0.3.0
 network 192.0.10.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.0.3.254 200
ip http server
ip pim bidir-enable
!
!
banner login ^CWelcome to the FOLB Router.
^C
banner motd ^CThere is currently no MOTD set.
^C
!
line con 0
line aux 0
line vty 0 4
 password xxxxx
 login
!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9826260
Don't put redistribute static on Router 2, only on router 1
0
 

Author Comment

by:IanH001
ID: 9830132
Ok i did that but Router 2 will still not ping 193.193.102.130 or 213.148.63.222

0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now