Printed jobs retained in queue

I have a user printing to a LaserJet 2200DN. It is set up on Win2000 W/S SP3 on a  TCP/IP port. When the user prints the job is not deleted from the queue (it remains, listed as "Printed"). Consequently, next time the user starts their computer, when the Print Spooler service starts all the jobs are printed again.

Keep printed documents is not checked in the queue's properties.

If I set up a queue to a different printer this problem does not occur.

I have tried deleting the queue and port, restarted and re-installing and the problem still occurs.

Other workstations with a similar setup do not exhibit this problem.

Can anybody come up with any suggestions to troubleshoot this?

Thanks,

Leon...
LVL 1
leonstAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

grithansonCommented:
Take a look at this link and check all permissions, I have read someplace that if you don't have the everyone group added to security that the queues will not clear.

http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/WINDOWSXP/home/using/productdoc/en/print_security_permissions_groupsP.asp

I've also had tried deleting a printer and recreating it, and not solving problems.  Probably maintains the information in the registry and reuses it.
0
oBdACommented:
Those should help:

Network Bi-Directional Printing Support in Windows NT
http://support.microsoft.com/?kbid=132465

Print Jobs Stay in Queue After Printing
http://support.microsoft.com/?kbid=104817
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
leonstAuthor Commented:
Thanks oBdA,

Turning off Bi-di support on the port fixed the problem. Never knew that the default TCP/IP port/LPR didn't support that!

Thanks again,

Leon...
0
lauramayeCommented:
oBdA - thanks from me too!  I've had this problem for a while driving me nuts and thanks to you it's sorted in less than a minute - Brilliant!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.